Evolution freeze after connection lost

Bug #584906 reported by Aymeric on 2010-05-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evolution
Expired
Critical
evolution (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evolution

I am connected to a wireless AP.
Some time the link is lost, after that evolution is often freezen (95 pourcent).

Now I run evolution from console to kill it with ^C on console I have this only message.

I am connected to only account as OWA.

"$evolution

 Error syncing up the counts"

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: evolution 2.28.3-0ubuntu9
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Mon May 24 12:33:38 2010
ExecutablePath: /usr/bin/evolution
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_FR.utf8
SourcePackage: evolution

Aymeric (mulx) wrote :
Angel Abad (angelabad) on 2010-05-24
Changed in evolution:
importance: Undecided → Unknown
status: New → Unknown
Changed in evolution:
status: Unknown → New
Changed in evolution (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Angel Abad (angelabad) wrote :

In Gnome Bugzilla Vibha Yadav said:

Thanks for the bug report. Unfortunately, that stack trace is not very useful
 in determining the cause of the crash. Could you please install some debugging
packages [1] and reproduce the crash, if possible?

Once bug-buddy pops up, you can find the stacktrace in the "details", now
containing way more information. Please copy that stacktrace and paste it as a
comment here. Thanks!

[1] debugging packages for evolution, evolution-data-server, evolution-exchange
and gtkhtml,
 plus debugging packages for some basic GNOME libs. More details can be found
here:

    http://live.gnome.org/GettingTraces/DistroSpecificInstructions

Thanks!

Changed in evolution (Ubuntu):
status: Triaged → Incomplete
Angel Abad (angelabad) wrote :

In Gnome Bugzilla Vibha Yadav said:

This is the issue of hang, thus Bug buddy won't pop-up. If you can reproduce it while running under gdb, do "Ctrl-C" and then execute "thread apply all backtrace". This would help in getting better traces if you've already installed debug packages. (see http://live.gnome.org/GettingTraces/Details#gdb-not-yet-running for details about how to do this).

Aymeric (mulx) wrote :

I run evolution trough gdb and get back-trace when it crash.

See attachment.

Angel Abad (angelabad) wrote :

Thanks Aymeric, posted in Gnome Bugzilla.

Angel Abad (angelabad) wrote :

Hi, sorry Aimeryc but as you can see in Gnome Bugzilla, this trace is not sufficient. Please install gdb pacakges and check

http://live.gnome.org/GettingTraces/DistroSpecificInstructions

Thanks!

Changed in evolution (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Changed in evolution:
status: New → Incomplete
Aymeric (mulx) wrote :

Evolution re-crash, I have 3 backtrace the 2 first is not probably useful.
I not sure that I have all debugging symbol for the first bt.

Aymeric (mulx) wrote :
Aymeric (mulx) wrote :
Aymeric (mulx) on 2010-05-31
Changed in evolution (Ubuntu):
status: Incomplete → New
Changed in evolution (Ubuntu):
status: New → Triaged
Changed in evolution:
status: Incomplete → Invalid
Aymeric (mulx) wrote :

Hi !

Why changing for invalid !? I think that I post enough bt !

Nobody answer to say if it's enough or not and because I don't have my life to post bt I stop....

If you want more bt, just say !

Aymeric :-|

Angel Abad (angelabad) wrote :

Hi! Its marked as invalid automatically by Bug Watcher, please see:

https://bugzilla.gnome.org/show_bug.cgi?id=619511

From Gnome Bugzilla:

"The trace completely lacks any debug information"

So, please reopen it if you can provide more info.

Thanks!

Changed in evolution (Ubuntu):
status: Triaged → Incomplete
Aymeric (mulx) wrote :

Hi!
I provided 3 backtraces with debug package installed (a least in the two last).
Called "second bt" & "third bt"

Bye.

Changed in evolution:
importance: Unknown → Critical
status: Invalid → Expired
Jörg Frings-Fürst (jff-de) wrote :

10.04 is not longer supported
change status to invalid (see gnome-Bugs)

Changed in evolution (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.