Ubuntu

evolution-dev should depend on libgtkhtml3.14-dev and libebook1.2-dev

Reported by Ilya Barygin on 2009-10-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Medium
evolution (Debian)
Fix Released
Unknown
evolution (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Evolution-dev should depend on libgtkhtml3.14-dev because mail/em-format-html.h #includes gtkhtml/gtkhtml.h and gtkhtml/gtkhtml-embedded.h. This causes build failures in packages build-depending on evolution-dev: https://bugs.launchpad.net/ubuntu/+source/mail-notification/+bug/332767/comments/18

Package: evolution 2.28.0-0ubuntu3

Related branches

Ilya Barygin (randomaction) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Changed in evolution (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 2.28.0-0ubuntu4

---------------
evolution (2.28.0-0ubuntu4) karmic; urgency=low

  * debian/control:
    - evolution-dev depends on libgtkhtml since it's used there
      (lp: #443406)

 -- Sebastien Bacher <email address hidden> Tue, 06 Oct 2009 00:27:25 +0200

Changed in evolution (Ubuntu):
status: Fix Committed → Fix Released
Ilya Barygin (randomaction) wrote :

Sebastien, thank you for the quick fix. However, I think that evolution-plugin.pc.in should also be adjusted so that cflags propagate properly.

It also turns out that libebook/e-destination.h is included from composer/e-msg-composer.h, so evolution-dev should also depend on libebook1.2-dev. I'm attaching a debdiff with modifications to debian/control and evolution-plugin.pc.in.

I still can't compile mail-notification because there seems to be a problem with gtkhtml3.14 (libgtkhtml3.14-dev doesn't install gtkhtml-editor.h while it should).

Changed in evolution (Ubuntu):
status: Fix Released → Confirmed
summary: - evolution-dev should depend on libgtkhtml3.14-dev
+ evolution-dev should depend on libgtkhtml3.14-dev and libebook1.2-dev
Sebastien Bacher (seb128) wrote :

could you open a GNOME bug about the pc file change?

Ilya Barygin (randomaction) wrote :

Oh wait, there's no problem with gtkhtml3.14. evolution-dev should additionally depend on libgtkhtml-editor-dev. I'll redo the debdiff.

Changed in evolution (Ubuntu):
status: Confirmed → New
Ilya Barygin (randomaction) wrote :

With this patch to evolution-dev, mail-notification builds fine.

Changed in evolution (Ubuntu):
status: New → Confirmed
Changed in evolution (Ubuntu):
status: Confirmed → Triaged
Changed in evolution (Debian):
status: Unknown → New
tags: added: patch-forwarded-upstream
Changed in evolution:
importance: Unknown → Medium
status: Unknown → New
Changed in evolution (Debian):
status: New → Fix Released

Hello Customer

Go to that cocktail party with this, and be sure to catch people’s attention.
All watches are packed in plain boxes and shipped discretely. They are delivered fast and in excellent condition. In case of some damage, we will reship your order.

*******************************************************
As requested, I just want to verify that I have finally received my package, and I must say it was well worth the wait! Thanks for such a high quality product! I look forward to conducting business with you again in the future.
Give thanks
                     Pierre Rossi
*******************************************************

Click here ---> http://moung.ru

Jörg Frings-Fürst (jff-de) wrote :

bug from 2009. Version not more supported.
change status to invalid.

Changed in evolution (Ubuntu):
status: Triaged → Invalid
Changed in evolution:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.