evolutions webcal doesn't support ical calendars with password

Bug #125578 reported by Alexander Gabriel on 2007-07-12
4
Affects Status Importance Assigned to Milestone
evolution-webcal (CentOS)
New
Undecided
Unassigned
evolution-webcal (Debian)
New
Undecided
Unassigned
evolution-webcal (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evolution-webcal

You cannot subscribe to calendars wich are protected by a password. try icalx.com for example.
That makes it absolutely useless for private calendars. That's a serious flaw in my mind.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use? What do you do? What happens? What else would you expect?

Changed in evolution-webcal:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Alexander Gabriel (einalex) wrote :

- Ubuntu: Dapper Drake, Feisty Fawn, Gutsy Gibbon (doesn't matter it never worked. one of the first things I test whenever a new version comes out)

- I try to add the calendar in the appropriate dialog by selecting "on the web", chosing a name and copying the url into the text field. I click Ok. (I can select secure conenction or not it doesn't make any difference)

- The Window disappaers and an Error Message pops up reading "Error at >>myurl<<: Unauthorized", the calendar appears in the menu but is left empty. restarting evolution and going to the calendar tab produces the known error message.

- I'd like to be riddened of the error message and instead be able to see and edit my calendar with changes saved back to the web.

user2037 (user2037) wrote :

The same symptoms plague my attempts to subscribe to published Ical's using Evolution in Gutsy. It prompts for the password once but only if the calendar is added via "New" -> "Calendar" and a user is specified. Even after providing the username and password, and clicking the "Remember password" check-box, the calendar still does not appear to download the published events.

Restarting Evolution after subscribing does not resolve the issue. The first attempt to access the newly subscribed calendar produce an "Unauthorized" message.

user2037 (user2037) wrote :

It appears my username and password combination may have been incorrect. Unfortunately I can find no way to view, edit, or remote the previously remembered password.

Sebastien Bacher (seb128) wrote :

do you still consider it as a bug?

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in evolution-webcal:
status: Incomplete → Invalid

Hi there,

I am having the same error message previously described. I am wondering if you could help me with this bug. I am happy to provide any info required.

I am using Ubuntu 10.10 with Evolution 2.30.3

Thanks

Javier

Changed in evolution-webcal (Ubuntu):
status: Invalid → New

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Natty Narwhal. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in evolution-webcal (Ubuntu):
status: New → Incomplete
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody

Hi Mathieu,

Thanks for looking at this. Unfortunately, I am still having the same problem with Natty Narwhal.

Thanks
Javier

Javier,

Thanks for the testing. I thought it might have been fixed since there
were commits to correct calendar access with authentication.

Since it doesn't worry and it seems those didn't affect the issue
you're seeing, do you think you could open a bug about this issue on
the upstream bug tracker (GNOME)? You can find all the instructions on
how to report a bug in their bugzilla on the wiki at
https://wiki.ubuntu.com/Bugs/Upstream/GNOME .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers