evoultion show that it success to connect to exchange but it can't open the mail folders

Bug #606822 reported by Nadav on 2010-07-18
314
This bug affects 64 people
Affects Status Importance Assigned to Milestone
evolution-exchange (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: evolution

ubuntu 10.10

evoultion show that it success to connect to exchange but it can't open the mail folders

no visual error apear

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evolution 2.30.2-0ubuntu5
Uname: Linux 2.6.35-020635rc5-generic i686
Architecture: i386
Date: Sun Jul 18 09:55:17 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=he_IL.utf8
 SHELL=/bin/bash
SourcePackage: evolution

Nadav (nadavvin) wrote :
Pedro Villavicencio (pedro) wrote :

evolution-exchange issue then, reassigning, thanks.

affects: evolution (Ubuntu) → evolution-exchange (Ubuntu)
Alexander Usyskin (sanniu) wrote :

Tried Maverick on VM and have same problem.
The calendar work flawless at the same time...

Have run it from console: No suspicious output or error. Same with additional debug flags.
Does anyone have suggestions what can I do to debug this?

Nadav (nadavvin) wrote :

why this bug is duplicate of #617549? if this bug reported earlier than bug #617549

Alexander Usyskin (sanniu) wrote :

The https://bugs.launchpad.net/bugs/617549 have received much more attention then this one, have workaround posted, so in my opinion it's better to duplicate lesser bug to more worked on.

Lesley Harrington (laharrin) wrote :

I can connect to the folders by disabling the plugin "org-gnome-exchange-operations.eplug", but Evolution crashes when I perform any mail functions.

Sep 3 11:46:14 lesh-desktop kernel: [33618.949872] evolution[15666]: segfault at aaaaaab6 ip 00fe3d94 sp bfeb9c60 error 4 in libedataserver-1.2.so.13.0.1[fcb000+24000]

Sep 3 11:40:51 lesh-desktop kernel: [33295.920230] evolution[15552]: segfault at 3 ip 0480aa95 sp b28fbf20 error 4 in libcamelexchange.so[47ef000+55000]

Sebastian Martinez (tychocity) wrote :

same problem for me

Hospik (jmhospers) wrote :

I hoped this would have been fixed for the 10.10 RC but still not working for me. Is this going to be fixed for the final release of 10.10? It seems like a severe problem to me for many (office) users of Ubuntu.

hilaire (hilaire-drouineau) wrote :

Same problem here. The --disable-eplugin workaround allow me to read and send e-mail, however in that case, I am note able to subsribe to other user calendar (the option is not available anymore).

k-rock (i-pfennigstorf) wrote :

Same problem here. It doesn't matter if it's a clean install or an upgrade or if it's a 32bit or 64bit Installation of Maverick.
Quite strange, but --disable-eplugin solved this issue.

bdr529 (michael-severin) wrote :

Same problem here. The importance of this bug still is undecided. For those who need access to MS-Exchange, this is a KO for Maverick..

Chris Ladd (caladd) wrote :

Here is a temporary workaround that appears to help:

1. Open the broken plugin's (Exchange Operations) config file as root:

sudo vim /usr/lib/evolution/2.30/plugins/org-gnome-exchange-operations.eplug

2. Disable the plugin from being a 'system' plugin, so that it will show up in evolution's plugin config GUI. Edit the 3rd line in that file by changing the "system_plugin" attribute to "false". The entire line will look like this:

<e-plugin type="shlib" system_plugin="false" location="/usr/lib/evolution/2.30/plugins/liborg-gnome-exchange-operations" load-on-startup="true" id="org.gnome.evolution.plugin.exchange-operations" name="Exchange Operations">

3. Save the change and exit

4. Launch evolution and pull up the plugin config GUI under "Edit"->"Plugins".

5. Uncheck the box next to "Exchange Operations" to disable the broken plugin.

6. Restart Evolution.

Stefano Bagnatica (thepisu) wrote :

The workaround proposed by Chris worked for me. I am able to send and receive mails with Exchange. Thanks!

Falk (andreas-mockel) wrote :

The workaround worked for mails, but calendar stopped working instead.. At least for me?

rsclison (rsclison-gmail) wrote :

Same problem here. Launching Evolution with disable-eplugin seems to fix only a part of the problem. Refreshing folders dont works correctly and calling a Send/Receive causes a sticky popup window to appear.

Stefano Bagnatica (thepisu) wrote :

Don't launch Evolution with "disable-eplugin", instead apply the workaround proposed in comment #13.

rsclison (rsclison-gmail) wrote :

In fact tried the workaround and it dont works. Evolution is trying to open the exchange folder (exchange://...) and dont succeed.

Workaround is not working for me. I cannot see my exchange tasks or calendar. When I try to open email I get about a dozen "scanning for new mail" and/or "scanning for changed messages" tasks appearing across the bottom which never complete. New emails that I compose do not get delivered, dont go into the sent folder, or the outbox either. . Emails that I delete from the inbox never get deleted on the exchange server. Eventually the entire evolution window turns gray and just hangs.

Workarounds are a partial success, in that I can now see myinbox messages. BUT, after downloading messages I get a 'scanning for new messages (100% complete)' message which never disappears, messages can't be sent and hitting send/receive gives a box which never disappears...

Looks like it's back to XP for the time-being!

Chris Ladd (caladd) on 2010-10-12
Changed in evolution-exchange (Ubuntu):
status: New → Confirmed

Workaround frorm #13 does not work for me. I am able to see my inbox, but as with #19 it freezes beyond that with multiple hung tasks. Workaround of setting --disable-eplugin does seem to work, as I am able to access my inbox, calendar, and contacts (although I'm still seeing short 2-3 minute lockups, e.g. when deleting messages).

Andy (andy-rao) wrote :

None of the workarounds have fixed all my issues in talking to our corporate MS exchange server. I give up. I am going back to Mozilla Thunderbird. At least email/calendar works reliably. Evolution has been hit or miss for me for the past 3 years and I doubt I am going to be returning to it again.

LarryBoy327 (larryboy327) wrote :

Thunderbird, Lightning & DAVMail - Works like a champ!

Lyle Sharp (lyle-sharp) wrote :

Yeah, none of that works for any substantial operations. I've seen the Evolution developers weigh in on this and it is an Ubuntu 10.10 only thing. No help there. What do we have to do to get whomever builds the packages for Ubuntu to re-do Evolution-Exchange connector with an eye for eliminating this problem and get us an update? The same problem was reported during beta, isn't that when they should be addressed even if just to say it's a known issue?

I'm no Linux guru, but I've plenty of experience and I'm not afraid to roll my own from source tarballs. I've got about 7 hours on this and have just gotten far enough to figure out that rolling my own compiled Evolution is going to take me a few more days to achieve and doesn't solve anyone else's problems with the Ubuntu distributed package.Can we get some help here? Please?

Marco Boneff (neffscape) wrote :

I confirm the behavior on my today installed Maverick (stable) release... this thing really sucks and breaks overall good experience that this ubuntu release provide... at least for people trying to use ubuntu at workplace. The workarounds are partially working but the opening command for the built-in notification applet can't be manually changed and so the whole experience is compromised.

Please solve this problem as soon as possible and provide an application update!

jeffdizle (jeffdizle) wrote :

I did the solution provided by Chris and it somewhat works. Evolution is still as unstable as Charles Manson. If a fix is not built soon I might need to revert to 10.04 :(

I echo Marco's sentiments. Ubuntu is great but Evolution, particularly evolution-exchange gives it a black eye.

Someone needs to write a new PIM that works with Exchange since that is the email platform for 99% of corporate users. Evolution has always been problematic, It's no more stable today than it was 5 years ago and seems like something breaks in evolution-exchange with every release.

guisar (seiferth) wrote :

Just got an update to i386 (32 bit) on 15 Oct that appears to have fixed this issue- Evolution is back to itś relatively stable and functional self (thank goodness) or at least the OWA portion works again against our 2003 interface.

John Ching (jmyching) wrote :

Is this an update for Evolution or for Ubuntu 10.10? Where did you get the update? I just want to try one more thing before moving to Davmail+Thunderbird...

jeffdizle (jeffdizle) wrote :

I'm running 64bit and I didn't get a update, perhaps that fix was 32 bit only? I found a even better work around. Install virtualbox, in the virtualbox create a vm for ubuntu 8.04.4, install virtualbox tools, configure evolution to talk to exchange, and done. The reason this is better is that the ubuntu developers haven't created a stable version of evolution-exchange SINCE 8.04! but in the 8.04 vm its totally stable and reliable(more so than even microsoft outlook).

Ralf Stangneth (rstangneth) wrote :

The evolution-exchange plugin update fixes the issue for me, too.
It's on the proposed repository. But i had to kick my evolution profile for it to work. No problem for me, but maybe for others...

Matthew Stefanski (mss272) wrote :

The update in proposed and removing .evolution also worked for me.

The update in proposed seems to allow me to connect. I was still having the issue where many tasks would show up in the bottom that would prevent me from doing anything (reading any emails, looking in any folders, etc), but I discovered that uninstalling the tracker-miner-evolution package eliminated this problem as well. I don't know if that was a new addition in 10.10 or not, but I never saw the problem in 10.04.

John Ching (jmyching) wrote :

I also updated to the Proposed evolution-exchange plugin and there is some improvement. I can open the folders now and the email download seems to be normal. However, when I exit Evolution, it just hangs. I have to kill the process manually.

Where does one find the proposed update? And what does 'kicking my evolution profile' mean? I've certainly been tempted to kick the computer...

sim909 (srizzi) wrote :

For those who, like me, have a major problem "kicking" (aka deleting) the full .evolution directory, with several email accounts plus a large local collection of old emails (>5GB total), I have tried the following and so far all is good:

- once upgraded evo, delete from the evolution settings the exchange account, then close evolution
- open a terminal
- rm -rf ~/.evolution/exchange
- rm -rf ~/.evolution/mail/exchange
- if you want to go any deeper, search under ~/.evolution for references to your old exchange account
- reboot (maybe not necessary, but just to be on the safe side...)
- upon reboot open evolution and re-add your exchange account. All other accounts/settings should be there untouched.

All based on previous posts, thank you all

hagbard (emailjasonclark) wrote :

I thought I would add my observations :

Right after upgrading to Ubuntu 10.10, the Evolution bug became apparent. After trying several workarounds and after installing the proposed updates, the ability to read and send email was restored.

When Evolution starts applying filters and moving messages to folders, it hangs 100% of the time. If I shut down Evolution and restart it, I can read the new messages (all sitting in the inbox). New messages will sometimes filter into folders as they come in, sometimes they will hang the program.

Thanks,

Jason

John Ching (jmyching) wrote :

Okay I have tried everything suggested here, including updating with the Proposed evolution-exchange plugin, but my evolution is still basically unusable after spending 2 days on this. It does try to update my inbox folders but it hangs 99% of the time. I have to kill it because normal exiting does not work. i think i am giving up and will give Thunderbird+Lightning+Davmail a try. I hope I do not have to go back to Windows and Outlook again. Unfortunately for many of us with a day job, connectivity to exchange is still paramount, and until that's resolved replacing windows on the desktop is still a dream.

sim909 (srizzi) wrote :

@John Ching, & others considering thunderbird + davmail:
before switching to Thunderbird+Lightning+Davmail, have you also tried evolution + davmail?

I use it with an exchange 2007 server and it works, including calendar. I would assume davmail also works with a 2003 server, and if not it doesn't matter whether you use davmail in combination with evolution or thunderbird or any other imap client.

Now that the updated evolution has solved the issue (at least for me and a few others), I am again happily accessing two different exchange accounts, one on a 2007 server, though davmail, and one on a 2003 server, through the exchange plugin. No need to use outlook.

If you have already tried this, sorry for suggesting the obvious

John Ching (jmyching) wrote :

Thanks @sim909. I will give evolution+davmail a try.
BTW, with the Proposed evolution-exchange plugin installed, do i still need to run evolution with the --disable-eplugin parameter? I've also noticed that even after I've done rm -rf ~/.evolution, I still see the old exchange calendar in evolution which tells me perhaps i didn't clean up everything correctly?

I tried the proposed update and it didn't seem to change a thing.

...but, I'm happily using Thunderbird with Lightning and Davmail. Don't think I'll bother with evolution again unless it's updated properly. Glad I haven't had to resort to XP and Outlook.

John Ching (jmyching) wrote :

Even with evolution+davmail, I still cannot shutdown evolution cleanly. It hangs 75% of the time on exit and the evolution main screen turns gray and just sits there for hours. If I enable offline folder access, then everything just hangs with no apparent progress reported in the bottom status messages. My mailbox is only about 100MB and I am on a fast broadband connection so i cannot imagine the problem is due to my mailbox size.

So finally i was forced to download Thunderbird with the Lightning calendar plug in last night, and amazingly everything is working like a charm, including email, calendar and global address book. My entire mailbox was downloaded and synchronized in 20 min. i was this close to dual-boot xp and run outlook on my netbook and i am glad there was another option.

Then this morning I overheard our IT folks talking about upgrading to Exchange 2010, and i know i will have to deal with this all over again soon as Davmail does not support Exchange 2010 :(.

Darveson Wright (nortagemci) wrote :

Looking forward to the solution also. Last 4 years using another distro that begins with the 6th letter... Almost tempted to return to Gates Doors.. But Ubuntu worked and more help out there on interent. Hope this can be fixed and there are others not willing to got the dark-side so we can get fixes for issues like this and the nightmare of getting vmware installed. That was the final straw with the previous distros last upgrade. Please, please, Ubuntu developer fix this Evolution issue. I dont want to torture myself with W7. Also the preference in evolution hangs solid and yes sometimes exiting can seem to hang.

sim909 (srizzi) wrote :

@John Ching, very late response, sorry. No, I do not need to use the --disable-eplugin, all plugins are enabled, and I haven't had an issue since. Last night I did the same on a LinuxMint Julia box, I added the maverick-proposed repository, updated evolution, removed exchange account plus related directories under ~/.evolution and all is good.

So, as far as I am concerned, I can report full success on an ubuntu 10.10 64 bit box and on a LinuxMint 10RC 32 bit box.

James Hanks (jhanks1981) wrote :

This drives me crazy. My workplace will ONLY allow us to access our email via OWA or MS Exchange (and forbids forwarding). I want to use Evolution for its calendar, but to use its calendar you need a properly set up email. So basically this exchange bug is putting a wrench in my whole work flow.

Download full text (3.2 KiB)

>>> www.bestpharmaonline.com.ua

- There is no reason to feel depressed if you, like so many other men today, have hit the rough spot of your sexual life when you cannot seem to be performing as well as you used to do. Your agitation and frustration are easily understood, and still you should know that with the modern development of worldwide pharmacological industries it is but natural that there is bound to be a solution for your own needs when it comes down to solving your erectile dysfunction problems.

- We suggest you getting erectile dysfunction drugs from our online drugstore cheaply, easily and without much to-do. You will always be taken care of and attended to with extreme care, and you will have the possibility of choosing from a wide range of erectile dysfunction products to find a solution that will best suit your particular needs.

- The whole world puts great trust in those famous diamond shaped pills, and if you are not an exception we would like to revise some basic points that speak in favor of putting your male health in the hands of those magical tablets.
Firstly, there is no need for regular therapy – those blue pills have to be taken directly before the planned sexual contact, and extra convenience shines through when you come to realize that the pills will not start working unless sufficient sexual stimulation is provided.

- Secondly, this erectile dysfunction solution is known for its extremely low adverse side effects profile, which makes it available for all age groups of patients. Besides, it really does not matter how old you are when it goes about taking erectile dysfunction pills – just make sure that you do not overdose, and they will work for you at their best!

- Finally, those fabulous pills do not only provide you with stable erection that can be maintained for as long as you need it – they also help you to achieve unheard sensitivity during the sexual act as well as make your genitals look much more sizey!

- Think of all those benefits of taking erectile dysfunction pills and the effect you can produce on your loved one – and do not hesitate to make your order and / or refills right away!

--- > www.bestpharmaonline.com.ua < ---

 _V______C________L
 ___I_______I_______E
 _____A_______A_______V
 _______G_______L_______I
 _________R_______I_______T
 ___________A_______S_______R
 _____________________________A

   There should be always time for love in our crazy world! Our pilules work like aphrodisiacs, ready to refill your source of desire anytime. Give her love on the table and in cinema! Order and get powers to be crazy again.
-
 - - -
------...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.