evolution will not connect to exchange 2007 server

Bug #206346 reported by Matthew Tighe on 2008-03-25
250
This bug affects 38 people
Affects Status Importance Assigned to Milestone
evolution-exchange
Fix Released
Medium
Nominated for Trunk by Ryan
evolution-exchange (Ubuntu)
Low
Unassigned
Nominated for Intrepid by veruus
Nominated for Jaunty by veruus

Bug Description

Binary package hint: evolution-exchange

That's all she wrote. Company upgraded to E2K7 OWA last week and evolution stopped connecting to it.

Changed in evolution-exchange:
status: Unknown → New
Changed in evolution-exchange:
status: Unknown → Confirmed
gabr10 (gabriobarbieri) wrote :

I have the same problem. Evolution cannot connect to exchange 2007, it comes up with an error when authenticating

The Exchange server is not compatible with Exchange Connector.

The server is running Exchange 5.5. Exchange Connector
supports Microsoft Exchange 2000 and 2003 only.

Any fix known for this?

gabr10 (gabriobarbieri) wrote :

BTW I am using the Hardy Beta

Matthew Tighe (tighem) wrote :

I'm changing this to confirmed as the upstream got confirmed as well. Unfortunately I don't think there is a fix for this yet. I googled around when it first happened and the developers are aware of it and are working on it. It's apparently not an easy fix - Microsoft changed quite a bit in the OWA front-end.

I did find an experimental MAPI plugin that worked pretty well, but when my organization upgraded the back-end to 2007 it stopped working as well. Hopefully now that Microsoft is publishing their specs this will get easier.

Changed in evolution-exchange:
status: New → Confirmed
Kevin Fries (kevin-kevinfries) wrote :

This problem should be fixable if the request in 121217 is completed. Hoping it can make it into Intrepid Ibex.

There is now bug 260786 about syncing OpenChange to Ubuntu. Maybe it helps if it gets promoted a bit more..

Changed in evolution-exchange:
importance: Undecided → Low
status: Confirmed → Triaged
Mike Basinger (mike.basinger) wrote :

My university will not support MAPI for Exchange, at least not for non Outlook clients, so the evolution-mapi lib will not help me. Our Exchange admin suggest that Evolution should look to support EWF (sp??) for the Evolution<->Exchange 2007 connection,

Changed in evolution-exchange:
status: Confirmed → Fix Released
Changed in evolution-exchange:
status: Triaged → Fix Released
gabr10 (gabriobarbieri) wrote :

I am using the latest Ubuntu version with all the updates, and I don't see this fixed...

baeza (baeza) wrote :

Not solved in Jaunty and gnome 2.26

baeza (baeza) wrote :

Ooops! Solved if you install exchange-mapi !!! Not installed by default.

baeza (baeza) wrote :

After using for some days, Exchange-MAPI works only through MAPI in Exchange 2007. It does not work through OWA!!! If you need to connect using OWA with Exchange 2007 YOU CANNOT, neither through Exchange connector nor through Exchange-MAPI.

Please unmark this bug as 'Fixed' because Eschange-MAPI DOES NOT fix the problem, only gives another way to conect to Exchange that is not always possible to use (MAPI), as Exchange-MAPI configuration is very poor, only valid for local Exchange servers.

Ramesh Kumar (ramesh-mimit) wrote :

Please mark it un-fixed, baeza is right, this is not the fix, but the other way to connect to exchange server but this is not much reliable though my system freezes when i use Exchange-Mapi method. And secondly u cant use Exchange-Mapi when your exchange server is on different network or not on internet, or alternatively say, if i want to connect my exchange via internet through OWA i cant do that by Exchnage-MAPI.

Please consider this..

mwolfe38 (mwolfe38) wrote :

I am trying to connect to Exchange 2007 server using evolution and I get the same error mentioned,

  The Exchange server is not compatible with Exchange Connector.

  The server is running Exchange 5.5. Exchange Connector
  supports Microsoft Exchange 2000 and 2003 only.

mwolfe38 (mwolfe38) wrote :

Sorry, forgot to add that I am using Ubuntu Lucid 10.04 with evolution 2.28.3

Asv (asv-ivoss) wrote :

This bug should be marked un-fixed. Exchange 2007 with OWA is still broken.

Super (superpudu) on 2010-06-07
Changed in evolution-exchange (Ubuntu):
status: Fix Released → Incomplete
Stephen Green (stegreen) wrote :

I think this bug should be escalated to high importance. Not being able to connect to Exchange is one of the things that stops adoption of Ubuntu in the Enterprise.

Get this right and more people may use Ubuntu on the desktop!!

mykola.kutsyy (n-p-kutsyy) wrote :

+1 to high importance

Kris Douglas (krisdouglas) wrote :

I have to agree with the importance raise, we were on the brink of moving over to exchange and had to bail it all because of this lack of support for exchange. I swear it used to work fine but I am receiving:

"The server is running Exchange 5.5. Exchange Connector
supports Microsoft Exchange 2000 and 2003 only."

Shame really

Ranjan (ranjansimon) wrote :

+2 to high importance. very important component

Danyl Mikhailov (2laya5obak) wrote :

+1 for high importance.

Arun Raja (arunraja-g) wrote :

+1 for high importance

Manikantan T S (manikantants) wrote :

+1 for high importance

bpdaniels (bpdaniels) wrote :

This has been unresolved for over a year. How do you expect to gain market share when you don't give a migration path to mixed OS shops?

As some else stated over 1 year ago:

I think this bug should be escalated to high importance. Not being able to connect to Exchange is one of the things that stops adoption of Ubuntu in the Enterprise.

Get this right and more people may use Ubuntu on the desktop!!

Jeff (ahjefri) wrote :

I do not know why it took me 10 seconds to get to my company's email in Andriod (linux on smart phone), while I have been spending hours and days just to find a solution to this problem..

I reinstalled 7 again in my laptop, emails are critical as far as I am concern,, surprizingly it has low priority,,,

boozker (oscargodson) wrote :

Yeah, I work for local government for a major city, and we use OWA protocol on version 5.5 ( 2007 ) and it's also not working. Gives me the same:
The server is running Exchange 5.5. Exchange Connector
supports Microsoft Exchange 2000 and 2003 only.

This should be high importance. I mean, c'mon, "exchange support" is a little misleading when you only support a release that was 7 years ago.

No, MAPI doesn't work either.

I want to totally get rid of this ancient windows box here, but until this is fixed I basically have an entire desktop computer for exchange...

gabr10 (gabriobarbieri) wrote :

I just can' understand how it has been more than two years since I subscribed to this, and there is no fix for it?!? Is this how you want to get people to migrate from Windows to Linux?

komuta (komuta) wrote :

There is another solution than direct OWA support from email clients. You use an OWA to POP/IMAP/SMTP/LDAP/Caldav gateway in Java called DavMail (http://davmail.sourceforge.net). I think it works pretty well with recent OWA protocol, I'm using it everyday at work. The main drawback is that you have to start it everytime at login, but if you have many computer which need to connect to the OWA server, DavMail can be set up as a service.

Changed in evolution-exchange:
importance: Unknown → Medium
Ernest Lehmann (ernestlehmann) wrote :

Still broken in 10.10. This is why Linux is not running in the Enterprise. This bug has been documented since 2008. Exchange support (all versions, including 2010) has to be easy and transparent to the average person. Please fix this bug.

Change to Thunderbird and Davmail!

http://aguerrerotoro.wordpress.com/2010/01/21/conectarse-a-exchange-con-thunderbird-mediante-owa/
Conectarse a Exchange con Thunderbird mediante OWA con DavMail

    Este
 problema surgió ya que en la empresa donde trabajo migraron el correo a
 exchange 2007 y solo habilitaron OWA y exchange para la conexión,
después de mucho intentar un compañero dió con la solución y es
conectarse mediante DavMail
El DavMail se puede descargar aqui http://davmail.sourceforge.net/download.html
Es de aclarar que estos pasos sirven tanto para linux como para guindos.
Pasos para configuración:
=> Configuración de DavMail

OWA: https://correo.empresa.com/owa

Local POP : Deshabilitado

Local IMAP: 1143

Local SMTP: 1025

Local HTTP: 1080

Local LDAP: 1389
=> Lectura de Correo

Protocolo: IMAP

Tipo de Servidor: Servidor de correo IMAP

Nombre del Servidor: Localhost

Puerto: 1143

Nombre de usuario: dominio\nombre.usuario

Correo: <email address hidden>

Seguridad de la conexión: Ninguna

Usar identificación segura: No
=> Salida de Correo

-Protocolo: SMTP

-Nombre del Servidor: Localhost

-Puerto: 1025

-Nombre de usuario: dominio\nombre.usuario

-Usar identificación segura: No
=> Calendario

Pasos para crear calendario:

-Ir al Menu: Archivo => Nuevo => Calendario

-Ubicacion: En la red

-Formato: CalDav

-Lugar: http://localhost:<email address hidden>/calendar

-Nombre del calendario: Empresa

-Nombre de usuario: dominio\nombre.usuario
=> Libreta de direcciones

-Pasos para crear la libreta de direcciones:

-Ir al Menu: Herramientas => Libreta de direcciones

-Ir al Menu: Archivo => Nuevo => Directorio LDAP

-En Tab General:

-Nombre: Empresa

-Servidor: Localhost

-DN base: ou=people

-Puerto: 1389

-DN para inicio de sesión: dominio\nombre.usuario

-Usar conexión segura (SSL): No

-En Tab Avanzadas:

-Alcance: Subárbol

-Configuración de la libreta de direcciones:

-Ir al Menu: Herramientas => Opciones

-En Tab Redacción => Destinatario:

-Servidor de directorio: Empresa
Y listo !!!

--- El mar, 10/19/10, Ernest Lehmann <email address hidden> escribió:

De: Ernest Lehmann <email address hidden>
Asunto: [Bug 206346] Re: evolution will not connect to exchange 2007 server
A: <email address hidden>
Fecha: martes, 19 de octubre de 2010, 03:12 am

Still broken in 10.10. This is why Linux is not running in the
Enterprise. This bug has been documented since 2008. Exchange support
(all versions, including 2010) has to be easy and transparent to the
average person. Please fix this bug.

--
evolution will not connect to exchange 2007 server
https://bugs.launchpad.net/bugs/206346
You received this bug notification because you are a direct subscriber
of the bug.

Status in Evolution Exchange - Exchange Plugin for Exchange: Fix Released
Status in “evolution-exchange” package in Ubuntu: Incomplete

Bug description:
Binary package hint: evolution-exchange

That's all she wrote. Company upgraded to E2K7 OWA last week and evolution stopped connecting to it.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/evolution-exchange/+bug/206346/+subscribe

Josh Steiner (josh-vitriolix) wrote :

Running into this on ubuntu 10.10, any progress towards a fix?

baeza (baeza) wrote :

Nope. Developers are going to work (not yet I think) in EWS. This could help, as Exchange 2007 has EWS support (also Exchange 2010) and it is quite easy in OWA enabled servers to activate EWS for remote access.
I agree that this bug is unsolved, as MAPI access is not for remote access.
Davmail is not working in my case.
EWS will solve the problem of remote access for Exchange 2007 and 2010, so let's hope we get it soon!

Dcore (dekor) wrote :

Any further news on this issue?

Thiago Belem (thiago.belem) wrote :

Still waiting :/

tags: added: evolution exchange
slyride (slyride) wrote :

Hello,
I too would really like to see this fixed.
Thanks!

Don Lee (dlee2654) wrote :

ok guys, its now 2011, this bug was first reported in 2007, if a simple web browser can connect to OWA, evolution should certainly be able to. what is the deal here?

snewberg (snewberg) wrote :

I filed the bug, I can't fix it, I'm not a programmer.

Shane

On Jun 19, 2011, at 2:03 PM, Don Lee <email address hidden> wrote:

> ok guys, its now 2011, this bug was first reported in 2007, if a simple
> web browser can connect to OWA, evolution should certainly be able to.
> what is the deal here?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (162328).
> https://bugs.launchpad.net/bugs/206346
>
> Title:
> evolution will not connect to exchange 2007 server
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evolution-exchange/+bug/206346/+subscriptions

Repox (repox82) wrote :

This probably affects more users than stated above - from my point of view, converting to Ubuntu seems pointless if I can't even use Microsoft Exchange. This affects my workflow and I can't help feeling that not trying to fix this bug, is the same as not caring about your users.

kenorb (kenorb) wrote :

The same problem on Ubuntu 11.04
Duplicate?
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/740043

Found some old post as well from 2007:
http://www.linuxquestions.org/questions/linux-software-2/evolution-exchange-and-active-directory-authentication-582014/

URL: https://staffnet.example.com/OWA/
Works in the browser.
Tried: /exchange /owa /OWA
When typed wrong password, definitely there is different message, so it recognise the password.

CORRECT PASSWORD ERROR:
"

Could not configure Exchange account because
an unknown error occurred. Check the URL,
username and password, and try again.
"

WRONG PASSWORD ERROR:
"Could not authenticate to server.

This probably means that your server requires
you to specify the Windows domain name
as part of your username (eg, "DOMAIN\user").

Also, you may have typed your password incorrectly."

Versions:
evolution 2.32.2-0ubuntu7
evolution-exchange 2.32.2-0ubuntu3

kenorb (kenorb) wrote :

User-Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/534.30 (KHTML, like Gecko) Ubuntu/11.04 Chromium/12.0.742.112 Chrome/12.0.742.112 Safari/534.30
Outlook Web Access experience: Basic
User language: English (United Kingdom)
User time zone: (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
Exchange mailbox address: /o=The Research Department Limited/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=rwieczorek
Outlook Web Access host address: https://staffnet.example.com/owa
Outlook Web Access version: 8.2.176.2
Outlook Web Access host name: staffnet.example.com
Client Access server name: xxx
Exchange Client Access server .NET Framework version: 2.0.50727.4200
Client Access server operating system version: Microsoft Windows NT 6.0.6002 Service Pack 2
Client Access server operating system language: en-US
Microsoft Exchange Client Access server version: 8.2.176.0
Client Access server language: en-US
Client Access server time zone: GMT Standard Time
Microsoft Exchange Client Access server platform: 64bit
Mailbox server name: xxx
Mailbox server Microsoft Exchange version: 8.2.176.0
Other Microsoft Exchange server roles currently installed on the Client Access server: Mailbox, Hub Transport
Authentication type associated with this Outlook Web Access session: Basic
Public logon: No

Ben Young (blaher) wrote :

Same problem in Ubuntu 11.10. Using Gnome Shell 3.2.1, instead of Unity. I have been waiting almost three years, to switch from Mozilla Thunderbird to Evolution, so I can achieve tighter integration with Gnome, especially since 3.0 is now out. Yet, this is the only single problem that has been holding me from moving. I can not connect to my company's 2007 Exchange server with Evolutions, and I instead am required to use Thunderbird. I demand you fix this as a high priority. You're losing a huge market share, Exchange 2007 has been out for at least four years, you're behind times, and a massive amount of users (just a sample above) are getting frustrated by this error.

Sukesh (sukesh-nischal) wrote :

Ubuntu developers are useless at fixing bugs, this works perfectly under Fedora, install Fedora otherwise you will always be stuck in the dark ages!

@Sukesh: What version of Evolution are you running?

If this is working fine under Fedora, that suggests that Fedora is
shipping a newer version of Evolution than Ubuntu 11.10 which connects
to Exchange 2007 server. In other words, the fix would have been made
upstream, and Ubuntu 12.04 will likely offer the updated Evolution
packages.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.