Evolution address book inaccessible without killing one time "e-addressbook-factory"

Bug #1010349 reported by Joseph Maillardet on 2012-06-08
396
This bug affects 31 people
Affects Status Importance Assigned to Milestone
evolution-data-server (Ubuntu)
Low
Unassigned

Bug Description

After a fresh boot of my system, Evolution is not able to access my work address book on LDAP and my personnal address book on Google.

With Google address book I get the error "Cannot open book: Source already loaded!"

After shutting down Evolution and killing by hand : /usr/lib/evolution/e-addressbook-factory. I relaunch Evolution and everything go right.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: evolution-data-server 3.2.3-0ubuntu7
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
Date: Fri Jun 8 09:07:18 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: evolution-data-server
UpgradeStatus: No upgrade log present (probably fresh install)

Joseph Maillardet (jokx) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in evolution-data-server (Ubuntu):
importance: Undecided → Low
Joseph Maillardet (jokx) wrote :

This bug doesn't affect Fedora or Debian Wheezy. It's definitly not a Gnome bug. The problem came from Ubuntu horrible Gnome 3.2 / 3.4 mix. Do not integrate full Gnome 3.4 (who's a complete and integrated desktop) is juste unbeleavable :-/

Gnome 3 lovers is realy sade with Ubuntu.

Sebastien Bacher (seb128) wrote :

you can claim this bug doesn't affect $distro, you can even claim that it doesn't Ubuntu precise either since you are the only one to see it, that's nothing due to the mix of versions and that's not an ubuntu bug since we don't patch evolution-data-server over Debian

I have the same problem and could resolve it by manually killing the e-addressbook...

int13 (int13) wrote :

same bug here : ubuntu 12.04

Tibor Farkas (farkas-carpatian) wrote :

ubtuntu 12.04 bug me too... :(

Nils (nils-fishtown) wrote :

Same problem here in12.04, today also this stopped working:
After shutting down Evolution and killing by hand : /usr/lib/evolution/e-addressbook-factory. I relaunch Evolution and everything go right.

The addressbook is visible again, but not when sending an email and want to look up aan email adres or use auto add on.

Nigel Pegram (ndpegram) wrote :

Same issue in 12.04, new install.

For me, e-addressbook-factory was not running after I quit evolution.

I re-started evolution, killed e-addressbook-factory while evolution was running and then it appeared after I exited evolution.

At the moment, all is working as expected.

Nigel

Bronkhorst R.B. (rbbronkhorst) wrote :

Same issue here since a few months (12.04).
Does anyone know if Canonical is going to work on this problem or is this part of the transition to Mozilla & leaving Evolution?

For me, Mozilla does not the job like Evolution does.

Rob

tornadof3 (p-m-reid) wrote :

I'm glad someone else has this same problem. Thought it was just me. It is very frustrating. Evolution is much better than Thunderbird, would be a shame to be *forced* to move.

Evolution's excellent addressbook hasn't been working well for more than a year now, starting with 11.04. The 'crowd' must have moved over to Thunderbird, or what else could be the reason for such a low priority for this annoying bug? Any Android user would love to have this working!

Currently, I'm using Ubuntu 12.04 (with evolution 3.2.3). There are two ways to get a Google addressbook working *for one session only*:

1. Start evolution, kill e-addressbook-factory, (re)open contacts (see above)
2. Run 'seahorse' from a terminal, delete the passwd for google://<youraddress>%<email address hidden>; start evolution, open addressbook, retype passwd. (This works for calendar trouble too: delete caldav://...... instead.)

Unfortunately, this solution only works for one session; upon re-invocation the whole misery starts again.

Could this bug be related to https://bugs.launchpad.net/ubuntu/+source/libgdata/+bug/755043 ?
Is there a way to increase to priority of this bug?

Sometimes, 'explaining' something makes you wonder about what you're explaining. So, I asked myself: Why does seahorse have this <myname>%<email address hidden>? Should that domain name be there twice?

So, I used seahorse to edit google://<myname>%<email address hidden> into google://<myname>@gmail.com

Now, I can get to my addressbook right after I start evolution!!! (I do not have the time now to reboot, to re-test etc, but I'll be back to report progress (or fall-back) in a few days.)

I see the same issue when using Evolution 3.2.3 on Ubuntu 12.04 with the MAPI connector to an Exchange server.

Disappointment! The problem is back after a reboot. The edited URL in seahorse (google://<myname>@gmail.com) is NOT the solution...

sektor (sektor-1) wrote :

I am a bit surprised to see 'low' as 'importance' for this bug. As far as I understood Ubtuntu 12.04 LTS users are not able to sync their evolution contacts with google on a permanent basis - like me. This is preventing Ubuntu LTS users to use Ubuntu LTS as real world workstation without additional fallbacks like M$. LTS versions are supposed to work for people and companies that need a resilient system, right? Please consider that evolution was the preferred solution before Ubuntu 12.04. I think the importance of this bug is not representing the real impact for Ubuntu LTS users therefore.

I am not able to code the things which are necessary to solve this bug but I am absolutly happy to support with whatever I can do to solve this issue. Please give me guidance on how to support you!

Thank you.

John Bester (john-bester) wrote :

I have had this problem for some time using Thunderbird. I have a "Google" addressbook that I cannot remember creating. After reading these posts (especially killing e-addressbook-factory) I seemed to have solved it for me (a Thunderbird user). The "Google" address book dates back to the time I used evolution. So here is what I understand of the problem:

The "Google" address book would always be empty (after opening Thunderbird and getting the message). But I could not delete it. After killing e-addressbook-factory and re-opening Thunderbird, the message was gone and the "Google" address book was filled. I could still not delete it though, because Thunderbird does not allow deleting a gnome-contacts folder (short version of message after trying to delete it).

Even though I am not using evolution any more and have uninstalled it, "evolution-data-server" (package) was still installed and the "gnome-contacts" depends on it. However, I have always used Thunderbird for my contacts, so uninstalling evolution-data-server together with gnome-contacts would not seem to affect me.

So how do I sync contacts with Google? Simple - I use Zindus Thunderbird plugin (and have been since I installed Thunderbird). This allows you to pick an addressbook to sync - in my case "Personal Address Book". So I really do not need to have a "Google" address book in any case.

Dennis Baudys (thecondordb) wrote :

I can also confirm the problem with Evolution not being able to show the Google address book (contacts) right from the start. The workaround of killing the /usr/lib/evolution/e-addressbook-factory while Evolution is running works. However this cannot be a permanent solution!

I'm using Ubuntu 12.04.2 LTS x86_64 with Linux 3.2.0-37-generic # 58-Ubuntu SMP and Evolution 3.2.3-0ubuntu6.

Does anybody know, whether the problem would be solved if I was using Ubuntu 12.10 together with an Evolution version that is more recent than 3.2.3 (if available)?

Thank you very much!

pascal (pascal-pascallen) wrote :

Workaround:
When logging in call a script which kills e-addressbook-factory

#!/bin/bash
sleep 120
killall e-addressbook-factory
/usr/bin/evolution
exit 0

chmod +x /foo/bar/e-addressbook-factory

Make a link in Unity: Upright gear / upstart --> create a link to your upstartscript

If you wish to hook in some call to "ethernet|wifi|3g up" && "ping gmail" or something. Help yourself.

@Dennis
using a newer Version of Evolution did help myself. Why is at Ubuntu 12.04 no Update cause this Problem?

79D970 (littletree2010) wrote :

I am using 12.04 and evolution 3.2.3 and am running into this prblem since a few weeks. Has that ever been fixed?

Raphael Mankin (raph-p) wrote :

I have two machines both running 12.04 with Evolution 3.2.3. One has this bug the other does not.

I start my sessions without evolution and then start it by hand later. On the 'bad' machine I have found no way of starting gnome without e-addressbook-factory running.. Again, the 'good' machine can do this.

information type: Public → Public Security
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers