Comment 21 for bug 778638

Glad to find an answer for this thumbnailer issue. I've just tested the proposed packages and they also work for me.

It's worth mentioning that you need to install both evince and evince-common packages from proposed:

 aptitude install evince/natty-proposed evince-common/natty-proposed