Ubuntu

Incompatibilty with Windows font Deja Vu Sans 9.9990234375 makes evince menu unreadable

Reported by Olivier Mengué on 2010-09-05
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Undecided
Unassigned
pango1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: evince

When the font path contains a directory with a (reported invalid) 'DejaVu Sans' font, the menu and dialog boxes are unreadable (boxes appear everywhere instead of letters LANG=fr_FR.utf8).
The font path may contain such a font in a dual boot system when the user has prepended a Windows "Fonts" directory to the font path (by linking it to ~/.fonts) and the DejaVu font is installed there (probably by OpenOffice.org 3.2 for Windows).

When the Windows Fonts directory is removed from the font path, evince is ok.

No such problem with other applications (Firefox, Gvim, OOo, gedit, Inkscape, Gimp).

Expected behavior
-----------------------
If the font is really invalid, it should be skipped and a valid one (which in my case in available in the standard font path) should be loaded instead.

Diagnostics
--------------
Here is the evince stderr output:

(evince:11361): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'DejaVu Sans 9.9990234375'

(evince:11361): Pango-WARNING **: font_face status is: out of memory

(evince:11361): Pango-WARNING **: scaled_font status is: out of memory

(evince:11361): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='DejaVu Sans 9.9990234375', text='●'

(evince:11361): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'DejaVu Sans 9.9990234375'

(evince:11361): Pango-WARNING **: font_face status is: <unknown error status>

(evince:11361): Pango-WARNING **: scaled_font status is: out of memory

Environment details
-------------------------

This is a dual boot system with Windows 7.
I have my Windows font directory linked in my environment to make all Windows fonts available in the Ubuntu environment:
   ln -s /media/sda1/Windows/Fonts $HOME/.fonts
   ls $HOME/.fonts/Deja*
Note that the file time AND file size of the fonts on the Ubuntu system are exactly the same as on Windows. However the content differ (checked with 'sum').

$ ls -l /media/win7/Windows/Fonts/Deja*
-rwxrwx--- 2 root plugdev 524056 2009-08-27 16:26 DejaVuSans-BoldOblique.ttf
-rwxrwx--- 2 root plugdev 573136 2009-08-27 16:26 DejaVuSans-Bold.ttf
-rwxrwx--- 2 root plugdev 493196 2009-08-27 16:26 DejaVuSansCondensed-BoldOblique.ttf
-rwxrwx--- 2 root plugdev 534464 2009-08-27 16:26 DejaVuSansCondensed-Bold.ttf
-rwxrwx--- 2 root plugdev 488440 2009-08-27 16:26 DejaVuSansCondensed-Oblique.ttf
-rwxrwx--- 2 root plugdev 544636 2009-08-27 16:26 DejaVuSansCondensed.ttf
-rwxrwx--- 2 root plugdev 329412 2009-08-27 16:26 DejaVuSans-ExtraLight.ttf
-rwxrwx--- 2 root plugdev 223408 2009-08-27 16:26 DejaVuSansMono-BoldOblique.ttf
-rwxrwx--- 2 root plugdev 301928 2009-08-27 16:26 DejaVuSansMono-Bold.ttf
-rwxrwx--- 2 root plugdev 229284 2009-08-27 16:26 DejaVuSansMono-Oblique.ttf
-rwxrwx--- 2 root plugdev 321524 2009-08-27 16:26 DejaVuSansMono.ttf
-rwxrwx--- 2 root plugdev 523804 2009-08-27 16:26 DejaVuSans-Oblique.ttf
-rwxrwx--- 2 root plugdev 622280 2009-08-27 16:26 DejaVuSans.ttf
-rwxrwx--- 2 root plugdev 294244 2009-08-27 16:26 DejaVuSerif-BoldItalic.ttf
-rwxrwx--- 2 root plugdev 306532 2009-08-27 16:26 DejaVuSerif-Bold.ttf
-rwxrwx--- 2 root plugdev 293472 2009-08-27 16:26 DejaVuSerifCondensed-BoldItalic.ttf
-rwxrwx--- 2 root plugdev 282092 2009-08-27 16:26 DejaVuSerifCondensed-Bold.ttf
-rwxrwx--- 2 root plugdev 301244 2009-08-27 16:26 DejaVuSerifCondensed-Italic.ttf
-rwxrwx--- 2 root plugdev 295840 2009-08-27 16:26 DejaVuSerifCondensed.ttf
-rwxrwx--- 2 root plugdev 301828 2009-08-27 16:26 DejaVuSerif-Italic.ttf
-rwxrwx--- 2 root plugdev 328908 2009-08-27 16:26 DejaVuSerif.ttf

$ ls -l /usr/share/fonts/truetype/ttf-dejavu/
total 7952
-rw-r--r-- 1 root root 524056 2009-08-27 16:26 DejaVuSans-BoldOblique.ttf
-rw-r--r-- 1 root root 573136 2009-08-27 16:26 DejaVuSans-Bold.ttf
-rw-r--r-- 1 root root 493196 2009-08-27 16:26 DejaVuSansCondensed-BoldOblique.ttf
-rw-r--r-- 1 root root 534464 2009-08-27 16:26 DejaVuSansCondensed-Bold.ttf
-rw-r--r-- 1 root root 488440 2009-08-27 16:26 DejaVuSansCondensed-Oblique.ttf
-rw-r--r-- 1 root root 544636 2009-08-27 16:26 DejaVuSansCondensed.ttf
-rw-r--r-- 1 root root 329408 2009-08-27 16:26 DejaVuSans-ExtraLight.ttf
-rw-r--r-- 1 root root 223408 2009-08-27 16:26 DejaVuSansMono-BoldOblique.ttf
-rw-r--r-- 1 root root 301928 2009-08-27 16:26 DejaVuSansMono-Bold.ttf
-rw-r--r-- 1 root root 229284 2009-08-27 16:26 DejaVuSansMono-Oblique.ttf
-rw-r--r-- 1 root root 321524 2009-08-27 16:26 DejaVuSansMono.ttf
-rw-r--r-- 1 root root 523804 2009-08-27 16:26 DejaVuSans-Oblique.ttf
-rw-r--r-- 1 root root 622280 2009-08-27 16:26 DejaVuSans.ttf
-rw-r--r-- 1 root root 294244 2009-08-27 16:26 DejaVuSerif-BoldItalic.ttf
-rw-r--r-- 1 root root 306532 2009-08-27 16:26 DejaVuSerif-Bold.ttf
-rw-r--r-- 1 root root 293472 2009-08-27 16:26 DejaVuSerifCondensed-BoldItalic.ttf
-rw-r--r-- 1 root root 282092 2009-08-27 16:26 DejaVuSerifCondensed-Bold.ttf
-rw-r--r-- 1 root root 301244 2009-08-27 16:26 DejaVuSerifCondensed-Italic.ttf
-rw-r--r-- 1 root root 295840 2009-08-27 16:26 DejaVuSerifCondensed.ttf
-rw-r--r-- 1 root root 301828 2009-08-27 16:26 DejaVuSerif-Italic.ttf
-rw-r--r-- 1 root root 328908 2009-08-27 16:26 DejaVuSerif.ttf

The fonts have probably been installed in my Windows environment by OpenOffice.org 3.2 (but I'm not sure).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: evince 2.30.3-0ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.32-24.42-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
Date: Sun Sep 5 21:14:26 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: evince

Olivier Mengué (dolmen1) wrote :
Olivier Mengué (dolmen1) wrote :

libpango1.0-0 is version 1.28.0-0ubuntu2

Note that this is not a new bug. I already had this bug for more than 2 years with the previous releases of Ubuntu and on a different PC (with similar setup : Windows Fonts dir in font path).

Gary M (garym) on 2011-01-03
tags: added: maverick
Vincent Law (vincentlaw) wrote :

Any news concerning this really annoying bug ?
Opened since more than 5 months and it's not assigned to anyone yet. Nothing more concerning importance evaluation ...

Maybe we're only three (the subscribers) having a dual boot and sharing fonts between OSes
No feedback from pango developers ? Do they got this bug reported ?

Did i say that it's annoying not being able to understand menus ?

Olivier Mengué (dolmen) wrote :

Vincent confirmed the problem.

Changed in pango1.0 (Ubuntu):
status: New → Confirmed
taj (othertaj) wrote :

Ubuntu Lucid 10.04 LTS, upgraded from Dapper

Pango problem every now and then also halts at system boot just before the graphic screen appears. Only restart helps. This has happened 3 or 4 times at irregular intervals.
Message on the screen could not be found in logs, so unfortunately this info is not extensive:

message:
unknown>:279 Pango-WARNING **: scaled font status is: out-of-memory
unknown>:279 Pango-WARNING **: shaping failure, expect ugly output

I also saw that the Deja Vu Sans font was mentioned as the offending font, that is why I thought that this thread was the most appropriate.

Reboot and normal login gave the same problem.

The only (!) workaround I could find was:
reboot (ctrl-alt-del)
start in system recovery mode. Choose normal start. Login. Type startx
Next reboot all works fine, that is why I could not exactly repeat the message.

This is not the first problem I have with pango in combination with Windows fonts. I also had squares instead of text at startup, which only disappeared after long waiting (see http://<email address hidden>/msg2656512.html). I think that pango needs some serious attention. Both problems could put people off who are new to ubuntu. Indeed it is really annoying.

Olivier Mengué (dolmen) wrote :

Hi taj,

How are your Windows fonts installed on your system?

Vincent Law (vincentlaw) wrote :

Hi Olivier,

Your question made me think about something :
I have a dual boot, the windows partition is mounted under linux
Then to access to Windows fonts I simply have made an "ln -s" from Windows/Fonts/* directory into ~/.fonts followed by an fc-cache to update cached informations
Everything works with it, I can use these fonts within my desktop apparence so as into OOo

Just before writing this comment I put a real copy of a ttf font (the one I'm using in most of the elements of my current theme) into my ~/.fonts and then, surprise !
Evince menus are now readable
So it seems that pango is not able to follow symlinks.
Really annoying in my case because my homedir is mounted from an NFS share. I simply cannot think about copying 350Mo of fonts into my homedir.

Vincenzoml (vincenzoml) wrote :

I don't have windows at all but I have a bug with the very same symptoms: boxes instead of letters in evince. This came after a recent upgrade to natty. I don't know where to look at, but I have some ms fonts installed (I think this comes from some restricted-extras package).

Vincenzoml (vincenzoml) wrote :

And this is what I see in the terminal when I launch evince

:~$ evince

(evince:4342): Pango-WARNING **: /usr/lib/i386-linux-gnu/pango/1.6.0/modules/pango-basic-fc.so: mappatura del segmento dall'oggetto condiviso non riuscita: Permesso negato

(evince:4342): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'

(evince:4342): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'

Vincenzoml (vincenzoml) wrote :

Finally, I don't have the above mentioned link in my home directory at all, and unistalling the packages ttf-dejavu-core and ttf-dejavu-extra does not help. Let me know if I should file a separate bug.

MarcoA (marcoalici) on 2011-04-20
Changed in evince (Ubuntu):
status: New → Confirmed
Andrea B. (seagull-) wrote :

I've the exactly the same problem on Lucid Lynx 10.04 64-bit since twenty days.
I've tried to reinstall the packages ttf-dejavu-core and ttf-dejavu-extra with no results.

Andrea B. (seagull-) on 2011-08-30
description: updated
Riccardo G (thejoker-rico) wrote :

I have the same problem! There's no solution??

Shinoda (technolust) wrote :

For organisational and backup purposes, I put my fonts folder in an internal storage HDD (/media/storage/fonts), separate from the system HDD, and made a symlink to it in /usr/share. So far, everything works fine except for Evince, which displays rectangles instead of text in its GUI, as mentioned by others.

Does anyone know why this hasn't been fixed yet, more than 2 years after the original bug report?

Using Ubuntu 12.10 64-bit with Evince 3.6.0.

Thanks in advance.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers