evince not open

Bug #571725 reported by Petterson Faria
122
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
High
evince (Fedora)
Fix Released
High
evince (Ubuntu)
Medium
Didier Roche
Lucid
Medium
Didier Roche

Bug Description

Binary package hint: evince

$uname -a
Linux learn 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

$evince --version
Visualizador de Documentos do GNOME 2.30.1

My package is "Evince 2.30.1-0ubuntu1"

$evince
** (evince:4682): WARNING **: Error creating last_settings file: Erro ao abrir arquivo "/home/ppu/.gnome2/evince/last_settings": Arquivo ou diretório não encontrado
Falha de segmentação

I tried "dpkg-reconfigure", "aptitude purge/install", "aptitude reconfigure", etc
But crash continue.

-----------
fix in package pushed -proposed:

 evince (2.30.1-0ubuntu2) lucid-proposed; urgency=low
 .
   * add debian/patches/02_fix_dot_dir_creation.patch:
     fix dot dir creation when launching evince directly (LP: #571725)
 .
 evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low
 .
   * New upstream release:
     Bug fixes:
     - Make inverted colors mode work in presentation mode too
       (#614693, Carlos Garcia Campos)
     - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
     - Fix loading of local documents when uri contains a page
       destination (#616515, Carlos Garcia Campos)
     - Take default settings from last document opened. Fixes
       regression caused by migration to gio metadata (#606090, Carlos
       Garcia Campos) (LP: #544639, #503372)
     - Update icons to match gnome-icon-theme appearance (#614747,
       Hylke Bons, Carlos Garcia Campos)
     - Make sure there's a new valid page range before updating caches
       (fdo#27599, Carlos Garcia Campos)
     - Update FSF address everywhere (#514607, Arun Persaud)
     - Fix loading of compressed password-protected documents (#613959,
       Carlos Garcia Campos)
     - Close previewer window with control + w (#612972, Carlos Garcia
       Campos)
     - Fix keybindings in previewer window (#612972, Carlos Garcia
       Campos)
     Translation updates

Test case:
install new evince version from -proposed (2.30.1-0ubuntu2), mv ~/.gnome2/evince ~/.gnome2/evince_bak, open a pdf, close it, reopen it.

Revision history for this message
Lai Jiang (laijiang) wrote :

I've also got this problem but you can create that directory manually to solve the problem. However I used to embed evince in chrome by mozplugger to view pdf files, after this update it is not working anymore.

Revision history for this message
Petterson Faria (contato-pettersonfaria) wrote :

Thanks, it works!

But, I saw this, causa I tried by console. If a user try only by click?
Is it a bug? The install my have to create this folder?

I'm writing for help make ubuntu better.

But "mkdir evince" solved the problem.
Thanks again.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

I don't see this crash with that version, even if i delete the last_settings file, is that only reproducible with the proposed version? could you downgrade and test?Thanks.

Changed in evince (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Pedro Villavicencio (pedro) wrote :

the file is not created on start with 2.30.0, this is a regression on the proposed package.

Changed in evince (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
status: Incomplete → Triaged
Revision history for this message
PatrickSCarrroll (patrickscarroll-hotmail) wrote :

I got the same error when run from the command line. I installed the RC of Lucid, then did the latest updates. Opening a PDF file from the desktop gives no error. Running evince from the shell (just type "evince") gives the error...
** (evince:2737): WARNING **: Error creating last_settings file: Error opening file '/home/patrick/.gnome2/evince/last_settings': No such file or directory

Segmentation fault

Revision history for this message
PatrickSCarrroll (patrickscarroll-hotmail) wrote :

Making the "~/.gnome2/evince" folder fixes the problem at least.

Changed in evince (Ubuntu):
status: Triaged → Confirmed
Martin Pitt (pitti)
tags: added: regression-proposed
Revision history for this message
Didier Roche (didrocks) wrote :
description: updated
description: updated
Revision history for this message
Bruno Martins (skorzen) wrote :

As already said before, 'mkdir /home/username/.gnome2/evince' solves the problem.

Revision history for this message
Didier Roche (didrocks) wrote :

Sure Bruno, but not all users will read the doc for this. Hence the new proposed package which don't require user to do that, it will be good to test it once accepted.

Changed in evince (Ubuntu Lucid):
status: Confirmed → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

I accepted 2.30.1-0ubuntu2 into lucid-proposed which fixes that regression. Since it only affected lucid-proposed, I close this bug now. Thank you!

Changed in evince (Ubuntu Lucid):
status: Triaged → Fix Released
Changed in evince:
status: Unknown → Fix Released
Revision history for this message
Stefano Angeleri (weltall) wrote :

works well

Revision history for this message
Richard (g-launchpad-mcgillivary-org) wrote :

Still seeing problem after upgrading evince (* removing last_settings file before testing)

>evince --version
GNOME Document Viewer 2.30.1

strace :-

clock_gettime(CLOCK_MONOTONIC, {71762, 431061467}) = 0
access("/home", F_OK) = 0
stat64("/home", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
access("/home/rmcgilli", F_OK) = 0
stat64("/home/rmcgilli", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
access("/home/rmcgilli/.gnome2", F_OK) = 0
stat64("/home/rmcgilli/.gnome2", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
access("/home/rmcgilli/.gnome2/evince", F_OK) = 0
stat64("/home/rmcgilli/.gnome2/evince", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
lstat64("/home/rmcgilli/.gnome2/evince/last_settings", 0xbfdcb8ec) = -1 ENOENT (No such file or directory)
open("/home/rmcgilli/.gnome2/evince/last_settings", O_WRONLY|O_CREAT|O_EXCL|O_LARGEFILE, 0666) = -1 EACCES (Permission denied)
write(2, "\n** (evince:18809): WARNING **: "..., 152
** (evince:18809): WARNING **: Error creating last_settings file: Error opening file '/home/rmcgilli/.gnome2/evince/last_settings': Permission denied

Home dir is encrypted so is on following filesystem type
     gvfs-fuse-daemon on /export2/home/rmcgilli/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=rmcgilli)

Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 571725] Re: evince not open

Hello Richard,

Richard [2010-05-01 8:34 -0000]:
> open("/home/rmcgilli/.gnome2/evince/last_settings", O_WRONLY|O_CREAT|O_EXCL|O_LARGEFILE, 0666) = -1 EACCES (Permission denied)

That looks like a local problem, though. What's the output of

  ls -ld /home/rmcgilli/.gnome2/evince/last_settings

?

> Home dir is encrypted so is on following filesystem type

This shouldn't make a difference; encryption should be totally
transparent wrt. file names and access permissions.

> gvfs-fuse-daemon on /export2/home/rmcgilli/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=rmcgilli)

This is unrelated.

Revision history for this message
Richard (g-launchpad-mcgillivary-org) wrote :

Here's a transcript of a session showing problem , at the end after I create the last_settings file manually evince starts up

So it's not a major issue for me as I can manually create the file to get evince running.

Note, I originally reported this under Bug 572028 which was the same issue with last_settings file reported by someone else; but was redirected to this bug.

rmcgilli@trawler:~$ id
uid=1000(rmcgilli) gid=1000(rmcgilli) groups=4(adm),20(dialout),24(cdrom),46(plugdev),106(lpadmin),121(admin),122(sambashare),1000(rmcgilli)

rmcgilli@trawler:~$ ls -ld /home/rmcgilli/.gnome2/evince/last_settings
ls: cannot access /home/rmcgilli/.gnome2/evince/last_settings: No such file or directory

rmcgilli@trawler:~$ ls -ld /home/rmcgilli/.gnome2/evince/
drwx------ 2 rmcgilli rmcgilli 4096 2010-05-03 08:26 /home/rmcgilli/.gnome2/evince/

rmcgilli@trawler:~$ evince

(evince:7957): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

(evince:7957): Gtk-WARNING **: Attempting to read the recently used resources file at `/home/rmcgilli/.recently-used.xbel', but the parser failed: Failed to open file '/home/rmcgilli/.recently-used.xbel': Permission denied.

** (evince:7957): WARNING **: Error creating last_settings file: Error opening file '/home/rmcgilli/.gnome2/evince/last_settings': Permission denied

Segmentation fault

rmcgilli@trawler:~$ touch /home/rmcgilli/.gnome2/evince/last_settings

rmcgilli@trawler:~$ evince

(evince:7959): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

rmcgilli@trawler:~$ ls -ld /home/rmcgilli/.gnome2/evince/last_settings
-rw-r--r-- 1 rmcgilli rmcgilli 0 2010-05-03 08:27 /home/rmcgilli/.gnome2/evince/last_settings

(evince:7959): Gtk-WARNING **: Attempting to read the recently used resources file at `/home/rmcgilli/.recently-used.xbel', but the parser failed: Failed to open file '/home/rmcgilli/.recently-used.xbel': Permission denied.

<Evince is running here>

Revision history for this message
Didier Roche (didrocks) wrote :

@Richard: apt-cache policy evince ?

Revision history for this message
Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in evince (Ubuntu Lucid):
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.30.1-0ubuntu2

---------------
evince (2.30.1-0ubuntu2) lucid-proposed; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates
 -- Didier Roche <email address hidden> Fri, 30 Apr 2010 09:02:33 +0200

Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Richard (g-launchpad-mcgillivary-org) wrote :

apt-cache policy evince
evince:
  Installed: 2.30.1-0ubuntu2
  Candidate: 2.30.1-0ubuntu2
  Version table:
 *** 2.30.1-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid-proposed/main Packages
        100 /var/lib/dpkg/status
     2.30.0-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages

Martin Pitt (pitti)
Changed in evince (Ubuntu Lucid):
status: Fix Released → Fix Committed
Revision history for this message
Richard (g-launchpad-mcgillivary-org) wrote :

Just done some more testing and if I move the evince directory to a none fuse filesystem with a symlink , the last_settings file gets created

e.g.

lstat64("/home/rmcgilli/.gnome2/evince/last_settings", 0xbfbc753c) = -1 ENOENT (No such file or directory)
open("/home/rmcgilli/.gnome2/evince/last_settings", O_WRONLY|O_CREAT|O_EXCL|O_LARGEFILE, 0666) = 9
fstat64(9, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
close(9) = 0
lstat64("/home/rmcgilli/.gnome2/evince/last_settings", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0

Quick look around and a bug(44886)has previously been reported with fuse 2.4 and O_WRONLY|O_CREAT , but was fixed; so wonder if this is a regression; will see if I can find the bug.

However, this means it's not an evince bug; but a fuse bug.

Revision history for this message
Didier Roche (didrocks) wrote :

Hum, that's weird, I can't reproduce your issue there.

I have tried even having a ~/.gnome2/evince directory, without the last_settings file, and evince opens silently and create it :/
I don't have also your EggSMClient warning on the command line, not sure how to effectively debug that TBH.

Revision history for this message
Didier Roche (didrocks) wrote :

ok, my answer was mixed up after. Keep us in touch if you find something in the fuse side ;)

Revision history for this message
Martin Pitt (pitti) wrote :

Thanks Richard. Does evince work well now?

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

Package in -Proposed work for me.
Test case ok.

Martin Pitt (pitti)
Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti)
Changed in evince (Ubuntu Lucid):
status: Fix Released → Fix Committed
Revision history for this message
Pedro Villavicencio (pedro) wrote :

the update is working fine now and as per the comments the issue with not being able to open evince was fixed, marking this as verification done, thanks all.

tags: added: verification-done
removed: regression-proposed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evince - 2.30.1-0ubuntu3

---------------
evince (2.30.1-0ubuntu3) lucid-proposed; urgency=low

  [ Jamie Strandboge ]
  * debian/apparmor-profile.abstraction: allow writes to removable media
    (LP: #490230)

  [ Didier Roche ]
  * debian/patches/03_fix_opening_hash_filename.patch:
    Fix opening files with '#' in its name (LP: #578996)

evince (2.30.1-0ubuntu2) UNRELEASED; urgency=low

  * add debian/patches/02_fix_dot_dir_creation.patch:
    fix dot dir creation when launching evince directly (LP: #571725)

evince (2.30.1-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release:
    Bug fixes:
    - Make inverted colors mode work in presentation mode too
      (#614693, Carlos Garcia Campos)
    - Respect GNOME22_USER_DIR env variable (#613637, Ray Strode)
    - Fix loading of local documents when uri contains a page
      destination (#616515, Carlos Garcia Campos)
    - Take default settings from last document opened. Fixes
      regression caused by migration to gio metadata (#606090, Carlos
      Garcia Campos) (LP: #544639, #503372)
    - Update icons to match gnome-icon-theme appearance (#614747,
      Hylke Bons, Carlos Garcia Campos)
    - Make sure there's a new valid page range before updating caches
      (fdo#27599, Carlos Garcia Campos)
    - Update FSF address everywhere (#514607, Arun Persaud)
    - Fix loading of compressed password-protected documents (#613959,
      Carlos Garcia Campos)
    - Close previewer window with control + w (#612972, Carlos Garcia
      Campos)
    - Fix keybindings in previewer window (#612972, Carlos Garcia
      Campos)
    Translation updates
 -- Didier Roche <email address hidden> Thu, 13 May 2010 16:31:06 +0200

Changed in evince (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Maurizio Varanini (varanini) wrote :

I get the error "Error opening file: Permission denied" opening a ".fdf" file on ntfs partition.
The same file is opened correctly if I change its extension in ".pdf" or if I move it on a linux partition. uname -a
2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
evince --version
GNOME Document Viewer 2.30.1

Revision history for this message
annunaki2k2 (russell-knighton) wrote :

For me, the released fix doesn't work. This is a NIS network with NFS mounted home directories mounted at /usr/people - a legacy our system being from the IRIX days. (I don't know if that make any difference)

Installed version info:
russell@basking:~$ evince --version
GNOME Document Viewer 2.30.1
russell@basking:~$ aptitude show evince
Package: evince
State: installed
Automatically installed: no
Version: 2.30.1-0ubuntu3
--snip--

My strace output when running evince:
--snip--
access("/usr/people/russell/.gnome2", F_OK) = 0
stat("/usr/people/russell/.gnome2", {st_mode=S_IFDIR|0700, st_size=133, ...}) = 0
access("/usr/people/russell/.gnome2/evince", F_OK) = -1 ENOENT (No such file or directory)
mkdir("/usr/people/russell/.gnome2/evince", 0700) = -1 EACCES (Permission denied)
lstat("/usr/people/russell/.gnome2/evince/last_settings", 0x7fff7b7d6ea0) = -1 ENOENT (No such file or directory)
open("/usr/people/russell/.gnome2/evince/last_settings", O_WRONLY|O_CREAT|O_EXCL, 0666) = -1 ENOENT (No such file or directory)
write(2, "\n** (evince:3441): WARNING **: E"..., 164
** (evince:3441): WARNING **: Error creating last_settings file: Error opening file '/usr/people/russell/.gnome2/evince/last_settings': No such file or directory

) = 164
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

As you can see here, clearly the same error. If I make the ./gnome2/evince directory and then touch the last_settings file, it works fine.

Any suggestions? I'm more than happy to do further testing.

Revision history for this message
gfairbanks (elvis-launchpad) wrote :

This is a comment to help others who have similar issues. I had moved my home directory to /opt/home/george on a different partition. AppArmor appears to prevent evince from writing there. I edited my /etc/apparmor.d/tunables/home file (see https://wiki.ubuntu.com/DebuggingApparmor#Adjusting%20Tunables) from:

@{HOMEDIRS}=/home/

to

@{HOMEDIRS}=/home/ /opt/home/george/

Then restarted apparmor

sudo /etc/init.d/apparmor restart

My evince problems (similar to reported above) are gone. Specifically, it no longer complains about not being able to read/write ~/.recently-used.xbel, ~/.gnome2/evince/evince_toolbar.xml, and ~/.gnome2/evince/evince_toolbar.xml. And it retains my settings across sessions.

Revision history for this message
Joe Collins (jgc26) wrote :

I was having the same problem - FUSE mounted home directory vis SSHFS. The suggestion made by gfairbanks worked for me! evince works again - THANK YOU!

Revision history for this message
FP (fabrice-pardo) wrote :

Instead of manually editing apparmor configuration files, you can call
 sudo dpkg-reconfigure apparmor
and give your real home path.

That's a pity that apparmor is not able to detect non standard home directory.

Revision history for this message
Twbecker (twbecker) wrote :

There is something weird going on here. I have the latest evince and I was getting the same errors. Creating ~/.gnome2/evince was not enough....I had to touch last_settings to get evince to open at all. For the record, my home dir is NFS mounted. And although evince opens now I still get these messages when running evince from the command line:

thomaswb@thomaswb-desktop:~$ evince

(evince:4901): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

(evince:4901): Gtk-WARNING **: Attempting to read the recently used resources file at `/u/thomaswb/.recently-used.xbel', but the parser failed: Failed to open file '/u/thomaswb/.recently-used.xbel': Permission denied.

(evince:4901): Gtk-WARNING **: Attempting to store changes into `/u/thomaswb/.recently-used.xbel', but failed: Failed to create file '/u/thomaswb/.recently-used.xbel.9C04EV': Permission denied

(evince:4901): Gtk-WARNING **: Attempting to set the permissions of `/u/thomaswb/.recently-used.xbel', but failed: Permission denied

Revision history for this message
Ugo Riboni (uriboni) wrote :

I have the same bug as Twbecker ( comment #31 ). It can be solved by touching the file ~/.gnome2/evince/last_settings as he mentions, and after doing that I have equivalent warnings as his. I can solve the warnings related to *.xbel* files by just removing them.
However I can not solve the warning about the session manager.

Evince is version 2.30.3-0ubuntu1

Changed in evince:
importance: Unknown → High
Changed in evince (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.