[gutsy] very hi cpu usage when scrolling pdf

Bug #122786 reported by Nicolò Chieffo on 2007-06-28
8
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Medium
Poppler
Won't Fix
Medium
evince (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

I'm using gutsy, and I have evince 0.9.1-0ubuntu1.
I notice a very hi cpu usage in this version of evince.
When scrolling, and when moving a small window (for instance a terminal) over evince with a open pdf.
This makes evince bad because it is too slow to use!

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does it happen with any pdf? Could you attach an example? Do you use a sidebar?

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Nicolò Chieffo (yelo3) wrote :

Yes it happens with all pdfs!
here's an example.
If a sidebar is the bar that opens when pressing F9, no. But it happens also when it is enabled.
It happens in al "view" modes: fullscreen, continuous, dual...

Could it be a graphic driver error?

Nicolò Chieffo (yelo3) wrote :

P.s. I have a mobility radeon 9700. I use the default driver

The bug has been opened on https://bugs.launchpad.net/ubuntu/+source/evince/+bug/122786

"Binary package hint: evince

I'm using gutsy, and I have evince 0.9.1-0ubuntu1.
I notice a very hi cpu usage in this version of evince.
When scrolling, and when moving a small window (for instance a terminal) over evince with a open pdf.
This makes evince bad because it is too slow to use!
...
http://launchpadlibrarian.net/8228961/01%20-%20IntroCorsoNew.pdf
Yes it happens with all pdfs!
here's an example.
If a sidebar is the bar that opens when pressing F9, no. But it happens also when it is enabled.
It happens in al "view" modes: fullscreen, continuous, dual...

Could it be a graphic driver error?

P.s. I have a mobility radeon 9700. I use the default driver"

Sebastien Bacher (seb128) wrote :
Changed in evince:
status: Incomplete → Confirmed
Changed in poppler:
importance: Low → High

Sebastien, does this problem happen to you, too?

i really doubt scrolling cpu usage is a poppler problem, i'd say it's more an evince bug, but i'll leave evince developers to comment

it's not really scrolling specific, it takes several second to render a page when switching

hmm, I can't reproduce the problem with evince. But if the problem is when redrawing once the page is already rendered, it's not a rendering problem. Is it reproducible for you Sebastien?

It's happening with the cairo and the splash backends, switching pages takes almost all the CPU for a few seconds. Could be an xorg bug though, according to sysprof it's spending almost all the CPU in /usr/bin/X (though there is no detail). Switching between windows is also slow when evince is opened, looks like it's doing something heavy for the video

that doesn't happen using an evince 0.8.1 binary on the same installation, looks like an evince bug

Changed in poppler:
status: Unknown → Confirmed
Changed in poppler:
status: Confirmed → Invalid
Changed in evince:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

That happens using a radeon card and seems to be due to http://bugs.freedesktop.org/show_bug.cgi?id=4320

sebastien, that but is more than 1 year old, while the problem with
evince is quite young, and it is using the evince which is in gutsy...
Are you sure that the problem is this?

I tried to install the feisty package on gutsy but the dependencies
are broken...

Sebastien Bacher (seb128) wrote :

evince started using cairo for rendering during the gutsy cycle

Nicolò Chieffo (yelo3) wrote :

It seems that the bug report about cairo is quite old and unfixed...
This will probably mean that it will not be fixed. Is there a way to
temporary disable cairo in evince, so that I can view my pdfs?
This will be a big problem for people who has an r300 card

Sebastien Bacher (seb128) wrote :

the easy workaround is to use evince 0.8 until the bug get fixed which will be before gutsy becomes stable

Nicolò Chieffo (yelo3) wrote :

have you got a link to the 0.8 version please?

Nicolò Chieffo (yelo3) wrote :

Using the fglrx driver I don't have this problem, so I think that the
problem is itself in the radeon driver. What do you think?

Sebastien Bacher (seb128) wrote :

I still thinks it's due to the upstream bug indicated

Nicolò Chieffo (yelo3) wrote :

All right... let's see when and if it get fixed, so!

Martin Pool (mbp) wrote :

I'm seeing this too with a Radeon R250 [Mobility FireGL 9000] both in initially rendering pages and changing pages. Moving windows around does not seem to be affected (as one of the upstream bugs suggests.)

Changed in evince:
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

"Me too" on gutsy on nv driver. Scrolling, resizing, window movement, changing pages, switching windows etc. is painfully slow (each step takes some 5 seconds). That didn't happen in feisty for me either (on the same hardware and drivers).

Nicolò Chieffo (yelo3) wrote :

I fixed this bug adding
Option "XAANoOffscreenPixmaps"
in the device section of xorg.conf

Martin Pool (mbp) wrote :

This seems somewhat better in the current gutsy (maybe? or maybe it's
just because I'm looking at a different pdf?)

Nicolò Chieffo (yelo3) wrote :

Are you using the XAANoOffscreenPixmaps?

Martin Pool (mbp) wrote :

No, I'm not using XAANoOffscreenPixmaps

Nicolò Chieffo (yelo3) wrote :

Add XAANoOffscreenPixmaps to fix

I'm having the same problem (evince working badly on a laptop with 1400x1050 display and a Radeon). What are the negatives of XAANoOffscreenPixmaps if any, and is there a real fix that will go into Gutsy eventually?

Nicolò Chieffo (yelo3) wrote :

I don't know if it goes into gutsy.
I don't see any performance regression using this option. but:
- I don't run compiz because it is too slow for now
- I don't run games

please tell us your results!

Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in evince:
status: Triaged → Fix Committed
Nicolò Chieffo (yelo3) wrote :

Can you tell me anything about why using XAANoOffscreenPixmaps fixes
the problem?

Changed in evince:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

it works around the slow path issue, no need to use it when the next version will be available though (likely next week)

Nicolò Chieffo (yelo3) wrote :

I asked it because I also experience the same slowdown in some flash
animations, in firefox, and it is fixed using this option.

Sebastien Bacher (seb128) wrote :

evince (2.19.4-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    Bug fixes:
    - Find works when findbar is hidden
    - Use directly cairo_surface_get_content
    - Great speedup by using CAIRO_FORMAT_RGB24 instead of CAIRO_FORMAT_ARGB32
      (LP: #122786)
    - Fix for embedded thumbnails dimension and rotation
    - Avoid ifdefs inside macros
    - Memory leak fixes
    - New icon sizes
    - Invalid read fix
    - Fix multihead problems in toolbar editor
    - Use the same cairo context for every page in the same expose event
  * debian/patches/02_autoconf.patch:
    - updated

 -- Sebastien Bacher <email address hidden> Tue, 28 Aug 2007 00:52:00 +0200

Changed in evince:
status: Fix Committed → Fix Released
Nicolò Chieffo (yelo3) wrote :

I confirm the fix. but just a question: if firefox has a similar
problem, that gets fixed using the same XAANoOFfscreenPixmaps
workaround, does this mean that it has the same problem?
(firefox uses CAIRO_FORMAT_ARGB32)

thanks

Sebastien Bacher (seb128) wrote :

that might be the same problem, I don't know cairo enough to comment on that though, you might want to contact upstream about the issue

Jesse Dudley (jesse-dudley) wrote :

I have Ubuntu 7.10 on fresh install with Evince 2.20.1. My CPU goes up to 50-80% when I use the scroll bar.

Please let me know what kind of information you require. I have not submitted a bug previously. I reloaded Evince and I did download the bug report package with it. Gnome launched an applet that collected information, but I am not sure where the file was stored.

I had no problem using Evince on Feisty. Your group has made a great tool--I hope this helps others.

Thanks

Jesse Dudley (jesse-dudley) wrote :

Since the last post, I have tried the following to resolve the CPU/Memory problem:

I added "XAANoOffscreenPixmaps" but it did not resolve the high CPU consumption.

I added epdfViewer and Xpdf viewer. I had the same high CPU usage in epdfViewer as in Evince, but I did not have the same problem in Xpdf. (However Xpdf is not a useful as Evince for my needs).

I have the same high CPU consumption in Firefox/Epiphany, independent of Evince.

My laptop has an Intel Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller.

Since my Gutsy and my Evince are new versions, apparently the problem still exists, or at least in my configuration. Please let me know if there is more information that could help you locating the problem--if it is a problem with Evince and not the dependencies.

Thanks.

tx (372046933-qq) wrote :

Same goes here with Mobility Radon HD3650 on Lucid Lynx laptop

Changed in poppler:
importance: Unknown → Medium
status: Invalid → Won't Fix
Changed in evince:
importance: Unknown → Medium
Changed in poppler:
importance: Medium → Unknown
Changed in poppler:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.