ethtool not available in post-ifup script

Bug #280421 reported by Sebastian Marsching on 2008-10-08
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Low
Chuck Short
ethtool (Ubuntu)
Wishlist
Chuck Short
Lucid
Undecided
Unassigned

Bug Description

=======================================================
SRU Justification:

1. Impact: users who have /usr on a separate, remote, slow filesystem, may find that ethtool does not exist when ethtool's ifup.d rules fire.
2. How bug was addressed: ethtool was moved from /usr/sbin to /sbin
3. Minimal patch: http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/ethtool/maverick/revision/12
4. To reproduce: put /usr on a slow (i.e. remote NFS mounted) filesystem, install ethtool on a system using it.
5. Regression potential: This fix has been applied in maverick and natty with no ill effects. If users have custom scripts calling /usr/sbin/ethtool by its full path, those might now fail since we do not provide an automatic link.

=======================================================

Binary package hint: ethtool

PROBLEM:

I am running Ubuntu 8.04 in a Xen DomU.

To fix network performance issues, the line "post-up /usr/sbin/ethtool -K eth0 tx off" is needed for the virtual ethernet device within the /etc/network/intefaces file.

Usually this works fine, however if /usr is stored on its own partition this command fails, as /usr is not yet mounted when udev executes ifup for the ethernet device.

Unfortunately this causes some very strange errors like "/etc/init.d/networking stop" to fail bacause the eth0 interface is brought up but not correctly registered in the state file.

The only workaround at the moment is to disable the ifup / ifdown hooks in /etc/udev/rules.d/85-ifupdown.rules.

PROPOSED SOLUTION:

The best solution would be moving /usr/sbin/ethtool to /sbin/ethtool so that it is available on startup before /usr has been mounted.

Chuck Short (zulcss) wrote :

Thanks for the bug report, this might be considered for future releases.

Regards
chuck

Changed in ethtool (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Thierry Carrez (ttx) on 2010-06-02
Changed in server-papercuts:
importance: Undecided → Low
milestone: none → maverick-alpha-2
status: New → Triaged
Ben Hutchings (benh-debian) wrote :

Note that since version 6+20080913-2 you can specify ethtool settings directly in /etc/network/interfaces.
However, this will of course fail in the same way if /usr is not mounted.

Chuck Short (zulcss) on 2010-06-03
Changed in ethtool (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ethtool - 1:2.6.34-1ubuntu1

---------------
ethtool (1:2.6.34-1ubuntu1) maverick; urgency=low

  * Move ethtool to /sbin from /usr/sbin. (LP: #280421)
 -- Chuck Short <email address hidden> Thu, 03 Jun 2010 09:02:43 -0400

Changed in ethtool (Ubuntu):
status: Triaged → Fix Released
Thierry Carrez (ttx) on 2010-06-03
Changed in server-papercuts:
assignee: nobody → Chuck Short (zulcss)
status: Triaged → Fix Released
Changed in ethtool (Ubuntu Lucid):
status: New → Confirmed
description: updated

Accepted ethtool into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ethtool (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Mark Russell (marrusl) wrote :

Sorry for the delay. This fix looks good to me and the customer has also verified. Thanks, everyone!

Jean-Baptiste Lallement (jibel) wrote :

Thanks for testing Mark, marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ethtool - 6+20091202-1ubuntu1

---------------
ethtool (6+20091202-1ubuntu1) lucid-proposed; urgency=low

  [ Serge Hallyn ]
  * Anibal Monsalve Salazar <email address hidden>: Move ethtool to
    /sbin from /usr/sbin (LP: #280421)
  * Ben Hutchings <email address hidden>: ethtool.if-up: Remove
    dependency on commands installed under /usr (Closes: #589123)

  [ Clint Byrum ]
  * debian/rules: install a symlink in /usr so we don't break any
    scripts that have explicitly mentioned the path to the file.
 -- Clint Byrum <email address hidden> Thu, 05 May 2011 16:21:33 -0700

Changed in ethtool (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers