ethtool settings may not apply on boot with separate /usr

Bug #777193 reported by Mark Russell on 2011-05-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ethtool (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ethtool

Description: Ubuntu 10.04 LTS
Release: 10.04

ethtool:
  Installed: 6+20091202-1
  Candidate: 6+20091202-1

System has ethtool setting in /etc/network/interfaces, in this case:
HARDWARE_DMA_RING_ rx 512

The default setting is 256. You can check the setting with `ethtool -g eth0`.

Expected behavior: on startup (actually on any ifup), /etc/network/if-up.d/ethtool should run, read /etc/network/interfaces and apply ethtool settings if they are there.

Observed behavior: on this system, it's clear that /etc/network/if-up.d/ethtool is executed before /usr is mounted, therefore the setting does apply as the ethtool binary is on /usr. The setting applies fine if you do an ifdown and ipup manually after startup.

Public bug filed by GSS (Mark Russell): https://bugs.launchpad.net/ubuntu/+source/ethtool/+bug/777193

I will attach logs showing what's happening.

Mark Russell (marrusl) wrote :

In this log first we show a couple of changes put into /etc/network/if-up.d/ethtool for logging information. It consists of echoing the time and checking mount a few times during the script. Then the results.

Changed in ethtool (Ubuntu):
importance: Undecided → Medium
Mark Russell (marrusl) on 2011-05-04
description: updated
description: updated
description: updated
Ben Hutchings (benh-debian) wrote :

ethtool is installed in /sbin since 1:2.6.34-1ubuntu1 (in maverick).

Changed in ethtool (Ubuntu):
status: New → Fix Released
Mark Russell (marrusl) wrote :

Except my customer is running Lucid.

Clint Byrum (clint-fewbar) wrote :

I do not believe this is a duplicate. This is a new, regression, as 280421 was fixed but then regressed. Unmarking as dupe.

Clint Byrum (clint-fewbar) wrote :

Err, my bad, it is a dupe. Thanks hallyn for the private comments. ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers