[Dapper] Adept can't open APT database

Bug #40410 reported by Daniel Franke on 2006-04-20
34
Affects Status Importance Assigned to Milestone
ept (Ubuntu)
Medium
mornfall

Bug Description

This is on a fresh Dapper Beta install:

I start adept and after I give kdesu my password this error pops up:

Window title: "Could not open cache - Adept Manager"

Message:
The APT Database could not be opened! This may be cause by incorrect APT configuration or some similar problem. Try running apt-setup and apt-get update in terminal and see if it helps to resolve the problem.

I don't have apt-setup but I have run an apt-get update and that didn't fix it.

apt-get works well tho.

Troy Unrau (troy-unrau) wrote :

I get the same problems, with both adept and adept_installer

amd64, dapper beta install from install cd (not live cd)

I submitted dupe 40488 before I found this previously posted bug

Daniel Franke (d-franke) wrote :

Forgot to add that I had the problem on i386

Karsten König (remur) wrote :

Can confirm this too

i386 and installer cd used as the espresso installer from the live cd always crashed
sudo adept from the console doesn't fix this adept issue either
adept-updater has the same problem

Karsten König (remur) wrote :

i had an old flight 5 + updates backup on another partition which still had a working adept etc
so i was making a backup of the current installation and forgot to wipe the backup partition, booted into this and adept runs on this partition

so it looks like on the beta installer cd you just forgot some configuration file, but i couldn't find out which one, if you got an idea how to do this i could look again

Michael Bialas (m-bialas) wrote :

I have found a solution. The file /var/lib/debtags/vocabulary is missing.
"sudo debtags update" solves the problem.

This command is commented out in the debtags.postinst-file.

Karsten König (remur) wrote :

Thanks this solves the issue perfectly

mornfall (mornfall) wrote :

This was fixed by a last debtags upload. It should work fine out of the box again.

Changed in ept:
assignee: nobody → me-mornfall
status: Unconfirmed → Fix Released
Ted Treadwell (ttread) wrote :

I'm not seeing this problem anymore in Kubuntu 6.06 Flight 7.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers