Side panel (Ctrl+F9) always show up every time EOG opens

Bug #923708 reported by Adolfo Jayme on 2012-01-30
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Medium
eog (Ubuntu)
Low
Unassigned

Bug Description

The side panel has become highly annoying because it opens every time I launch eye-of-gnome (e.g. when I open an image from Nautilus). This is in eog v3.3.4, Ubuntu Precise.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
Sam_ (and-sam) wrote :

Not the case with 3.2.1 on Oneiric.
Eog opens with sidebar. Disabling it and reopen doesn't help.
eog:
  Installed: 3.3.4-0ubuntu1
  Candidate: 3.3.4-0ubuntu1
  Version table:
 *** 3.3.4-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in eog:
importance: Unknown → Medium
status: Unknown → New
Robert Roth (evfool) on 2012-01-30
Changed in eog:
importance: Medium → Unknown
status: New → Unknown
Sam_ (and-sam) wrote :

Upstream developer said: Already fixed for next release.
Thank you, looking forward to it.

Changed in eog:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in eog (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Low
Adolfo Jayme (fitojb) wrote :

Thank you Sam and Sebastien for taking care of this! :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.3.4-0ubuntu2

---------------
eog (3.3.4-0ubuntu2) precise; urgency=low

  * debian/eog.gsettings-override:
    - don't display the sidebar by default (lp: #923708)
 -- Sebastien Bacher <email address hidden> Wed, 01 Feb 2012 15:57:46 +0100

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
Sam_ (and-sam) wrote :

Still opens every image with side bar. Disabling side bar doesn't help it's displayed on restart.
eog:
  Installed: 3.3.4-0ubuntu2
  Candidate: 3.3.4-0ubuntu2
  Version table:
 *** 3.3.4-0ubuntu2 0

Tobias Wolf (towolf) wrote :

That because the Ubuntu fix was not the fix that upstream implemented. The Ubuntu fix was a gsettings override, but upstream made a code change.

Please pull this change from eog git instead:

http://git.gnome.org/browse/eog/commit/?id=6b28ca6b46fda34855d89564e5097324947ac1b9

Sebastien Bacher (seb128) wrote :

> Please pull this change from eog git instead:

it's not "instead", the default change was orthogonal to the upstream fix that we will get with the next tarball which should be rolled today

Changed in eog (Ubuntu):
status: Fix Released → Fix Committed
Tobias Wolf (towolf) wrote :

I see. Thank you, Sebastien.

Sebastien Bacher (seb128) wrote :

eog (3.3.5-0ubuntu1) precise; urgency=low

  * New upstream version:
    - Don't show sidebar by default, or at least remember setting
      (lp: #927858)
  * debian/control.in:
    - updated gtk requirement

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.