Ubuntu

EOG - Image viewer hangs system when opening large image file

Reported by Gordon Dracup on 2011-10-18
88
This bug affects 20 people
Affects Status Importance Assigned to Milestone
eog (Ubuntu)
Undecided
Unassigned

Bug Description

Since upgrade to 11.10, opening large jpg image files causes system to hang. Hard reset required.
Happy to supply further information if you let me know what you need.

 ~ $ apt-cache policy eog
eog:
  Installed: 3.2.0-0ubuntu1
  Candidate: 3.2.0-0ubuntu1
  Version table:
 *** 3.2.0-0ubuntu1 0
        500 http://au.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: eog 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Tue Oct 18 20:50:55 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/eog
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: eog
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (4 days ago)
XsessionErrors:
 (nautilus:1952): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:1952): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (gnome-shell:1923): Clutter-WARNING **: The actor 'uiGroup' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
 (gnome-shell:1923): Clutter-WARNING **: The actor 'uiGroup' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

Gordon Dracup (gordon-dracup) wrote :
Gordon Dracup (gordon-dracup) wrote :

It may not be all large images that cause the system to hang. I have attached an example image that causes my system to hang every time. Its dimensions are W 3744 x H 5616.

summary: - Image viewer hangs system when opening large image file
+ EOG - Image viewer hangs system when opening large image file
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
jan holmén (jnhlmn) wrote :

I have the same problem on a clean install of 11.10 64bit version
It doesn't hang the whole system, just the desktop. It is possible to recover by logging in from another computer and killing the "gnome-session" process.

Same problem here,
I have Ubuntu 11.10 64 bits version upgraded from 11.04 64 bits.

Image Viewer hangs while opening a .jpg file with size of 2.2 MB. Returns to normal sometimes after 1 min. of hang state.

Dennis van Dok (dvandok-gmail) wrote :

Opening a folder with several 6MB photos; the first few display ok, then the system hangs (or at least is very slow to respond). This sounds like more of a kernel bug than EOGs. Back in the days of Windows 95 we were used to user processes hanging the system but this should never be possible on a proper OS.

Robert B (robertb-macau) wrote :

I c an confirm this bug. Just tried to open a 1.6MB JPG image file using eog. It shows "Opening image ..." and the beginning bit of the progress bar and then freezes. My system monitor also freezes and the only thing that still works is the mouse pointer, although it's slower than normal. All window buttons, menus, desktop etc. are unresponsive to mouse interaction. Keyboard shortcuts (Ctrl-Alt-F1, Ctrl-Alt-Backspace, Ctrl-Alt-Delete etc.) don't work.

This is not the first time this has happened to me. It has affected my office PC (Dell Optiplex 755) as well as my home PC (Dell Inspiron 530), both running Ubuntu 11.10 32bit, and already surfaced when I was still using Ubuntu 11.04. It seems to affect eog only as gimp and shotwell don't have this problem.

This is a critical bug as the only way to recover from it is to do a hard reset, which could result in the loss of data.

svenw (svenw1973-launchpad) wrote :

Same here. It just locks the entire session when opening a bootchart. I can move the mouse pointer only.
I have to kill gnome-session and logon again.

apt-cache policy eogsven@sww500:~$ apt-cache policy eog
eog:
  Installiert: 3.2.1-0ubuntu1
  Kandidat: 3.2.1-0ubuntu1
  Versionstabelle:
 *** 3.2.1-0ubuntu1 0
        100 /var/lib/dpkg/status
     3.2.0-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Have exactly the same problem. Only the "eye of gnome viewer" has this problem. Tried opening the same file with gthumb and gimp. It opens without any issues.

angus73 (andrea-vai) wrote :

I experienced this problem with Ubuntu 11.10 and hoped that would be fixed in 12.04 LTS. Unfortunately, I can confirm that it still happens in 12.04.
I sum up the behaviour of my system:
- EOG and all the desktop seems freezed when I try to open any image with EOG (the EOG image loading progress bar usually fills partially)
- when the desktop is freezed:
  - I can still move the mouse pointer
  - ctrl+alt+F1 does not work
  - I can log into the system from a ssh session and restart gdm, and it works again
- using other programs like f-spot, shotwell etc., the same images are opened correctly

I agree that this is a critical bug, because it affects the default image viewer for Ubuntu and it can cause loss of data.

I would also point out that the issue happens with images of different size, so I would change the bug title, that is about "large" image files

Let me know if I have to provide any further information
Running Ubuntu 12.04LTS and graphics Intel 82852/855GM

Malin Bruland (malinkb) wrote :

To me it happens in 12.04 LTS

angus73 (andrea-vai) wrote :

I can point out that in 12.04 LTS it does happen if I choose the Gnome session. If I logon into Unity it does not happen... Ironic because it is EOG, not EOU (Eye Of Unity), and more ironic for me, as I prefer Gnome :-/

Sebastien Bacher (seb128) wrote :

If anyone still get the issue on 12.04 lts could you open a new bug using "ubuntu-bug xorg" (do it after getting the issue if possible) and add the bug reference here? those seem rather video driver, xorg issues than eog ones, the command will also add details on your video configuration

angus73 (andrea-vai) wrote :

I am still getting the issue on 12.04 LTS.
I have tried to use the command "ubuntu-bug xorg" through an ssh connection just after I had reproduced the problem.
The output follows. Some rows are translated by me from italian.

*** Gathering informations about the problem [...] this could take a few minutes (*translation by me*)
........................................................................................................................................
*** 'precise' is no longer under development, but technical support is still
available and will give you quicker results than filing a bug here.
Also, if you do have a bug, we will give it higher priority if you've gone
through technical support channels first.

Scelte:
  1: I don't know what to do
  2: Continue. I already know of a patch to fix this problem.
  3: Continue. Yes, I have discussed this with technical support.
  4: Continue. I don't need technical support.
  5: Please point me to where I can get technical support.
  N: Annulla
Scegliere (1/2/3/4/5/N): 1

If I choose "1":
***

http://www.ubuntu.com/support/ is the best place to get free help with technical issues.

Next, if I choose "4":
*** Problem in xorg

Cannot report the problem (*translation by me*)

Please work this issue through technical support channels first.

No crash report pending. Try --help for further information. (*my translation*)

...and then it returns to the command prompt.
I didn't choose any other options because they all seems to me not concerning my problem
So, I don't know exactly what to do or where I am wrong.

angus73 (andrea-vai) wrote :

Sorry for the double comment. I think I managed to to that choosing "3", and filed the new bug 1032251 here: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1032251

yin rong (yr0319) wrote :

system hangs when I open a 400MB+ png image in Ubuntu 12.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers