Ubuntu

"Share My Desktop" doesn't work with XMPP in 11.10

Reported by Nate Gingras on 2011-10-25
48
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Fedora)
Unknown
Unknown
empathy (Ubuntu)
Low
Unassigned

Bug Description

Share My Desktop in Ubuntu 11.10 seems to be broken. The user receives no feedback, and nothing interesting happens. Doesn't appear to matter what version the client is using. The XMPP server is OpenFire 3.6.

Release: Ubuntu 11.10 (freshly installed)
Empathy Version: 3.2.0.1-0ubuntu1

Relevant Empathy debug logs attached.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
François Tissandier (baloo) wrote :

Same problem here on Openfire too. And it doesn't seem any better on Gtalk either. Quite serious for us here as we are using this to help our users a lot.

François Tissandier (baloo) wrote :

Is nobody working on this problem ? :-( It's a great tool for computer support when you don't want to deal with firewall settings or VPNs.

Bilal Shahid (s9iper1) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Bilal Shahid (s9iper1) wrote :
Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Bilal Shahid (s9iper1) wrote :

gdb /usr/lib/vino/vino-server
- Hit 'r' to start it once it's loaded in gdb
- Try to offer a tube
- Once vino crashed in gdb type 'bt full' and attach the out put on upstream bug.

Changed in empathy:
status: New → Incomplete
François Tissandier (baloo) wrote :

It's working now ! same server, we didn't update anything on it.

Bilal Shahid (s9iper1) on 2011-12-16
Changed in empathy (Ubuntu):
status: Confirmed → Invalid
Changed in empathy:
status: Incomplete → Invalid
Bilal Shahid (s9iper1) wrote :

reopening the bug because it is still present.

Changed in empathy (Ubuntu):
status: Invalid → Confirmed
Changed in empathy:
status: Invalid → New
Pavel Borecki (pavel-borecki) wrote :

Hi Muhammad,
I read instructions on Gnome Bugzilla and I think, that their instruction (somewhat unclear) "Try to offer a tube" means "Try to share your desktop". After it fail, then return do gdb and type "bt full" to get list of information useful for developers solving this problem. Unfortunately, I got only "No stack." - please try it on your machine - if you will be more succesfull, then it will be possible to complete bug report at Gnome Bugzilla and get problem solved.

Bilal Shahid (s9iper1) wrote :

i am trying but there is no option coming to share desktop is not hilighted with the other options

Bilal Shahid (s9iper1) wrote :

any body else please attach the log in up stream bug.

Bilal Shahid (s9iper1) on 2012-04-23
Changed in empathy (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in empathy:
status: New → Invalid
Changed in empathy:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.