"Share My Desktop" doesn't work with XMPP in 11.10

Bug #881664 reported by Nate Gingras on 2011-10-25
48
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Fedora)
Won't Fix
Undecided
empathy (Ubuntu)
Low
Unassigned

Bug Description

Share My Desktop in Ubuntu 11.10 seems to be broken. The user receives no feedback, and nothing interesting happens. Doesn't appear to matter what version the client is using. The XMPP server is OpenFire 3.6.

Release: Ubuntu 11.10 (freshly installed)
Empathy Version: 3.2.0.1-0ubuntu1

Relevant Empathy debug logs attached.

Created attachment 502998
telepathy-gabble log from sender

Description of problem:
I have tried to share desktop with my friend. We both have Jabber account on the same server. The remote desktop request is not received on the other side.

Version-Release number of selected component (if applicable):
Empathy 3.0.1 -> Empathy 3.0.2
Empathy 3.0.2 -> Empathy 3.0.2

How reproducible:
Always if versions match above-mentioned.

Steps to Reproduce:
1. Connect to Jabber account via Empathy
2. Select contact, who is connected via Empathy
3. Share your desktop

Actual results:
Remote desktop request is not shown on the other side. Impossible to share desktop.

Expected results:
Remote desktop request is shown on the other side. When accepted, Vinagre should handle remote desktop invitation.

Additional info:
Works when following versions are used:
2.32.1 (person who shares desktop)
3.0.2 (person who receives remote desktop invitation)
Does not work in reversed order.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
François Tissandier (baloo) wrote :

Same problem here on Openfire too. And it doesn't seem any better on Gtalk either. Quite serious for us here as we are using this to help our users a lot.

François Tissandier (baloo) wrote :

Is nobody working on this problem ? :-( It's a great tool for computer support when you don't want to deal with firewall settings or VPNs.

Bilal Shahid (s9iper1) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Bilal Shahid (s9iper1) wrote :
Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Bilal Shahid (s9iper1) wrote :

gdb /usr/lib/vino/vino-server
- Hit 'r' to start it once it's loaded in gdb
- Try to offer a tube
- Once vino crashed in gdb type 'bt full' and attach the out put on upstream bug.

Changed in empathy:
status: New → Incomplete
François Tissandier (baloo) wrote :

It's working now ! same server, we didn't update anything on it.

Bilal Shahid (s9iper1) on 2011-12-16
Changed in empathy (Ubuntu):
status: Confirmed → Invalid
Changed in empathy:
status: Incomplete → Invalid
Bilal Shahid (s9iper1) wrote :

reopening the bug because it is still present.

Changed in empathy (Ubuntu):
status: Invalid → Confirmed
Changed in empathy:
status: Invalid → New
Pavel Borecki (pavel-borecki) wrote :

Hi Muhammad,
I read instructions on Gnome Bugzilla and I think, that their instruction (somewhat unclear) "Try to offer a tube" means "Try to share your desktop". After it fail, then return do gdb and type "bt full" to get list of information useful for developers solving this problem. Unfortunately, I got only "No stack." - please try it on your machine - if you will be more succesfull, then it will be possible to complete bug report at Gnome Bugzilla and get problem solved.

Bilal Shahid (s9iper1) wrote :

i am trying but there is no option coming to share desktop is not hilighted with the other options

Bilal Shahid (s9iper1) wrote :

any body else please attach the log in up stream bug.

I can confirm this problem. I used to help my mum with this feature and it's very bad that it stopped working. Please notify me, if you need any further information. Thanks.

Bilal Shahid (s9iper1) on 2012-04-23
Changed in empathy (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in empathy:
status: New → Invalid
Changed in empathy:
status: Invalid → Fix Released

This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Changed in empathy (Fedora):
importance: Unknown → Undecided
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.