German spellchecking does not work

Bug #559894 reported by Thomas Krause on 2010-04-10
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Empathy
Confirmed
Medium
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

I activated both "German" and "English" in the spell checker configuration dialog but every non-english word is underlined in red.

Ubuntu says the language support is fully installed.

I'm using
Description: Ubuntu lucid (development branch)
Release: 10.04

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: empathy 2.30.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
Date: Sat Apr 10 11:17:05 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.utf8
SourcePackage: empathy

Thomas Krause (krause) wrote :
Thomas Krause (krause) wrote :
tags: added: regression
Thomas Krause (krause) wrote :

Deactivating "English" and only activating German does not work work as well.

Omer Akram (om26er) wrote :

can you please attach an image with only german enabled so that we have enough info to send it upstream.

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Thomas Krause (krause) wrote :

It also happens when only German is activated. The words are all correct (and common enough that the spell checker should know it). Even "Test" is highlighted (which was valid in the "German and English" configuration).

Thomas Krause (krause) wrote :

For curiosity, I changed it to use only Norwegian (Bokmål) and it works. So this seems not to be a "non-English" problem but only one with the German locale. Which spellchecker does Empathy use? I tried hunspell on the command line for German and it worked without any problems.

Empathy uses enchant but I think they are considering another aproach

Sebastien Bacher (seb128) wrote :

is spellchecking working using the enchant command line tool or in gedit?

Thomas Krause (krause) wrote :

This is the output of enchant

thomas@tk-laptop:~$ cat testdic.txt
Dies ist ein Test: sfff
thomas@tk-laptop:~$ enchant testdic.txt -l
sfff

Gedit also works well with German.

Sebastien Bacher (seb128) wrote :

ok, seems it's not an enchant issue then, weird

Thomas Krause (krause) wrote :

Why is the status still "Incomplete", do you need more information from my side?

Sebastien Bacher (seb128) wrote :

no, it just seems only you get this issue and ten thousand of bugs are waiting, it's not likely that one will get worked anytime soon by somebody not getting the bug

Changed in empathy (Ubuntu):
status: Incomplete → New
Thomas Krause (krause) wrote :

I did a fresh reinstall (without using the old config files) and the issue was fixed afterwards. Maybe the upgrading to Lucid was causing the confusion.

Brian Curtis (bcurtiswx) wrote :

as per the reporters comments i am invalidating this bug

Changed in empathy (Ubuntu):
status: New → Invalid
Thomas Krause (krause) wrote :

The same problem occurred after upgrading from Lucid to Maverick. Is there any way to reset language support and hope it will work then?

Benjamin Schmid (benbuntu) wrote :

I have exactly the same problem here after a *fresh* install of Maverick: The German spell checking does not work though installed and activated. The enchant Test above works for me, too. So german in echant seems to work well.

Changed in empathy (Ubuntu):
status: Invalid → New
tags: added: maverick
removed: amd64
Changed in empathy (Ubuntu):
status: New → Confirmed
tags: added: natty
Jonas Schwabe (jonas-schwabe) wrote :

I can confirm this on "fresh" Natty...
Had no problems with the previous versions thought,

I am experiencing this bug in Oneiric Beta. So it still doesn’t seem to be fixed.

Bilal Shahid (s9iper1) wrote :

is this still present confirm it?

Thomas Krause (krause) wrote :

After reinstalling Natty from scratch I did not get this problem any longer. After upgrading to Oneiric it appeared again. So yes, it's still and issue and I can confirm ist.

Tchiller (peter-toennies) wrote :

Confirmed!
No changes until now.

Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Bilal Shahid (s9iper1) wrote :

answer the developers at https://bugzilla.gnome.org/show_bug.cgi?id=666686 and subscribe to the bug
thanks

Benjamin Schmid (benbuntu) wrote :

Thanks Muhammad. I provided a full description of the bug and its reproduction based on the input provided here esp. by Thomas.

The bug is also reproduceable in the newer Empathy 3.3.1-0ubuntu2~ppa11.10+1 availble in the telepathy PPA.

Benjamin Schmid (benbuntu) wrote :

As discussed in gnome-bugs #666686 this is not a problem not in Empathy, but either in the spell checking library enchant or the dictionary provided with Ubuntu:

The same effect appears i.e in gedit and traces down as follows:
If you select "Deutsch" as language option (only available option in Empathy) it fails. This equals to locale "de". If you choose "Deutsch (Deutschland)" ("de-DE") spell checking works. In Empathy you have no option to choose "de-DE" as workaround.

Traces down to the following test:

~/dev$ enchant -d de-DE test.txt
~/dev$ enchant -d de test.txt
error: line 1: missing or bad word count in the dic file
Hash Manager Error : 4

Bilal Shahid (s9iper1) wrote :

adding the new bugstream link.thanks

Changed in empathy:
importance: Medium → Unknown
status: New → Unknown
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Confirmed
Grek-336 (kult01) on 2012-06-30
tags: added: precise
Grek-336 (kult01) wrote :

Bug is still present in 12.04 LTS (Precise Pangolin)

enchant works well, empathy not.

~$ enchant -d de-DE /tmp/German_Test_Text.txt
~$ enchant -d de /tmp/German_Test_Text.txt
error: line 1: missing or bad word count in the dic file
Hash Manager Error : 4

Same problem here, but I can offer a workaround:

remove package hunspell-de-de
install aspell-de and myspell-de-de

Restart empathy, switch german spell check off and on again ...

MarcS (marc-schmitzer) wrote :

I ran into this aswell on Saucy.
Some hints in the upstream bug report helped me to find a work around, though:
Use dconf-editor, go to org/gnome/empathy/conversation and replace the "de" in "spell-checker-languages" with "de_DE". Seems to do the trick.

Perhaps someone can help me.
I cannot add a language to Empathy because I do not know how.
I search the net and all I find is people who added a language and cannot activated it, but nobody actually describes how to add a language.
Some people say go to Settings/Region & Language/ and go to Empathy and add a language, yet there is no "Empathy" tab in Regions & Language.
Any help?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.