wrong transparency in contact's tooltips

Bug #538293 reported by Yann Dìnendal
100
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Ubuntu)
Low
Unassigned
Nominated for Maverick by Pavol Klačanský

Bug Description

In Ubuntu 10.10 with empathy 2.32 tooltips in the contact list have broken tranparency.

Revision history for this message
Yann Dìnendal (yannbreliere) wrote :
Revision history for this message
Vish (vish) wrote :

Not a theme bug , it happens in all themes which enable transparency of the tooltips.

It is a gtk bug .

Changed in light-themes (Ubuntu):
status: New → Invalid
affects: light-themes (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, confirming the issue, note that the gtk tooltip changes comes from upstream bugzilla and fedora but is not in the upstream gtk version

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Yann Dìnendal (yannbreliere) wrote :

It might be a bug with light-themes (among other themes), really: I've just noticed it works perfectly with the Sorbet theme (from the community-themes package).
See attached screenshot for a transparent png rendered well in a transparent tooltip.
Sorbet is the only theme I've found where it looks good. It is based on Homosapien which has the problem, so you might want to look the differences between both themes.

Revision history for this message
Kenneth Wimer (kwwii) wrote :

Does this also happen when using the Radiance theme?

Revision history for this message
Yann Dìnendal (yannbreliere) wrote :

Yes. If I remember well, the bug happens with every theme I have (Ambiance, Radiance, Human, Homosapien, ...) except Sorbet.

Revision history for this message
Yann Dìnendal (yannbreliere) wrote :

Of course, I didn't mean Human in the previous comment: it has opaque tooltips, so transparent images are rendered well.

Ambiance, Hanso, Homosapin, Impression, Night Impression, Radiance all have the problem.

I thought DarkRoom also had the the problem, as the image's background is colored, but it might be normal: the background of the image is transparent. See attached screenshot.

Revision history for this message
Yann Dìnendal (yannbreliere) wrote :

Something else I've noticed: the transparent icon in the weather tooltip of the date/time applet is displayed well with every theme.

Revision history for this message
Vish (vish) wrote :

Interesting that the bug doesnt affect the weather tooltip! , so it might be a problem with empathy.

Revision history for this message
Omer Akram (om26er) wrote :

interestingly empathy 2.30.1.1(its in proposed) no longer shows image for people with no avatar. so if the problem is not with other apps. I guess this bug could be closed ?

Revision history for this message
Vish (vish) wrote :

Switching task to empathy , As per Omer's comment that the bug seems fixed in empathy 2.30.1.1.

Once empathy is released to Lucid bug can be closed.

affects: gtk+2.0 (Ubuntu) → empathy (Ubuntu)
Revision history for this message
Yann Dìnendal (yannbreliere) wrote :

I believe he meant that empathy does no longer display the default image in the tooltip of people without avatar...
Which was the most common case to see the problem, as the default image is transparent. But people can still have a transparent avatar which will not display correctly.

Revision history for this message
Pavol Klačanský (pavolzetor-deactivatedaccount) wrote :

Hallo, I have latest updates of maverick, but problem occurs

As you can see in screenshot, there are only borders transparent, probably, they shouldn't be transaprent, it looks weird

Revision history for this message
Brian Curtis (bcurtiswx) wrote :

I'm still not convinced this is an empathy issue. Seems more of a theme issue or a GTK issue. If anything it should be forwarded upstream so that someone can take a look and we can go from there. http://wiki.ubuntu.com/Bugs/Upstream/GNOME for instructions

Revision history for this message
skalka (skalka) wrote :

I can confirm that even on Maverich tooltip on Empathy are wrong displayed. It happens with every contact, with picture or not. I can confirm that whether and all others tooltips are good. I've tried with all the themes installed by default on Maverick.

Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
Vish (vish) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system.

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
skalka (skalka) wrote :

Just Checked on Lucid, with Ambiance everything works as expected.

Changed in empathy:
status: New → Incomplete
Omer Akram (om26er)
description: updated
summary: - Wrong transparency in tooltips of the new themes
+ wrong transparency in contact's tooltips
Revision history for this message
Ricardo Ferreira (ricardofcf) wrote :

In case this helps, Pidgin does not have the same problem. And it's GTK as well.

Revision history for this message
manzur (sl-solaris) wrote :

this is happening to me too

Revision history for this message
Reloweb (reloweb) wrote :

Any news?

Revision history for this message
infected (infected) wrote :

Its frustrating to see this bug is still alive. I would be happy if someone could fix it very soon because i'm working with empathy every day and its always bugs me...

Changed in empathy:
status: Incomplete → New
Revision history for this message
melo (carmeloscollo) wrote :

Can confirm this bug for ubuntu 11.04!
I did a fresh install but kept my home-partition.
It's been quite a long time now that I'm looking at this rather ugly tooltips.
Is there any way I can help fixing this?
Provide some information of any kind maybe?

Revision history for this message
pablomme (pablomme) wrote :

Empathy in oneiric has fully-opaque tooltips. While I'd prefer to see some transparency, this bug appears to have been fixed in oneiric.

Changed in empathy:
status: New → Fix Released
Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

I'm getting an issue like this in Precise where a solid white rectangle appears in the tooltip, obscuring the contact details (see attached screenshot). This occurs under both Ambiance and Radiance. Is it this bug I'm seeing or should another report be filed?

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

No, I guess my issue was bug #929651.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.