Empathy sometimes fails to connect to IRC servers

Bug #456326 reported by Michael on 2009-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Empathy
Confirmed
Medium
empathy (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: empathy

I have Empathy set to auto-join various channels on freenode. Sometimes however it fails to do so with no visible reason, and I can't make it join without restarting Empathy.

System: Karmic 64bit, updated yesterday.

Michael (michaeljt) wrote :

Disabling and re-enabling that account sometime later made Empathy connect to the server.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
importance: Undecided → Low
Michael (michaeljt) wrote :

Tagged it onto the end of https://bugzilla.gnome.org/show_bug.cgi?id=602911 for now. Not sure if that is right or not, but hopefully someone upstream will read it and tell me :)

summary: - Empathy sometimes fails to connect to an IRC server
+ Empathy sometimes fails to reconnect to IRC servers

Yes, I would say it is the same bug

Changed in empathy (Ubuntu):
status: New → Confirmed
Michael (michaeljt) wrote :

I respectfully disagree with your subject change though. I was talking about the first connection to the server after starting Empathy.

Michael (michaeljt) wrote :

However, on the subject of connections and reconnections, I also discovered today that empathy sometimes switches to status "disconnected" when it loses the connection, and won't reconnect until that is manually changed back. I wonder how many connection problems are related to little bits of UI awkwardness like that?

summary: - Empathy sometimes fails to reconnect to IRC servers
+ Empathy sometimes fails to connect to IRC servers
Changed in empathy (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Triaged
Omer Akram (om26er) wrote :

Michael can you please try the development release of empathy from this ppa https://launchpad.net/~telepathy/+archive/ppa and test if you still face this issue.

Changed in empathy (Ubuntu):
status: Triaged → Incomplete
Michael (michaeljt) wrote :

I have enabled the PPA once off and pulled the current version of Empathy and associated packages. Please tell me if you want me to test any future versions, because I disabled the PPA again once I had them. Since this issue is not something I see every day, I will report back if I do see it again. If I don't report back within a week or two, you can probably assume that this is fixed (and I can still re-open it if you do close it). Thanks!

Michael (michaeljt) wrote :

Note: I am on Lucid now.

Michael (michaeljt) wrote :

I tried manually breaking and re-establishing my VPN connection a couple of times, which previously seemed to cause this bug to occur. Then I disabled and re-enabled the account and was re-connected immediately, as expected. Although my status is *still* (it always was) always "disconnected" unless I manually change it. Is that expected? Other than that, it looks so far like this is fixed in the PPA version. Any idea when it will hit mainline?

Michael (michaeljt) wrote :

Should this be fixed in the current repository version? I just got this again with 2.30.0.1-0ubuntu3. I suspended my laptop to RAM while Empathy was running, resumed it and ran it for an hour without an internet connection, suspended it again and resumed it at home with a wireless + VPN connection to the internet. Empathy was in the "disconnected" state (it starts up in that state and stays in it unless I manually change it. However it normally connects fine while in this state), and did not re-connect until I changed its state to "available". (Off-topic, but when I change the state back to "disconnected" it really does disconnect...)

Vish (vish) wrote :

Bug is still open upstream.

Changed in empathy (Ubuntu):
status: Incomplete → Triaged
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Confirmed
Michael (michaeljt) wrote :

Status update. At least currently the only times I experience something akin to this is when I have been recently disconnected and my old nick is still in use on the server. So it boils down to empathy not trying alternative nicks (which I think is another open bug). Other than that this no longer affects me.

Michael (michaeljt) wrote :

Ahem, yes that is bug 446200 reported by myself.

It is possible be the ports that are configured for the servers.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.