Ubuntu

Empathy sounds not in default ubuntu theme

Reported by Brian Curtis on 2009-07-17
290
This bug affects 53 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Brian Curtis
Nominated for Lucid by Omer Akram
Nominated for Maverick by Dennis Baudys
Karmic
Undecided
Unassigned
ubuntu-sounds (Ubuntu)
Low
Luke Yelavich
Nominated for Jaunty by Brian Curtis
Nominated for Lucid by Omer Akram
Nominated for Maverick by Dennis Baudys
Karmic
Low
Luke Yelavich

Bug Description

Binary package hint: empathy

2.6.31-3-generic #19-Ubuntu SMP Tue Jul 14 16:04:41 UTC 2009 i686 GNU/Linux

empathy:
  Installed: 2.27.3-2ubuntu3
  Candidate: 2.27.3-2ubuntu3
  Version table:
 *** 2.27.3-2ubuntu3 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Empathy sounds are not a part of the default theme in Ubuntu. Since its a big possibility that it will be default in ubuntu, then the sounds should be a part of the default ubuntu theme.

Brian Curtis (bcurtiswx) wrote :

For sound notification apparently the default ubuntu sound theme contain only the phone-incoming-call sound, you need to install this one :
http://people.freedesktop.org/~mccann/dist/sound-theme-freedesktop-0.2.tar.bz2 to have all the required sounds

Guillaume Desmottes (cassidy) wrote :

This is a sound theme issue, not an Empathy one.

I opened #388519 listing all the sounds used by Empathy which are missing in Ubuntu's sound theme.

Changed in empathy (Ubuntu):
status: New → Invalid
Nicolò Chieffo (yelo3) on 2009-07-17
Changed in ubuntu-sounds (Ubuntu):
status: New → Confirmed
Brian Curtis (bcurtiswx) wrote :

From Bug#388519 Xavier

Actually Empathy uses:

"message-new-instant"
"message-sent-instant"
"service-login"
"service-logout"
"phone-incoming-call"
"phone-outgoing-calling"
"phone-hangup",

Jaunty only provides "phone-incoming-call". All others are missing. I don't know for karmic.

zerwas (zerwas) wrote :

This bug still affects 9.10 Karmic Koala.

Changed in ubuntu-sounds (Ubuntu Karmic):
importance: Undecided → Low
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
description: updated
Jacob Peddicord (jpeddicord) wrote :

Michael:

There's no real need to update the description with a different Empathy version. As previously stated, the problem lies in missing sounds in ubuntu-sounds. There is no issue with Empathy.

Michael Chang (thenewme91) wrote :

I'm aware of that.

I didn't actually intend to change the description, but I think the edge server may have mangled with the whitespace when I unintentionally submitted my changes to the server by clicking the edit icon twice.

Sorry for the noise.

Changed in ubuntu-sounds (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
Brian Curtis (bcurtiswx) on 2009-08-27
tags: added: metabug
tags: removed: metabug
Brian Curtis (bcurtiswx) wrote :

Sebastien: is this bug still going to get attention before karmic?

Guillaume Desmottes (cassidy) wrote :

Yes; lot of sounds are still missing.

Sebastien Bacher (seb128) wrote :

do you have recommendations on what needs to be done there? I've no clue about sound themes and which one could be used there and how

Guillaume Desmottes (cassidy) wrote :

I'd say the more important ones are:
"phone-outgoing-calling": no sound in the theme so you don't hear anything
"phone-incoming-call": there is a sound but it's really awful :)

Brian Curtis (bcurtiswx) wrote :

another important one is the one that notifies you that you have received a new instant message. I imagine there will be an uproar if people can't tell when they've been sent a new message with audio.

Yes, there certainly will be if this isn't addressed. There is already some tension with Empathy being default, so lets try and keep them at bay :).

At the very least, we could just take the sounds from purple and use them.

I could also fashion some sounds if any are willing to accept contributions

This bug is still present in Karmic Beta.
'~ uname -a; Linux T43 2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:55:55 UTC 2009 i686 GNU/Linux'

mercutio22 (macabro22) wrote :

I see this marked as invalid. Does it mean it won't be fixed or just that this isn't empathy's bug? In the last case which package should this bug target?

Brian Curtis (bcurtiswx) wrote :

this means invalid for empathy.. since it's an ubuntu-sounds problem not including the sound files that empathy uses

On Sun, Oct 4, 2009 at 6:35 PM, mercutio22 <email address hidden> wrote:
> I see this marked as invalid. Does it mean it won't be fixed or just
> that this isn't empathy's bug? In the last case which package should
> this bug target?
>

The bug should be targeted at ubuntu-sounds package, just like it is...

Mr. Bacher, is there any plan or idea on what sounds are going to be used?

Sebastien Bacher (seb128) wrote :

not sure what changes are required as stated before but if nobody steps with suggested changes it seems that one will not change before karmic now

Brian Curtis (bcurtiswx) wrote :

I see this being solved in two ways.
1- we can take the sounds used in pidgin and just have empathy use those
2- we can take the sounds from empathy's freedesktop.org sounds and
implement those

I am working 9-5 ET, and I will discuss this with the telepathy people
once I get home.

I understand your confusion Sebastien. If you are on this evening
(ET) then I will talk to you then.

~Brian C.

On Mon, Oct 5, 2009 at 8:17 AM, Sebastien Bacher <email address hidden> wrote:
> not sure what changes are required as stated before but if nobody steps
> with suggested changes it seems that one will not change before karmic
> now
>
> --
> Empathy sounds not in default ubuntu theme
> https://bugs.launchpad.net/bugs/400485
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Research is what I'm doing when I don't know what I'm doing.
--Wernher Von Braun
"The second law of thermodynamics: If you think things are in a mess
now, JUST WAIT!!"
----------------------------------------------------------------
The Statement Below is True
The Statement Above is False
----------------------------------------------------------------

Changed in ubuntu-sounds (Ubuntu Karmic):
assignee: Sebastien Bacher (seb128) → Luke Yelavich (themuso)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sounds - 0.12

---------------
ubuntu-sounds (0.12) karmic; urgency=low

  * Drop card_shuffle.wav as its not used by anything any more.
  * debian/control: Remove conflict against gnome-audio as ubuntu-sounds no
    longer has any of the same files. (LP: #343288)
  * Import some sounds from the freedesktop sound theme needed for empathy
    notifications. (LP: #400485)
  * debian/copyright: Updated to cover newly added sounds.

 -- Luke Yelavich <email address hidden> Mon, 12 Oct 2009 10:56:43 +1100

Changed in ubuntu-sounds (Ubuntu Karmic):
status: Confirmed → Fix Released
Xavier Claessens (zdra) wrote :

Sorry but this bug is not solved yet, from the list I posted:

"message-new-instant" -> OK
"message-sent-instant" -> Missing
"service-login" -> OK
"service-logout" -> OK
"phone-incoming-call" -> OK
"phone-outgoing-calling" -> Missing. "phone-outgoing-busy" is now provided but not yet used by empathy
"phone-hangup" -> Missing and not used by empathy it seems... It is in our list of sound but I see nowhere it is actually called. So you can ignore that one.

Changed in ubuntu-sounds (Ubuntu Karmic):
status: Fix Released → New
Luke Yelavich (themuso) wrote :

FOr the files that are missing, the freedesktop does not have anything to satisfy those. If you could point me to some files that could fill this task, and hae either GPL or creative commons license, then I'd be happy to add them.

Gnome-look.org has some very nice sounds. My favorite is Borealis:

http://gnome-look.org/content/show.php/%22Borealis%22+sound+theme?content=12584

^Popup seems like a good contender for "message-sent-instant"

manzur (sl-solaris) wrote :

I am going to download it to hear them

Karmic is set to release in less than a week.

If at all possible, could it be done so that ANY sound is used for each action? Something that just sounds okay? Lots of people are going to get a bad impression with Empathy when they find out that their sound notifications are broken.

By my last comment, I meant just finding some sounds that can do the job and use them for now.

Is this bug still alive? I don't use Empathy.

Brian Curtis (bcurtiswx) on 2009-12-12
Changed in ubuntu-sounds (Ubuntu Karmic):
status: New → Fix Released
Changed in ubuntu-sounds (Ubuntu):
status: New → Fix Released

Released where?
The bug still persists with me.
'T43:~$ uname -a; Linux T43 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686 GNU/Linux'

Id2ndR (id2ndr) wrote :

One part of this bug is fixed, but there stiil is some actions that doesn't have any sound associated with.

Changed in ubuntu-sounds (Ubuntu):
status: Fix Released → Confirmed
Changed in ubuntu-sounds (Ubuntu Karmic):
status: Fix Released → Confirmed

I have ubuntu-sounds 0.12 (in Karmic) and sound notifications set in Empathy but still get no sound alerts ... this bug does not seem to be fixed for me for **any** empathy sound notification.

Carlos

tekstr1der (tekstr1der) wrote :

Ditto Carlos. I do remember having working empathy sounds as of karmic release. I've not used it since and just discovered it is now silent, though configured properly.

tekstr1der (tekstr1der) wrote :

I was wrong. If I adjust my volume to max, I can faintly hear service-login.ogg when empathy starts.

Arun (akarun87) wrote :

I am pretty sire

Cheers,
Arun

Sent from my nexus one.

On 12 Feb 2010 19:51, "tekstr1der" <email address hidden> wrote:

I was wrong. If I adjust my volume to max, I can faintly hear service-
login.ogg when empathy starts.

--
Empathy sounds not in default ubuntu theme
https://bugs.launchpad.net/bugs/400485
You received ...

Arun (akarun87) wrote :

Sorry about that.
I am pretty sure that there is no sound when I call somebody. It says
ringing although I don't hear anything.

Cheers,
Arun

Sent from my nexus one.

On 12 Feb 2010 20:04, "Arun" <email address hidden> wrote:

I am pretty sire

Cheers,
Arun

Sent from my nexus one.

>
> On 12 Feb 2010 19:51, "tekstr1der" <email address hidden> wrote:
>
> I was wrong. If I adjust...

>
>
> --
> Empathy sounds not in default ubuntu theme
> https://bugs.launchpad.net/bugs/400485
You received ...

Pavol Klačanský (pavolzetor) wrote :

no sound in lucid too

rifter (rifter0x0000) wrote :

I have no sounds, either (in Karmic). I installed the freedesktop theme as above but that did not make the sounds work. Is there some workaround to get sounds in Empathy?

William Wolf (throughnothing) wrote :

No sound for me in lucid for empathy. I have sounds for everything else...rhythmbox, banshee, firefox/flash, epiphany/flash, vlc, totem...just about everything else I have tried. I also tried installing sound-theme-freedesktop and switching my sound theme to "default" from "ubuntu" and I still get no sounds with empathy.

tristan8276 (tristan8276) wrote :

The notification sounds work for me under Lucid Beta. However, they do not work on my girlfriend's Acer AspireOne netbook with Lucid Beta. I've checked under System -> Preferences -> Sound and I have the same available sounds listed under the Ubuntu sound theme that she does. Is it a missing pointer or reference somewhere?

lizardmenke (lizardmenke) wrote :

I just installed the brand new final release of Lucid. And the sound notifications for Empathy don't work here.
All other sounds work just fine.

razor7 (ghiamar) wrote :

The same here...!Lucid, empahy no sounds!

razor7 (ghiamar) wrote :

Installing this sound theme solves the problem http://cgit.freedesktop.org/sound-theme-freedesktop/

Omer Akram (om26er) wrote :

Karmic has been released for a while so marking karmic task as wont fix.

Changed in ubuntu-sounds (Ubuntu Karmic):
status: Confirmed → Won't Fix
chreko (chreko) wrote :

Sound is working in the final release of Lucid after (1.) installing the sound-theme-freedesktop package and (2.) activating the sound theme under System > Preferences > Sound by selecting "Default" instead of "Ubuntu".

Marcus Habermehl (bmh1980de) wrote :

What about to adding symlinks to the ubuntu theme and making the freedesktop theme a dependency?

Ron_ (ronald-liebman) wrote :

No sounds in Karmic. Same as #37 and #44, I installed freedesktop and activated Default preference.

Re: #43. Karmic was my first (and last) Ubuntu install. Since mid-2009, a pattern has emerged:
a) Release software filled with regressive bugs.
b) Trivialize complaints.
c) Mark bugs as too old to matter.
Theoretically, this could go on indefinitely, without ever adequately prioritizing users' concerns. This is no way to build market share, and the market is noticing.

Dennis Baudys (thecondordb) wrote :

Hi!

This bug affects me too and is annoying!

The bug still exists in the current Ubuntu 10.10 Maverick Beta. Given the fact that Empathy is the new horse to bet on (installed by default) and Empathy doesn't even have the possibility to be configured in a way that received messages make a window pop up, this »no-sound-by-default-bug« makes it even worse!

The only way to be informed about new messages waiting in Empathy is the message indicator icon in the Gnome panel on the top. That icon didn't even have some color in the default theme shipped with Ubuntu up to 10.04 Lucid – but was simply colored »in another gray« (but I may remember wrongly). Now – with 10.10 Maverick beta and that theme currently shipped by default – the icon switches to a green colored one, indicating new messages (in Empathy) at last.

Please think about it …
Thank You and Regards,

Dennis Baudys

PS: I nominated this bug for being fixed (a good .oga file copied to the correct location and renamed to .ogg or what else – maybe even a fix for, or some default sound shipped with Empathy?) for the Maverick release.

Brian Curtis (bcurtiswx) wrote :

I don't have this issue anymore with maverick. I hear a message notification sound upon new messages, both first and continuing message. There have been sound updates, do you still experience this with an updated system?

nebcanuck (nebcanuck) wrote :

Running an updated Maverick and the issue is still there for me.

So far as I know, the issue has never been with incoming messages when the window isn't focused. The only other sound included is the "contact comes online" sound, which is a duplication of Pidgin's online sound. After that, there are no sounds even if you enable them. I don't get any notification sound when I speak in a focused chat, when a contact speaks to me in a focused chat, or when a contact goes offline.

Is this any different for anyone else?

ckpinguin (ckpinguin) wrote :

Can't believe this still doesn't work on some distros...

Linux Lover (obake) wrote :

I will silently pray that this gets fixed.

John Bester (john-bester) wrote :

It is a pity, really, to think that programmers have time to waste like this. Had it been me, I would have simply added an "Ubuntu with sound" scheme in 2009 when this bug was first reported. Yes, here we are in 2011 and the only time spent on the bug was posting 50 replies to this bug.

Brian Curtis (bcurtiswx) wrote :

there should be sounds for: received, sent, new convo, contact online/offline, account online/offline

Which are people not getting?

We're going through right now and trying to get the correct sounds in. Thanks for your responses.

Ken VanDine (ken-vandine) wrote :

I just reviewed sounds provided by the freedesktop sound theme and the ubuntu sound theme, the relevant sounds missing from ubuntu-sounds are:
 - phone-incoming-call.ogg
 - message.oga

We need to look at adding those to ubuntu-sounds

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sounds - 0.13

---------------
ubuntu-sounds (0.13) natty; urgency=low

  * Imported message.ogg and phone-outgoing-calling.ogg from the freedesktop
    sound theme needed for empathy notifications. (LP: #400485)
 -- Ken VanDine <email address hidden> Wed, 02 Mar 2011 10:04:05 -0500

Changed in ubuntu-sounds (Ubuntu):
status: Confirmed → Fix Released
gjs (frans-stekelenburg) wrote :

Having this issue for the longest time, and amazed that something basic like this does not get solved, I have found a possible workaround that solves this for me: Instantbird 1.0

http://www.instantbird.com/

I have sound now..

This bug is fixed in Natty.
Using Pidgin also can be a solution.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions