Open (but do not raise) new conversation windows automatically

Bug #206547 reported by Mahdi on 2008-03-25
384
This bug affects 70 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
GNOME Shell
New
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
empathy (Ubuntu)
Wishlist
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher

Bug Description

Binary package hint: empathy

On up-to-date hardy amd64, when I receive a message, the tray icon start blinking but the message is not shown. I have to click the tray icon to see it on a new window (or an open window, depending on my confs). This is very annoying, specially if my panel containing the tray is set to autohide. There should be an option to open messages automatically and/or a better visual message notification (like pidgin's guifications).

Design "spec": https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/206547

Related branches

Neo_ocm (neo-ocm) wrote :

Same problem happens to me.
Window doesn't pop when being talked, my responses are always late!
If the conversation window already exists sometimes flashes sometimes not.

Kẏra (thekyriarchy) wrote :

I'm confirming this. It should go on the wishlist

Changed in empathy:
status: New → Confirmed
Changed in empathy:
importance: Undecided → Wishlist
Xavier Claessens (zdra) wrote :

If I'm working on something else I don't want a chat window to popup. New conversation should not be intrusive. Unless you have a great idea to propose, I think this bug should be closed WONTFIX.

Hi Xavier.
Please dont mark this as WontFix.

I'm going to tell you two thing that all Devs hate:

1 - please copy and improve the behavior of your competitors (pidgin);
2 - give user choices;

for number one, u wont see users complaing about it, do you? Users like this, thats why there is this ticket and 3 ppl confirming it.

for number two, i would go with this options:
* silent, like the actual behavior;
* show up on the taskbar and blink (it still is messy when user hides taskbar, or on those new netbook laptops without it, but that would be version 2.0, lol);
* full blown popup, nasty, irritating, keyboard typing catcher.

and then let user choose the one they like. i would use both 2 and 3, depending on my status...

Niels Egberts (nielsegberts) wrote :

I also would like to see this implented.

Taavi S. (tuisu) wrote :

I second the need to rethink message notification, it is too unintrusive.

My suggestion would be to:
1. open the conversation window when you're available (eg. you're available for chat)
2. show blinking systray icon when you're busy or away (eg. you're doing something important and don't want to be disturbed)

Ian Higginson (xeriouxi) wrote :

I think this would be a good option to implement, too.

I like how Empathy integrates into Gnome as well as it does, etc. but it is missing some of those little things that people are used to, like the message notifications. I feel Empathy has got a very good base to build upon, and adding those little things here and there will only increase it's usefulness! =)

Saul Howard (saul-convictfilms) wrote :

I think this is a very important fix.

Automatic opening of chat windows should at least be optional. In fact I like Taavi S.'s idea best (to open automatically when you are available, and to use the blinking tray icon behaviour when you are busy etc).

For myself, I limit all chat windows to a specific workspace, so they can never disturb me or be intrusive. One should not assume that just because it annoys you, it annoys everybody.

Arie Skliarouk (skliarie) wrote :

I second the Saul Howard's opinion.

Skype has a nice bubble notifications, where the notification includes the message that you received. If you want to answer to the message, you can click on the baloon and it will take you directly to the chat window with the sender.

summary: - No option to open messages automatically
+ Add option to open messages automatically

I just uninstalled empathy from koala and went back to pidgin, as my first day with it i missed around 30 IM's as there was only a blinking icon on the emapthy window and i never leave that window in context (who does?). My opinion, at least give people the option to have a popup.

Tim Besard (maleadt) wrote :

I'd love to see a different behaviour as well. I agree on the fact that chat windows shouldn't be too intrusive, but even when I'm occupied I'd love to get _any_ indication of a new chat. Taavi's solution is indeed a neat one, and the current situation fits the 'invisible' status better IMHO (ie. when I want to work without getting disturbed, unless I initiate the chat myself).
Especially when I already have a chat opened on another desktop, it wouldn't hurt opening the new chat in that window already.

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Steven Danna (ssd7) on 2009-10-31
Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Gert (mar-rocca) wrote :

So, where does this story continue? Can someone please direct me to a link or something? (the missed IM calls are driving me crazy... it's surely my fault but I tend to miss the little notification icon's change)

Lightbreeze (nedhoy-gmail) wrote :

Gert you can follow the progress of the bug at https://bugzilla.gnome.org/show_bug.cgi?id=548754

Gert (mar-rocca) wrote :

thank you Lightbreeze

M (mzmcgrat) wrote :

According to http://library.gnome.org/devel/hig-book/stable/desktop-notification-area.html.en
In reference to animation in the Notification Area, it says, "Do not rely on blinking or animation as a means of alerting the user to any particular event." I too believe that ONLY a small "blinking" icon in the Notification Area on the Gnome Panel is unexpected/wrong behavior. In fact, when trying to use the Google Talk video feature, I got a ringing sound but no obvious means to answer the call when a contact called me, even though the chat window and contact list were visible and my status was set to "available". The "accept call" dialog window appeared only after clicking the icon on the Notification Area.

This behavior is like trying to answer a phone call when your phone is hidden somewhere in your room. The default behavior should be to pop up a new message tab, window, or dialog box when a contact first messages you or requests your immediate attention with something like a call.

I'd be OK with this behavior if there was at least a way to open the new message from the keyboard without having to click on the blinking icon. Also the blinking icon is hideous by the way.

kai_en (kaien13) wrote :

New message should be pop into the panel while being minimised and blinking. This would easily alert the user without being too intrusive.

M (mzmcgrat) wrote :

In what I think may be a duplicate bug report to the one already given in this thread, someone has posted a patch that may improve this functionality. I have not tested it, though. https://bugzilla.gnome.org/show_bug.cgi?id=585914

I know this is being worked on upstream, but perhaps the papercuts team should give some advice on how best to fix it?

Vish (vish) on 2009-11-25
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → lucid-round-4
status: New → Triaged

The paper cut would be to change the default behavior, not to implement and present the user with an option. I think we should create and milestone the more direct paper cut, "Open (but do not raise) new conversation windows automatically".

David's proposal sounds like a good suggestion.

Like so many have said before me, it would be really nice to be able to click the notification bubble to enter the conversation. I mean, why would you be interested in knowing that someone has sent you a message unless you are able to reply to it.

A drop-down text editor for replying directly in the notification would also be awesome I think. Maybe two buttons. One to open a new window, one to do a quick reply in the notification. Don't know if it is possible, but damnit, it would be a clever and smooth way to handle IM's.

summary: - Add option to open messages automatically
+ Open (but do not raise) new conversation windows automatically
description: updated
Guillaume Desmottes (cassidy) wrote :

I have a branch implementing this (see the upstream bug) but it needs some testing to be sure it always behave properly.

I strongly disagree with opening windows automatically by default, It breaks all indicator applet idea and in my humble opinion current way is the best (give indication that you need to give attention to conversation. If you can't then you don't have tens of windows lingering open in the background). Popup windows always have been bad stuff, and I don't see any real reason to enable it by default just because of legacy of IM clients. Option will be available and that's nice (thanks to Guillaume and other devs). But I think it should be left as it is.

It could be enabled when accounts are imported from Pidgin or some other IM client, for example.

Matthew Paul Thomas (mpt) wrote :

Actually, it's not true that it "breaks all indicator applet idea". The messaging menu is a useful aggregator of incoming messages, but we never intended it as the only method of notifying you of new conversations -- it's not noticable enough for that. New IM conversations should open a window in the background, and incoming audio/video calls should open a morphing window in the foreground.

Matthew, no, it is true, it does break current system. I remember quite clearly that concept of "nothing interferes with my work" was championed by Canonical, witch introduced notifications and indicator. It was clear direction and I welcomed that. Now again there is change in things. Sorry, but pop-under window is *still* a interference. I don't want windows to be opened automatically, period. No updates, no messages.

"...but we never intended it as the only method of notifying you of new conversations -- it's not noticable enough for that"

It is noticeable, if it's explained. Of course, it is easer to revert back to old ways instead of explaining. Sometimes users should be educated, not pleased.

No offence, but IMHO it is very huge step backwards.

ukblacknight (tom-blacknight) wrote :

If the windows are spawning behind other windows, how is it an interference? They're not disrupting work flow as focus isn't being stolen and they're not suddenly covering up any windows that are at the front.

I've never found fault with the way that Pidgin and emesene deal with conversation windows spawning. The situation is, is that many people are removing Empathy due to the fact that they're missing the notification about a conversation, and they have their main contact window closed. I have myself missed many conversations as they were waiting for me to open them from the main window - not ideal. This was one of the many reasons why I dismissed Empathy.

Nurturing old behavioural models isn't exactly best practise. Notification in right top corner - what else do you need? Do you really will follow how many conversations and open windows you have under your current active?

ukblacknight (tom-blacknight) wrote :

9 times out of 10 I miss the notification in the top right (in reference to notify-osd), and I hardly ever notice the indicator-applet status, usually because it never catches my eye to grab my attention.

I understand that nurturing old models isn't always the best, and that it does seem inconsistent with what notify-osd and indicator-applet are trying to achieve, however it is a tried and true method, and it seems to work well.

The busy status (or do not disturb) is good at keeping the IM client discreet - maybe empathy shouldn't spawn new windows when the status is busy, but do so when the status is not busy. If you're working, set to busy and you'll tend to conversations when you're ready, or in any other scenario, you don't mind windows opening.

"Do you really will follow how many conversations and open windows you have under your current active?"

I don't quite get what you mean here! I understand that English probably isn't your first language so no worries!

Matt Fletcher (mattfletcher) wrote :

What's proposed here isn't simply nurturing an old model. Let me pose you this question. If when you received a telephone call your phone did not ring, but instead a small light turned on on the side of the handset, don't you think you would miss calls?

The nature of an IM client is fundamentally different to that of other programs. It demands an immediacy that a notification applet simply cannot provide. It's one area where I don't want my PC to stay out of the way.

I've found how Pidgin handles this issue very well for tabbed chat windows.

When you're currently focused on a chat window, I get the upper right
notification about a new message and a new tab is added in the current chat
window. Then, I only have to press Ctrl-Tab to see to the next new
messages. It makes it easy and fast to find new messages when working in a
tabbed window.

I think that would make sense because when you change conversation tab soon
after receiving a new message notification, you are most likely looking for
the new conversation to which to reply. If there is a timer that signals
that a new message is old already, then the behavior of Ctrl-Tab (or
Ctrl-PageUp/Down) can return to default next/previous tab.

When you're not focused on a chat window, focusing on a tabbed chat window
can automatically set focus on the new conversation, as again, the most
likely reason for focusing on a chat window soon after receiving a
notification is to interact with the new message...

On Thu, Jan 14, 2010 at 11:30 PM, ukblacknight <email address hidden>wrote:

> If the windows are spawning behind other windows, how is it an
> interference? They're not disrupting work flow as focus isn't being
> stolen and they're not suddenly covering up any windows that are at the
> front.
>
> I've never found fault with the way that Pidgin and emesene deal with
> conversation windows spawning. The situation is, is that many people
> are removing Empathy due to the fact that they're missing the
> notification about a conversation, and they have their main contact
> window closed. I have myself missed many conversations as they were
> waiting for me to open them from the main window - not ideal. This was
> one of the many reasons why I dismissed Empathy.
>
> --
> Open (but do not raise) new conversation windows automatically
> https://bugs.launchpad.net/bugs/206547
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Chat app, and Telepathy user interface: Unknown
> Status in One Hundred Paper Cuts: Triaged
> Status in “empathy” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: empathy
>
> On up-to-date hardy amd64, when I receive a message, the tray icon start
> blinking but the message is not shown. I have to click the tray icon to see
> it on a new window (or an open window, depending on my confs). This is very
> annoying, specially if my panel containing the tray is set to autohide.
> There should be an option to open messages automatically and/or a better
> visual message notification (like pidgin's guifications).
>
> Design "spec": https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/206547
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/empathy/+bug/206547/+subscribe
>

Matthew Paul Thomas (mpt) wrote :

Pēteris, sorry, but you're mistaken. <https://wiki.ubuntu.com/NotificationDesignGuidelines> has said the same thing on this topic since I wrote it a year ago: "When a notification is not time-critical, and there is a relevant window to display it in, present the notification as a banner or other text in that window ... if the window is not currently open, you can open it automatically, in the background to minimize accidental clicks."

Anyway, one of my colleagues has just completed a week of user testing of the upstream version of Empathy, with 16 separate participants. We'll publish full results in a couple of weeks, but one notable preliminary result is that for many of the participants, when someone started a new conversation with them, or tried to send them a file, and Empathy showed this using its notification area item, they just didn't notice.

David Baucum (maxolasersquad) wrote :

This has also bugged me about empathy. I thought I would eventually get used to it, but I never did. This behavior has caused me on several occasions to reply to the wrong person, or just simply not notice that someone has IMed me.

Jancis (beaver-inbox) wrote :

We should be more open-minded. I have previously replaced empathy with pidgin just because of this behavior - I have missed important conversations because I don`t look all my time at screen so I miss osd notification. If this new usability is considered to be forced, devels could at least put an option to enable those popup windows somehow.

Alex Launi (alexlauni) on 2010-03-05
Changed in empathy (Ubuntu):
assignee: nobody → Alex Launi (alexlauni)
assignee: Alex Launi (alexlauni) → nobody
Changed in hundredpapercuts:
assignee: nobody → Alex Launi (alexlauni)
status: Triaged → In Progress
Alex Launi (alexlauni) wrote :

This patch is only a partial solution to the problem but it's a start. In its current form, the first message received for a new conversation that is not the first (in other words, the first message of a conversation to open a new tab instead of a new window) does not set the urgent hint or update the window title. Any subsequent messages behave normally. This is because the new-message signal needs to be connected to earlier, but I need to go to bed and can't figure out how to accomplish this right now. Hopefully someone else will have time, or I will later. Anyway it can't hurt to post here in hopes that someone else will look at it.

Upstream says that this feature should not be merged for lucid anyway as it needs more consideration on how to be done right. I'm not sure I agree with them, but they should be represented none the less.

tags: added: patch
Sebastien Bacher (seb128) wrote :

the change is non trivial and upstream recommended about it, it seems rather something for lucid+1

tags: added: patch-upstreaminput
removed: patch
yannickm (yannickm) wrote :

This is a *VERY SERIOUS* flaw in empathy.

A messaging system where users will often fail to see they have been messaged is like a mobile phone that has a barely audible ring tone and doesn't vibrate.

How would you feel if you missed 70% of the phone calls that you received .. You'd throw the phone in the garbage can, or exchange it.

Now, the fact the empathy has such a ridiculously huge flaw is bad. But the fact that it's now the DEFAULT instant messaging software of ubuntu is *REALLY BAD*

That flaw should either be fixed ASAP, or empathy should be removed from the default distribution and pidgin put back in as default.

Sebastien Bacher (seb128) wrote :

the previous comment is not rational, you can install piding if you want and auto-opening dialogs is not the only way to claim the users attention there

yannickm (yannickm) wrote :

True, it is not the ONLY way to get the user's attention.

However, the current one (a small icon on the corner of the screen) is an *incredibly bad one*.

It's not just my opinion of the ones of all the people who's complained on this issue in this bug, but it's been well documented here https://wiki.ubuntu.com/EmpathyVsPidginUsability

Personally the first thing i do is indeed to install pidgin, however i think it's terribly bad for ubuntu as a whole to be inflicting empathy on new users in it's current state. Keep in mind first impressions count alot, so software that is installed by default should work well.

Which is why i think it should be either fixed by providing some kind of notification that is more efficient, or otherwise it shouldn't be the default one in ubuntu

Changed in empathy:
status: Unknown → Confirmed
frizzle21 (frederik-nnaji) wrote :

anybody who would like to follow this upstream can go to bugzilla here:
https://bugzilla.gnome.org/show_bug.cgi?id=585914

that's the current place to check this thing out.

Gordon (spambox-thisblueroom) wrote :

I loathe Pidgin's UI, but I'll likely be switching back on Lucid if there isn't a patch for this soon.

I don't understand why people are starting yet another bug report flamewar over whether or not auto-opening windows for incoming new messages is the Right Way.

MAKE IT AN OPTION. Then people can turn it on, or off. :P

beytu (beytu) wrote :

Hi,

i'm also missing a lot of discussion. Now, i need to check every time if the notification area changes color :(. Isn't it possible to make it an option ? Or to make the super notification thing to blink ?

Michael Bohn (michaelwbohn) wrote :

I respond to most of my chats an average of 20-30 minutes late since I started using Empathy in 10.04. This is unacceptable. There shouldn't even be a debate about whether or not to include an option for this. Clearly people want it both ways, so make it work both ways. I have 5 monitors on my Ubuntu box at work and screen space is not an issue, so auto-raising the chat is preferred. Some people need chats to be very intrusive as they may need to address something urgent, as is the case for me at work. Can the people who disagree with having this feature explain to me how they are affected in any way by the addition of this option? Don't like it? Don't use it. It is as simple as that.

Michael Morgan (mikmorg) wrote :

I have another program that has similar behavior. It's called E-Mail. If I didn't want an instant notification, I wouldn't use IM! Why is this the default, let alone the ONLY OPTION?

Tom Goh (tomgohj) wrote :

Anyone know if there is a PPA for the patched version.

Daniel Wu (danielwu68) wrote :

With all due respect, I missed a lot of chats or responds them too late because of this "desired behavior". It is ok for developers not to change the design. I will just switch the IM client.
I wonder if there is a place to vote not to have Empathy as default IM client in up coming Ubuntu releases. Or perhaps a someone could point me a link to cleanly remove it from Ubuntu 10.04.

blaamann (baggetun) wrote :

Very annoying bug. Please fix it. This is a perfect example where user choice is the right option.

Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-4 → maverick-round-3-chat
Henry H (henry74) wrote :

This should definitely be an option. The purpose of INSTANT MESSAGING is to allow folks to communicate in real-time. If I fail to notice a chat message then it doesn't allow me to respond instantly.

The folks who are upset about "intrusion" shouldn't be concern if this is provided as an option. There is clearly enough of an issue here to have a MILLION THREADS like this one.

MAKE a POP-UP WINDOW AN OPTION, PLEASE.

Vish (vish) wrote :

This has now been fixed upstream

Changed in hundredpapercuts:
assignee: Alex Launi (alexlauni) → nobody
status: In Progress → Fix Committed
Changed in empathy (Ubuntu):
status: Triaged → Fix Committed
Changed in empathy:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.31.5.1-0ubuntu1

---------------
empathy (2.31.5.1-0ubuntu1) maverick; urgency=low

  * New upstream version:
    Bugs fixed:
    - Fixed #585914, Notification icon must be clicked before user can
      see new messages (lp: #206547)
    - Fixed #597124, Should make better use of libnotify actions
    - Fixed #599161, Audio/Video client should be a separated process
    - Fixed #617405, Empathy's short (menu) description should focus on its use,
      not the technology
    - Fixed #621753, Should be able to build with GTK+3
    - Fixed #622729, duplicated messages when opening chat
    - Fixed #623054, Should re-add data/org.gnome.Empathy.gschema.xml.in
      to POTFILES.in
    - Fixed #623112, Bip backlog are not displayed any more
    - Fixed #623117, Debug window should look for TP clients
    - Fixed #623358, Use TpSimpleHandler to handle text channels
    - Fixed #623396, Fixed some leaks
    - Fixed #623679, /join broken
    - Fixed #623756, empathy-CRITICAL **:
      empathy_chatroom_is_always_urgent: assertion `EMPATHY_IS_CHATROOM
    - Fixed #623817, Sync man pages with Debian
    - Fixed #623914, since tp-logger history is shown as normal messages
      in adium themes
    - Fixed #623937, empathy -h does not start hidden (lp: #603451)
    - Fixed #623972, Toggling [ ] Enabled in the accounts dialog with the
      keyboard doesn't work
    - Fixed #624054, Fix a memory leak in EmpathyAvatar
  * debian/empathy.1, debian/empathy-accounts.1, debian/empathy.manpages:
    - drop local manpages copies since they are updated upstream now
  * debian/empathy.gconf-defaults, debian/patches/02_notifications_focus.patch:
    - gsettings doesn't allow overwritting defaults yet to change the schemas
  * debian/empathy.install:
    - updated for the new files to install
 -- Sebastien Bacher <email address hidden> Tue, 13 Jul 2010 21:38:46 +0200

Changed in empathy (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) wrote :

Fixed in Maverick

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in empathy:
importance: Unknown → Medium
Omer Akram (om26er) wrote :

This bug dont seem fixed to me in Maverick is there any option somewhere to enable it?

Geert Jan Alsem (gj-alsem) wrote :

The option is currently called "Display incoming events in the notification area", and you have to turn it off to get new chats to pop up.

It's not a very clear name for the option I think, but they are aware of this upstream, as can be read in the GNOME bug report.

This is not working as expected, can you add another option to force this? Or make this clear that one has to uncheck "Display incoming events in the notification area". What is happening to me is (Maverick) that the icon blinks in the notification area but when I ALT+TAB to the chant window, the tab for the new chat isn't open unless I click the notification area. Is this a desired behaviour?

Aparte from that empathy is great and I would love to stick to it and not to go for pidgin.

timothymowens (timothymowens) wrote :

For the log of all that is Holy, please add this option. With it being an option, people can agree or disagree, but at least it will be there for people like me who are missing conversations because I don't have the contact list open all the time... I know, there's a little blue envelop in the Unity bar, but it's not enough for me.

rg (rob-themayfire) wrote :

These empathy options don't seem to have any effect for me at all. Ubuntu 11.10, Gnome Shell 3.2.1, Empathy 3.2.0.1. "Open chats in separate windows" is checked, "Display incoming events in the notification area" is not checked. Contacts window is open but not focused. Somebody IMs me and the ONLY indication I get is the popup message at center bottom of the screen for a few seconds. If I'm not looking at the screen just then there is NO visible indication of a new message. The chat icon thingie in the upper right is grey as ever, there is no chat window opened. Only way I know of a new message is if I happen to put my mouse in the lower right corner to see the notification bar.

I've tried it with "Enable Bubble Notifications" checked or unchecked. I've restarted gnome, I've rebooted the computer. Nothing I do changes the behavior as just described. What could I be missing??

(I'm having to use Pidgin because it does pop up chat windows for me. But even with pidgin running and empathy not running I still get hidden notifications in the hidden lower right bar, but they pile up forever cause I never have a reason to click them. So I'd LIKE to just use empathy, but not if I'm going to keep missing messages completely)

rg (rob-themayfire) wrote :

btw, besides the point of the preferences not working, I would be satisfied with ANY of the following when I receive an IM:

a. chat window pops up and steals focus (lots of people don't like this, which is understandable)

b. small NON-HIDDEN blinking icon somewhere (some people don't like this, which seems debatable)

c. small NON-HIDDEN non-blinking icon somewhere that merely changes color -- even that's easier to notice than something that requires me to keep compulsively checking with my mouse (how can anyone seriously be against this?)

Yet somehow, the only scenario I am able to get is:

d. small hidden icon

MightyE (mightye) wrote :

There is a regression which re-introduces this bug when running Gnome-Shell. I am running 3.2.2.1 from the Oneiric PPA (3.2.2.1-0ubuntu1~oneiric1).

I've tried every combination of options listed in this bug report, including the most common suggestion here and elsewhere to check "Open chats in separate windows" and uncheck "Idsplay incoming events in the notification area".

All new incoming chats appear ONLY in the notification area. If you're not either constantly checking your notification area, or not looking at the screen for the 3 or 4 seconds the new notification appears, there's no way to know someone has sent you a new message, and no combination of settings seems to affect this.

Tanner Watson (tannerwatson) wrote :

Experiencing the same behavior in Onereic x64 with Empathy 3.2.0.1.

I'm going to try @mightye's suggestion to see if new chat windows will open when receiving a message.
* Check "Open cats in separate windows"
* Uncheck Display incoming events in the notification area.

I'll post back once I see if this works with my setup.

Lars Karlitski (larsu) wrote :

This has indeed regressed. The problem is that telepathy-indicator doesn't approve incoming messages until the corresponding menu item is activated. ("Approving" means that the channel request is forwared to Empathy.)

My first idea to fix this was to make telepathy-indicator an observer only, not an approver. Empathy's "Display incoming events in the notification area" preference must be turned off for this to work, so that Empathy approves channels automatically and opens the chat window. However, as soon as the window is created, Empathy tells telepathy to remove the pending message, which means that the messaging menu doesn't contain the new channel (and doesn't turn blue). It works for every message after the initial one, though.

My second idea was to make telepathy-indicator approve every incoming channel request, so that it gets handled immediately by Empathy. This has the same problem as above: the first message is immediately removed and the messaging menu doesn't turn blue.

[Aside: Both solutions suffer from the problem that Empathy sometimes opens new chats in the foreground, even though the event is explicitely marked as not originating from a user action.]

I assume the last option is to patch Empathy to only remove pending messages when the window is focussed. Maybe someone with more insight into telepathy has a better idea on how to fix this?

Changed in telepathy-indicator:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Lars Uebernickel (larsu)
Chris Wilson (notgary) wrote :

If this is a regression, then shouldn't a new bug report be opened instead of reopening the old one?

Lars Karlitski (larsu) wrote :

Sure, why not: bug #1098549.

no longer affects: telepathy-indicator
Xavier Guillot (valeryan-24) wrote :

The option "display incoming events in the notification area" is no more available in last Empathy 3.6.3 shipped in Raring, so no more way to "force" any incoming message to put the chat window on the focus when Empathy is in the background !

The only indication goes on the MeMenu and I missed it often. There are no more notifications, too (bubbles on the top right corner via libnotify), as there are in Pidgin and I did not find any way to configure them, only sounds can be.

Well, is Empathy going like other Gnome apps (as Nautilus) and come with less and less functions or customization at each new version ? Why not let the user choose what he prefers as options ?

So is there a way to have this back in Ubuntu (via Dconf or everything else) ? I prefer Pidgin but Empathy is well more integrated now, with online contacts, Telepathy...

Thanks for your help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.