Comment 279 for bug 417757

I've noticed multisecond delays since switching to Lucid.
I have two boxes here. Identical resolv.conf entries for local DNS.
The Karmic machine responds instantaneously, the Lucid one takes several seconds for uncached addresses.

If I run:
ltrace wget -O/dev/null http://domainwebserver/url/

And I haven't hit this webserver on our domain recently, I can see it hang for several seconds on getaddrinfo.
It then hangs again resolving the full name (domainwebserver.ourdomain.local) if a redirect is issued.

So far I've tried:
disabling ipv6 in sysctl.conf and as kernel param in grub.
replacing the hosts line in nsswitch.conf w/ only "files dns" (the full hosts line in lucid works fine in karmic).

Uninstalling libnss-mdns.

Despite all this I repeatedly get hangs on getaddrinfo - other things respond quickly, such as dig and nslookup.

The only improvement I've experienced (and this was also new to Lucid) was that after I removed:
mdns4_minimal [NOTFOUND=return] I no longer got complete failure to perform lookups.
That line appears to work fine in Karmic, with the exact same servers.

I've also tried adding or removing wins from the hosts line in nsswitch.conf in case that was why Karmic was fast.
No difference. Whether wins was there or not, Karmic remained fast, and Lucid slow.