Comment 227 for bug 417757

1. Do you have the package source "karmic-updates" enabled? If no, enable it in Synaptic just for one time. After enabling it, do an update (but not an upgrade!).
2. Look for the libc6 package and choose the version (Ctrl + E, or in the "Package" Menu). Choose the newest which should be 2.10.1-0ubuntu16 from karmic-updates and click the green checkmark ;) Should work.