zic -l Foo/Bar leads to broken /etc/localtime

Bug #1212662 reported by Sandra Karuving on 2013-08-15
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Medium
Unassigned

Bug Description

since 13.04, zic seems to be broken.
Go to the Systemsettings set the correct time and turn on ntp. next, the timezone are correct but the time will always set tu UTC.

in a bugreport on kde.org > https://bugs.kde.org/show_bug.cgi?id=317999#c11 a userhas found out that it could be zic's fault

--kubuntu-dev note--
a user did some fiddling to zic and came up with a fix/workaround
http://www.kubuntuforums.net/showthread.php?62995-Wrong-time-zone-on-your-clock-Help-Kubuntu-devs-create-a-fix&p=330437&viewfull=1#post330437

in particular the problem is that zic -l Foo/Bar will copy Foo/Bar which on debian systems is a relative symlink, so /etc/localtime ends up being broken since it doesn't point to an actual file anymore.

this issue seems to be affecting all of debian and pretty much renders zic useless for purposes of setting the system timezone.
----

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libc-bin 2.17-91ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-5.17-lowlatency 3.10.2
Uname: Linux 3.10.0-5-lowlatency x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Thu Aug 15 13:14:33 2013
Dependencies:
 gcc-4.8-base 4.8.1-8ubuntu1
 libc6 2.17-91ubuntu1
 libcap2 1:2.22-1.2ubuntu2
 libgcc1 1:4.8.1-8ubuntu1
 multiarch-support 2.17-91ubuntu1
InstallationDate: Installed on 2013-06-06 (69 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: eglibc
UpgradeStatus: Upgraded to saucy on 2013-06-17 (58 days ago)

Sandra Karuving (lumks) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed
description: updated
Changed in eglibc (Ubuntu):
importance: Undecided → Medium
summary: - broken zic set wront time via ntp
+ zic -l Foo/Bar leads to broken /etc/localtime
description: updated
dino99 (9d9) wrote :

This is no more a supported version now

Changed in eglibc (Ubuntu):
status: Confirmed → Invalid
Adolfo Jayme (fitojb) on 2015-05-05
Changed in eglibc (Ubuntu):
status: Invalid → Confirmed
dino99 (9d9) on 2015-05-05
tags: removed: raring saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments