Comment 33 for bug 1453738

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ecryptfs-utils - 107-0ubuntu3

---------------
ecryptfs-utils (107-0ubuntu3) wily; urgency=medium

  * Rename libecryptfs0 to libecryptfs1 and adjust the packaging. It has
    actually shipped libecryptfs.so.1 since at least trusty. Add
    C/R/P: libecryptfs0 for smoother upgrades, this needs to be kept until
    after 16.04 LTS.

ecryptfs-utils (107-0ubuntu2) wily; urgency=medium

  * Add setup-swap-check-links.patch: When commenting out existing swap, also
    consider device symlinks like /dev/mapper/ubuntu--vg-swap_1 or
    /dev/disks/by-uuid/ into account. Fixes broken cryptswap under LVM and
    manual setups. (LP: #1453738)
  * debian/ecryptfs-utils.postinst: On upgrade, uncomment underlying
    unencrypted swap partitions that are referred to by a device link when
    crypttab and fstab have a "cryptswap*" device referring to them.

 -- Martin Pitt <email address hidden> Thu, 09 Jul 2015 12:20:47 +0200