Upgrade Eclipse to 3.7.0

Bug #604390 reported by Victor Costan on 2010-07-11
438
This bug affects 83 people
Affects Status Importance Assigned to Milestone
eclipse (Debian)
Fix Released
Unknown
eclipse (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be nice to have Eclipse 3.7 in Oneiric.

Micah Gersten (micahg) on 2010-07-11
Changed in eclipse (Ubuntu):
importance: Undecided → Wishlist
zzz (oldman-deactivatedaccount) wrote :

This is clearly in-progress, as can be seen by the ongoing branch work in git.

http://git.debian.org/?p=pkg-java/eclipse.git

Changed in eclipse (Debian):
status: Unknown → New
Benjamin Drung (bdrung) on 2010-07-11
Changed in eclipse (Ubuntu):
status: New → In Progress
assignee: nobody → Benjamin Drung (bdrung)
Benjamin Drung (bdrung) on 2010-08-05
Changed in eclipse (Ubuntu):
assignee: Benjamin Drung (bdrung) → nobody
sandeep048 (sandeep048) wrote :
tags: added: upgrade-software-version
Marius B. Kotsbak (mariusko) wrote :

Could you update the PPA above for Natty please?

Marius B. Kotsbak (mariusko) wrote :

I tried the PPA above, and got version 3.6.0, but not the marketplace. Is that something that was added between 3.6.0 and 3.6.2? Or is it removed in the Debian version?

Achu (achu) wrote :

@sandeep048 i tried that PPA (https://launchpad.net/~eclipse-team/+archive/debian-package) on Natty after installing eclipse doesn't start. I only see the splash screen. it doesn't open at all. My afraid face this problem to.

Hanmac (hanmac) wrote :

@Achu Abebe: the problem is the SWT i think ... eclipse need swt 3.5 ... natty has swt 3.6

Benjamin Drung (bdrung) wrote :

Eclipse ships its own version of swt.

Changed in eclipse (Debian):
status: New → Fix Released
summary: - Upgrade Eclipse to 3.6
+ Upgrade Eclipse to 3.7
description: updated

PPA fails to work on 11.04 64bit

Mark Schmidt (schmidtm) on 2011-09-26
summary: - Upgrade Eclipse to 3.7
+ Upgrade Eclipse to 3.7.1

For anyone interested in eclipse 3.7, and waiting for ubuntu packages, debian experimental packages actually work well on oneiric (it doesn't on natty).
Get the .deb from the following url: http://packages.debian.org/experimental/eclipse
or add an experimental repository to your sources.list to get dependencies as well...

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package eclipse - 3.7.0-0ubuntu1

---------------
eclipse (3.7.0-0ubuntu1) oneiric; urgency=low

  * Upload to Ubuntu (LP: #860723).
  * Use pkg-config to determine CFLAGS and LIBS for gnomeproxy.
  * Eclipse 3.7 requires at least version 3.3 of asm3.
  * Update debian/copyright.
  * Drop xulrunner from Apport hook.
  * Update debian/watch file.
  * Add patch to find libjasper-java 5.5.33-1 on Debian.
  * Update lintian overrides.

eclipse (3.7~exp-5) experimental; urgency=low

  * Forced many Eclipse version qualifiers to "dist" to avoid buildd
    issues (new patch: forceContextQualifier.patch)

eclipse (3.7~exp-4) experimental; urgency=low

  * We need to install org.eclipse.equinox.concurrent in eclipse-
    platform-data in order for many features to work
  * Merge eclipse-plugin-cvs into eclipse-platform-data, updating
    package description accordingly. Added unversioned Replaces and
    Breaks.

eclipse (3.7~exp-3) experimental; urgency=low

  * Re-added main lucene bundle to eclipse-platform
  * Added myself to Uploaders, with permission

eclipse (3.7~exp-2) experimental; urgency=low

  * Fixed the regression to pde-build script in eclipse-pde.

eclipse (3.7~exp-1) experimental; urgency=low

  [ Andres Mejia ]
  * Update to my @debian.org email.

  [ Niels Thykier ]
  * New upstream release.
    - Built without xulrunner support (Closes: #631061)
  * Added Build-Conflicts to ensure xulrunner is not picked up if
    built in unclean chroots.
  * B-D on liblucene2-java (>= 2.9.4+ds1-3~) due to #631234.
  * Bump debhelper compat to 8.

eclipse (3.6.2~exp-1) experimental; urgency=low

  [ Anders Kaseorg ]
  * debian/patches/gnomeproxy-pkg-config.patch: Use pkg-config to find
    include files and libraries for libgnomeproxy. (LP: #749218)

  [ Benjamin Drung ]
  * New upstream version (Closes: #587742, LP: #604390).
    - Allows kernels with weird versions (LP: #600584).
  * Use a svn e3.6 branch snapshot of eclipse-build.
  * Drop four backported patches.
  * Drop fix-shell-script-perm.patch.
  * Refresh remaining patches.
  * Drop removed plugins and install new plugins.
  * Drop uname workaround.
  * Add six new patches.
  * Add three patches that moves commands from debian/rules into the ant build
    process.
  * Drop seven patches that are accepted upstream.

  [ Niels Thykier ]
  * Removed Adrian Perez, thanks for your support.
  * Updated debian/copyright.
  * Bumped B-D on icu4j.
  * Added B-D to build swt with webkit support.
  * Use mh_clean to clean up after the maven-repo-helper.
  * Pulled the eclipse-platform.NEWS from the master branch and removed the
    old NEWS file.
  * Reduced eclipse-plugins-cvs to a Suggests for eclipse-jdt. (LP: #657286)
  * Made eclipse-plugin-cvs an architecture all package.
  * Made SWT load its JNI from well defined location to prevent occasional
    extraction to ~/.eclipse.

  [ Andres Mejia ]
  * Numerous changes to eclipse packaging just to get eclipse building using
    sbuild.
    - Changes introduced to eclipse so that it builds with latest ant (1.8.2).
      This required updating eclipse-build-generatedScripts.tar.bz2 inside the
      debian directory and...

Read more...

Changed in eclipse (Ubuntu):
status: In Progress → Fix Released

I think we should re-open this because by now, 3.7.1 is out and is the target of this bug (as per the title).

On 09/28/2011 08:45 AM, Christoph Buchner wrote:
> I think we should re-open this because by now, 3.7.1 is out and is the
> target of this bug (as per the title).

I think you should say thank you, and help with it, if you want it.

There will always be a newer version that we want at the time a package is available for Ubuntu I assume...

sry, forgot my manners.
Thank you for packaging! Even though it's not really relevant for me anymore since i switched to a directly downloaded version quite a while ago.
I just wanted to point out that the 'fixed' status (about 3.7.0) is not in accordance with the bug title (upgrade to 3.7.1.), and therefore 'fixed' status is wrong. Sorry if something else was implied.

Benjamin Drung (bdrung) wrote :

Please open a new bug for 3.7.1. We use eclipse-build as upstream and they haven't released the eclipse 3.7.1 sources yet.

summary: - Upgrade Eclipse to 3.7.1
+ Upgrade Eclipse to 3.7.0

Thanks. I just did (bug #861755) and subscribed the "original reporter" - Mark Schmidt, who changed the summary in this bug.

Andrew Cowie (afcowie) wrote :

I would note in passing that this bug started as "It would be nice to have Eclipse 3.6 in Maverick" which was filed over a year ago when all Ubuntu had was an outdated 3.5.2 package. We never did get a 3.6 package, so everyone I know has been downloading binaries from eclipse.org - which is obviously a behaviour we want to disincent.

The real issue here is that Eclipse's June releases are right around freeze time for the Ubuntu's October release. That creates all kinds of problems, especially if the just-released Eclipse isn't packaged in Debian yet either. So, it's nice to see the Ubuntu developers now seem better able to track upstream.

Hopefully we'll be able to bring 3.7.1 and further 3.7.x into Oneiric as they come out.

AfC

Marius B. Kotsbak (mariusko) wrote :

Also see bug #882436 about missing marketplace client.

Marius B. Kotsbak (mariusko) wrote :

See bug #1019273 for the next upgrade.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.