Ubuntu

Buttons disappear or do not respond to mouse clicks in Eclipse

Reported by h-gent-o on 2009-10-05
428
This bug affects 87 people
Affects Status Importance Assigned to Milestone
Azureus
Invalid
Undecided
Unassigned
Eclipse
Fix Released
Unknown
eclipse (Ubuntu)
High
lichcct
Declined for Karmic by Sebastien Bacher
gtk+2.0 (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher

Bug Description

After update from alpha 6 to beta Karmic Koala - Eclispe is no longer working correct. It seems to be a problem with GTK.
Few buttons are not working - nothing happens when pressing the button or the expected dialog is not shown as expected.
I also tested other eclispe package with same result.

eclipse 3.5.1 downloaded directly from www.eclipse.org has this bug.

Solution: Install eclipse 3.5.1-0ubuntu7 (or later) from the Ubuntu archive.

Related branches

h-gent-o (h-gent-o) wrote :
h-gent-o (h-gent-o) wrote :

Eclispe == Eclipse (sorry for the typo)

I fixed the title of the bug, but just so you know, you can edit the title of a bug report yourself.

summary: - Eclispe GTK is not working correct - especially buttons
+ Eclipse GTK is not working correct - especially buttons
Gabe Gorelick (gabegorelick) wrote :

Can you provide a screenshot of the bug?

affects: ubuntu → eclipse (Ubuntu)
Changed in eclipse (Ubuntu):
status: New → Incomplete
Rockwalrus (rockwalrus) wrote :

I think I've experienced the same thing -- does double-clicking the button make it work? (I saw a similar bug report when trying to figure out how to fix it that said that they needed to triple click, which is one more click than I need to do.)

h-gent-o (h-gent-o) wrote :

I attached the screenshot. For example clicking on the ok button has no effect.

Maybe you can rebuild. Download Eclipse SDK 3.5.X --> Start Eclipse --> Menubar --> Help --> Tipps and Tricks ... --> try to press the ok button. This is only one example where the button is not working.

I'm pretty sure this is a GTK issue. I couldn't see few lines in a listview but when I switch my theme to another one the lines are there, but buttons are still not working. I have to say I updated over the last month Karmic Koala from Alpha2 up to the latest beta.

P: Thanks, I didn't know to change the title would be possible afterwards

Gabe Gorelick (gabegorelick) wrote :

I'm more inclined to think this is an Eclipse issue with their gui code, as it looks like the gtk widgets are being drawn correctly and there are no X errors. It's just probably eclipse has implemented some callbacks incorrectly or something. Unfortunately, Eclipse 3.5 is not supported in Karmic. Can you confirm this on the version of Eclipse available from the Karmic repositories? Otherwise, I'll have to close this bug.

I'll test if this happens with eclipse package from the ubuntu
repository as well. Just to let you know, everything was working fine
with Karmic until aplha6. With the beta of Karmic something must have
changed causing the problems. Also it would be for the very first time,
that the binary eclipse package would not work with ubuntu. We have the
same eclipse environment (binary package) on different dev systems
runnings, including ubuntu 9.04 and earlier without any issues.

I have the exact same problem. Everything worked fine until I updated to 9.10. Now buttons like the close editor tab and minimize side tabs do not work. If i click once, the cursor changes to a text editing cursor, then if I click again (being very careful not to move the mouse) it will close. Everything worked perfectly in 9.04. When i updated, the tab coloring looked different and it stopped working.

VTWoods (vtwoods) wrote :

As a side note, I tried to install the version from the repositories; however, it seems to be broken (I get broken package messages). I am trying to downgrade to eclipse 3.4 from www.eclipse.org.

VTWoods (vtwoods) wrote :

Downgrade did not work. It seems to be a problem with the gtk buttons. Is it possible to downgrade gtk to the version used in 9.04?

zegenie (zegenie) wrote :

I'm experiencing the same issues. Could it be related to the issues described in this blog post?
http://www.dataforte.net/blog/2009/09/28/eclipse-3-5-and-gtk-2-18/

VTWoods (vtwoods) wrote :

I was able to fix the problem runnning eclipse 3.5 with GDK_NATIVE_WINDOWS=1 set. I start Eclipse as follows:

#/usr/bin/bash
export GDK_NATIVE_WINDOWS=1
`~/bin/eclipsePackage/eclipse3.5/eclipse -vmargs -Xms128M -Xmx512M -XX:PermSize=128M -XX:MaxPermSize=512M &> /dev/null` &

Thanks for the tip off Zegenie.

Benjamin Drung (bdrung) wrote :

Today eclipse 3.5.1-0~ubuntu1 was released to karmic. Is this version is still affected?

Benjamin Drung (bdrung) on 2009-10-06
Changed in eclipse (Ubuntu):
status: Incomplete → In Progress
Rockwalrus (rockwalrus) on 2009-10-07
affects: eclipse-eclipsers → eclipse-ubuntu
Rockwalrus (rockwalrus) on 2009-10-07
affects: eclipse-ubuntu → libgtk
Changed in libgtk:
importance: Undecided → Unknown
status: New → Unknown
Rockwalrus (rockwalrus) wrote :

The blog posting has a patch that is supposed to fix the problem. I have not tested the patch.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307 is related to the comments that say that GDK_NATIVE_WINDOWS=1 fixes the problem.

Maybe the gtk packages should conflict with versions of the libswt package << 3.5.whenever.the.fix.is.added.

VTWoods (vtwoods) wrote :

eclipse 3.5.1-0-ubuntu1 is still affected by the bug.

Benjamin Drung (bdrung) on 2009-10-07
Changed in eclipse-eclipsers:
importance: Undecided → Unknown
status: New → Unknown
Benjamin Drung (bdrung) on 2009-10-07
Changed in eclipse (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.1-0ubuntu2

---------------
eclipse (3.5.1-0ubuntu2) karmic; urgency=low

  * New snapshot from eclipse-build.
    - Apply GTK 2.18 z-order patch (LP: #443004).
  * Remove unversioned swt.jar link (LP: #446155).
  * Add wrapper script for setting LD_LIBRARY_PATH (LP: #445842).
  * Call remove with -f to fix FTBFS on powerpc.

 -- Benjamin Drung <email address hidden> Fri, 09 Oct 2009 21:41:39 +0200

Changed in eclipse (Ubuntu):
status: Fix Committed → Fix Released
VTWoods (vtwoods) wrote :

I downloaded the current release from the repositories and it will not start on my machine. It gives me the splash screen, then prompts me for my workspace. After that the splash screen returns, and eclipse attempts to start loading modules. Eclipse then crashes and an empty gray box pops up. I ran eclipse with the '-debug' option and received no information about the error.

Benjamin Drung (bdrung) wrote :

@VTWoods: Your problem has nothing to do with _this_ bug report. You probably experience bug #448688. Please run "rm -rf ~/.eclipse".

erani (erani-mail) wrote :

Still have bugs. Some fields in forms a disabled and you can not enter the value, also why the update&install is disabled for package version of eclipse?

Benjamin Drung (bdrung) wrote :

Can you give an example?

The disabled update&install is bug #438414. It will be fixed in the next upload.

Daniel (hackie) wrote :

Same problem here

Scenario:---------------
Start Eclipse->File->New Class->Name=XX->Push "Finish"

Button looks like it remains pushed (as if I did not release the mouse button, but I did)
Pressing Return key would create the class
Click now to "Cancel": nothing happens but "Finish" Button gets unpressed but also keeps Fokus (dotted Rect)
Clicking "Cancel" again closes assistant
---------------

Tested GDK_NATIVE_WINDOWS=1 (see above) now and no problems anymore.

Eclipse is manually installed here (3.5.1; up-to-date)
Ubuntu Karmic (also up-to-date)
sun-java6-bin 6-16-0ubuntu1.9.04

Benjamin Drung (bdrung) wrote :

@Daniel: It's fixed in the Debian package and it will be fixed in the next upstream release.

Benjamin Drung (bdrung) on 2009-10-15
Changed in eclipse (Ubuntu):
importance: Undecided → High
erani (erani-mail) wrote :

@Benjamin will you announce when it will be fixed? I don't want to upgrade my second pc till this problem is not fixed.

An example when it happen for me is when I try to search something in src file or when trying to add an svn repository location.

Benjamin Drung (bdrung) wrote :

@erani: I have released eclipse 3.5.1-0ubuntu7 (which builds currently). With this version you can install plugins as user (they are stored in ~/.eclipse). Please open a new bug report if you encounter any issue with this version.

Raine (rainefan) wrote :

I'm also having same problem (some buttons stay pressed - don't work) with updated Karmic 64-bit.

I'm having problems with eclipse downloaded directly from www.eclipse.org

The solution was the trick setting env var GDK_NATIVE_WINDOWS=1 before laucnhing eclipse bin.

Raine

Benjamin Drung (bdrung) wrote :

To clarify this:

eclipse 3.5.1 downloaded directly from www.eclipse.org has this bug.

Solution: Install eclipse 3.5.1-0ubuntu7 (or later) from the Ubuntu archive.

description: updated
gerstrong (gerstrong) wrote :

But without CDT... It doens't seem to work with that version

Benjamin Drung (bdrung) wrote :

eclipse-cdt from the Ubuntu archive does not work (bug #163739), but you can install CDT as user with eclipse 3.5.1-0ubuntu7.

I'm having the same problem,
The Eclipse from software center works though, but you need to do alot of updates before you can use it, because it doesn't seem to have pdt, java ee installed

Kristian Rink (kawazu) wrote :

Same problem here, using stock packages off eclipse.org. Having plugins installable via Eclipse Update Center rather than apt package management seems the most common use case related to using Eclipse, so I see the GDK_NATIVE_WINDOWS solution to deal with this. :(

Benjamin Drung (bdrung) wrote :

The wrapper script from eclipse 3.5.1+repack~1-0ubuntu1 uses GDK_NATIVE_WINDOWS.

Imre Gergely (cemc) wrote :

This solution does NOT work for me. I have 64bit Karmic installed with ia32-sun-java6-bin 6-15-1 and eclipse 3.3.0 downloaded from the eclipse site.

I tried export GDK_NATIVE_WINDOWS=1, export GDK_NATIVE_WINDOWS=true, the ran ./eclipse from the unpacked eclipse directory. It starts, then I go to Help / Software Updates / Find and Install, select Search for new features to install, click 'Next'... and that's it. 'Next' won't "click". It's pressed, but it won't go. If I press space, it goes. On the other hand the 'Cancel' button works every time ;)

Tried it with 3.3.0, 3.3.2 which won't work. For version 3.5.1 it IS working, but I really need 3.3. All versions are downloads from eclipse.org and are 32bit (if that matters).

VTWoods (vtwoods) wrote :

I agree with the above posters. While the fix i posted allows you to close tabs and such, when navigating internal dialog boxes next and finish don't always work. I have to hit space or return to activate a clicked button.

Damien Cassou (cassou) wrote :

I experienced the same problem with another java tool: CrashPlan Pro. Exporting GDK_NATIVE_WINDOWS=1 fixed the problem there too.

Kristian Rink (kawazu) wrote :

Adding to that, however, it _seems_ to be a GNOME related problem. Using XFCE/Xubuntu desktop (also GTK+-based) on my platform doesn't expose this issue, no matter whether or not GDK_NATIVE_WINDOWS=1 is set. Can anyone confirm this, or is this just my system?

Imre Gergely (cemc) wrote :

I can't confirm it, I tried with TWM and WindowMaker, and the "no-click" problem still appears, with or without the GDK_NATIVE_WINDOWS variable set.

Rockwalrus (rockwalrus) wrote :

Imre: sorry, unpatched versions of SWT before 3.5.2 simply will not work properly with GTK 2.17 and greater. This is due to a change in GTK. You might be able to replace the SWT in 3.3 with 3.5.2 and get Eclipse 3.3 to work that way, but no promises, or to port the patch to 3.3's swt and rebuild it. Alternatively, you can try downgrading GTK to a 2.16 version.

Jörn Dreyer (j.dreyer) wrote :

ok, GDK_NATIVE_WINDOW=1 fixes the behaviour ... why does it also work when I set GDK_NATIVE_WINDOW=0 ?

hiunlink (hiunlink) wrote :

I just upgrade Ubuntu 9.10 yesterday, and It also has the problems like GUI freeze, no respese. And I download Eclipse IDE for C/C++ Developers from offical website for testing this problem. When I open the new eclipseIt had a warning message telled something like eclipse would use the gcj(GNU Compiler for the Java) for running eclipse. So I thought those problems maybe be occured by GCJ, and remove it. It surprisely solved those problems. I do not read comment wrote by your guys detaily, so this comment just for someone have eclipse problem when upgrading Ubuntu 9.10.

Roch Delsalle (mnml) wrote :

I have the same problem, I need to press enter to activate the buttons for the search function of eclipse (Zend Studio mod).

Alvaro Toledo (atoledo) wrote :

Workaround does not work for me either. I'm using Eclipse 3.3 with Java 1.5.0_16.

Alvaro Toledo (atoledo) wrote :

Imre, try to upgrade SWT in your Eclipse to 3.5.1. I'm using Eclipse 3.3 and it seems to be working for me.

I can confirm this bug for the current eclipse version 3.5.1 (galileo-SR1) in Ubuntu 9.10.

I doesn't just affect buttons, it affects all GUI elements like checkboxes, dopdowns etc. They can not be selected with the mouse any more but they can be activated with the keyboard (space key, tab key...).

Setting GDK_NATIVE_WINDOWS=1 fixes it for me.

knas_r (knas4ever) wrote :

Hi - I'm having the same problem with crashplan! The command export GDK_NATIVE_WINDOWS=1 works for me, but after reboot I need to do it again. Any permanent FIX??

Claus (ubuntu beginner)

Benjamin Drung (bdrung) wrote :

@Claus: Either you use the package provided by Ubuntu or you create a small shell script for running eclipse.

nh2 (nh2) wrote :

Please try Eclipse 3.6 M2 (http://download.eclipse.org/eclipse/downloads/drops/S-3.6M2-200909170100/index.php). I do not have button problems with it.

Tom (tom-ducbase) wrote :

I set GDK_NATIVE_WINDOWS=1 and I still get:

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f90f5a59f7a, pid=6912, tid=140261207550224
#
# JRE version: 6.0_16-b01
# Java VM: Java HotSpot(TM) 64-Bit Server VM (14.2-b01 mixed mode linux-amd64 )
# Problematic frame:
# C [libpango-1.0.so.0+0x24f7a] pango_layout_new+0x2a
#
# An error report file with more information is saved as:
# /opt/eclipse3.5/hs_err_pid6912.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

PeterElkjaer (peterelkjaer) wrote :

Hi, I have no issues getting Eclipse to work with the fix applied.

However I use Eclipse for well programming....
When I run my company's RCP program we are running it against a targetplatform based on 5.0.

Is there a single plugin (jar), I can replace to get this program running?
Is there a startup parameter I can set, and how so that I can get my RCP application running again.

Hope you can help.

/Peter

Rockwalrus (rockwalrus) on 2009-11-05
summary: - Eclipse GTK is not working correct - especially buttons
+ Buttons disappear or do not respond to mouse clicks in Eclipse
Changed in gtk+2.0 (Ubuntu):
status: New → Fix Released

Same problem here ... the export GDK_NATIVE_WINDOWS=1 workaround fixes it for me as well.

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
flyingzl (lei-zhao-neusoft) wrote :

eclipse 3.3,export GDK_NATIVE_WINDOW=1 makes no effect..

Same problem with BIRT on Eclipse (see attached file for details of the crash)

I try to install th ubuntu package for eclipse (aptitude install eclipse) but i cannot install BIRT on it....trying to find why (copy plugins and feature in /usr/lib/eclipse...)

Another log for eclipse birt crash

Xtien (xtien) wrote :

Same issue here on two different computers. The "export GDK_NATIVE_WINDOWS=1" fix fixed the problem. Does anyone know why this works, I mean, what the problem is?

Gabe Gorelick (gabegorelick) wrote :

@Xtien, this has to do with the new client side windows implemented in the latest gtk+ release. This is breaking eclipse's swt-gtk bindings. Setting GDK_NATIVE_WINDOWS turns off this new feature, thus fixing the problem. But client side windows are actually pretty useful, so just turning them off is not a viable long term solution. There is a patch to fix this upstream in eclipse, and is scheduled for inclusion in 3.5.2.

Xtien (xtien) wrote :

Gabe, thanks for the reply.

There are more problems in Eclipse after the upgrade I think. I was using JavaHL with subclipse, but that doesn't work any more. This morning I couldn't get svnkit to work either. Hopefully Eclipse 3.5.2 will come out soon.

don_filippo (gonzoh) wrote :

The same problem - buttons not responding - with Eclipse (downloaded from eclipse.org) and Vuze (Azureus) 4.2.0.8. In Vuze the problem appears for example when I'm trying to press button 'OK' in update pop-up window - to solve that, I have to press enter on activated button. In Eclipse works GDK_NATIVE_WINDOWS and pressing enter. These problems appeared on Ubuntu 9.10. I had no problems with same Eclipse version on Ubuntu 9.04

Lubosz Sarnecki (lubosz) wrote :

Buttons only work when i press enter after clicking (this is an input hack :D )

Changed in eclipse (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Gabe Gorelick (gabegorelick) wrote :

@don_filippo, it's understandable that this bug would also effect vuze, since that is also written in SWT.

Are there any SWT apps that don't suffer from this? We may want to change the scope of this bug report to reflect that it potentially effects a large number of SWT apps and not just eclipse.

Onkar Shinde (onkarshinde) wrote :

@Gabriel,

On what basis have you marked this bug as fix released in eclipse?

Gabriel Bauman (gabrielbauman) wrote :

@Onkar,

I mis-clicked the other day and set the status from Fix Released → Fix Committed, then corrected back to its original state. Isn't that obvious from the bug history?

It's "worked around" at least in the Ubuntu eclipse package, but not
fixed in the actual Eclipse build - that's planned for Galileo SR 2
AFAIK.

marksml (info-marks) wrote :

@Adrian Wilkins: There different packages based off eclipse. If I would want to download one of these packages and then wanted to adapt it to work correctly on ubuntu 9.10. What would I have to do? Can you describe more in detail so the ones who are interested can do that by themselves on their one eclipse packages?

Thanks in advance!

regards, Michael

marksml (info-marks) wrote :

@Adrian: sorry - saw the comments with the "export GDK_NATIVE_WINDOWS=1" workaround from VTWoods to late.

regards, Michael

Changed in eclipse (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
LG (einstein-lg2008) on 2010-01-02
Changed in eclipse (Ubuntu):
assignee: nobody → LG (einstein-lg2008)
Changed in azureus:
status: New → Invalid
lichcct (lichcct) on 2010-03-12
Changed in eclipse (Ubuntu):
assignee: LG (einstein-lg2008) → lichcct (lichcct)
Changed in eclipse-eclipsers:
status: Unknown → Fix Released
mbudd (marvbudd) wrote :

I'm on an amd64 release of Ubuntu 9.10 - the Karmic Koala. I could not get subclipse 1.6 to install because the final "Finish" button was always inactive. This even happened on the suggested 3.5.1-0ubuntu7, which I downloaded and installed manually using dpkg instead of using synaptics.
Finally, I found that selecting "Hide items that are already installed" button presented a different dialog where I could deselect the Subversion Revision Graph, and Subclipse integration for Mylyn 3 early on before the later screens solved the problem.
I REALLY WANT THIS FIXED.
Thanks!

Gabriel Bauman (gabrielbauman) wrote :

@mbudd

The problem you are experiencing is not related to this bug, which has nothing to do with "inactive" buttons. Sufferers of this bug had to click *active* buttons more than once to get them to work.

Also, there is no benefit to using dpkg over synaptic.

I've had the issue you are experiencing before, and it was solved by making sure Eclipse had full write access to its own directory. If you're allowing eclipse to install features and plugins in ~/.eclipse, you are going to have problems.

The problem with this bug is that it is also present in other
applications that is built on Eclipse.
I've experienced the button-problem in both Zend Studio and Aptana.

The "workaround" is to click on the button so that it becomes active
( or marked ) and then press enter or the key combination for the
specific button.

Trond

VTWoods (vtwoods) wrote :

I have upgraded to lucid and installed the ubuntu eclipse package. Everything seems to be fine. I was able to install subclipse with no problems. I will report back if this problem resurfaces.

userxp (userxp) on 2010-04-28
Changed in eclipse (Ubuntu):
status: Fix Released → Confirmed
Gabe Gorelick (gabegorelick) wrote :

Please don't change the status of this bug without providing a good reason. Thanks.

Changed in eclipse (Ubuntu):
status: Confirmed → Fix Released
dronus (paul-geisler) wrote :

WORKAROUND for anyone who stil experience this bug: After a button is stuck by clicking on it, the action can be invoked by pressing return/enter. Worked on several systems for me.

Trond Husoe (tr-huso) wrote :

On Sun, 2010-05-09 at 11:00 +0000, dronus wrote:
> WORKAROUND for anyone who stil experience this bug: After a button is
> stuck by clicking on it, the action can be invoked by pressing
> return/enter. Worked on several systems for me.
>

Or you can click the hotkeys (e.g. alt e).

Trond

vovkab (vovkab) wrote :

The same bug on Ubuntu 10.04 and Eclipse Helios, but in properties panel (with android development tools).
When I click on "..." button it's just disappears, but if I press space button on keyboard click proceed.
Check screenshot in attack

Changed in libgtk:
importance: Unknown → Low
status: Unknown → Fix Released
TLArevo (tla-revo) wrote :

I'm using Ubuntu 10.10 and Eclipse 3.6.1 i have the same issue with php documentation popup is totally black cannot see anything in it please help to fix this :)

Trond Husoe (tr-huso) wrote :

On Sat, 2010-11-13 at 20:18 +0000, TLArevo wrote:
> I'm using Ubuntu 10.10 and Eclipse 3.6.1 i have the same issue with php
> documentation popup is totally black cannot see anything in it please
> help to fix this :)
>
I believe this is because Eclipse uses the theme in Ubuntu. It is how
ever a totally different bug than the one you are replying to now.

The "bug" is also present in 10.04.

-t-

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.