ebox: Depends: libapache-authcookie-perl but it is not installable

Bug #255368 reported by Fernando Miguel on 2008-08-06
106
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ebox (Ubuntu)
Undecided
wesley
Nominated for Jaunty by Neal McBurnett
Intrepid
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Neal McBurnett
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: ebox

# apt-get install ebox
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ebox: Depends: libapache-authcookie-perl but it is not installable
E: Broken packages

Changed in ebox:
status: New → Confirmed
Niels Egberts (nielsegberts) wrote :

I'm having the same issue in Intrepid-server.

Ebox is even in the ubuntu-server-guide:
https://help.ubuntu.com/8.04/serverguide/C/ebox.html

Niels Egberts (nielsegberts) wrote :

Libapache-authcookie-perl has been deleted from intrepid... The comment was that it was buggy and unmaintained.

Could we get this lib back or is there another solution?

Javier Uruen Val (juruen) wrote :

In the meanwhile you can install it from the following ppa:

https://launchpad.net/~ebox/+archive

HaTaX (hatax2) wrote :

I added "deb http://ppa.launchpad.net/ebox/ubuntu intrepid main" to my sources.list and it solved the problem of not finding the libapache-authcookie-perl package.

ebox is installed and working on 8.10 for me with that repo added.

Just thought I'd pass along what worked for me

ov10fac (ov10fac) wrote :

I have the same problem. I added the URl to my sources list and still get the error. I am new to Ubuntu (been using Fedora for years) and don't know how to use the ppa to install files as suggested by javier Uruen Val.

Any help will be greatly appreciated.

On Sat, Nov 8, 2008 at 3:39 PM, ov10fac <email address hidden> wrote:
> I have the same problem. I added the URl to my sources list and still
> get the error. I am new to Ubuntu (been using Fedora for years) and
> don't know how to use the ppa to install files as suggested by javier
> Uruen Val.
>
> Any help will be greatly appreciated.

https://help.launchpad.net/Packaging/PPA

:-Dustin

This doesn't fix the fact that ebox installation is broken out of the box in Intrepid. Is this package going to be added back to the repos, or is ebox going to find a way to live without it? this is unacceptable.

.Ru (vodarus) wrote :

>This doesn't fix the fact that ebox installation is broken out of the box in Intrepid.

Confirm bug on Intrepid.

cl0s (itsclos) wrote :

Same here, I was able to get it working from the launchpad source but that version is not as stable, does have more modules though. I installed libapache-authcookie-perl from the gusty package (http://packages.ubuntu.com/hardy/libapache-authcookie-perl) and was able to install the default ebox from there.

Matthew East (mdke) wrote :

This isn't a documentation bug. The package is uninstallable.

Changed in ubuntu-docs:
status: New → Invalid

> Confirm bug on Intrepid.

Are you backing me up, or telling me to confirm? It's confirmed.

Javier Uruen Val (juruen) wrote :

I know this doesn't fix the issue but I opened a bug that was marked as duplicated where I explained what happened in Intrepid:

https://bugs.launchpad.net/ubuntu/+source/ebox/+bug/273486

Anton Roeder (filtered4spam) wrote :

So, how can the proposed FF exception be accomplished?

I agree that taking eBox out completely would be a pity, since it is quite prominently advertised in the Server Guide. Integrating the new version as soon as possible seems to be the way to go then. Would give the chance to update the somewhat buggy documentation in Server Guide too.

Changed in ubuntu-docs:
assignee: nobody → milena-stamenova
status: Invalid → Confirmed
Leslie Mulder (lesm) wrote :

I managed to get ebox installed (intrepid, i386):

a) wget http://launchpadlibrarian.net/3297915/libapache-authcookie-perl_3.10-1_all.deb

to get the missing package in interpid (i386)

b) dpkg -i http://launchpadlibrarian.net/3297915/libapache-authcookie-perl_3.10-1_all.deb

to install the package (no complaints)

c) apt-get install ebox

and say yes to the all of the subsequent stuff that it wants to install, unless you don't want it.

drapsag (drapsag) wrote :

Leslie:

I tried that before and it doesn't works. It look likes it is installed, but it won't start the Ebox deamons. It keeps on saying there is something wrong with orbit.... I can't reproduce it, because I installed ebox by adding the "deb http://ppa.launchpad.net/ebox/ubuntu intrepid main" to my sources.list. This isn't the best solution although, because it isn't stable in my opinion.

My whole impression of ubuntu 8.10 isn't very good. It is buggy, not finished, not complete. I think I will go back to hardy...

drapsag (drapsag) wrote :

Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: Not running within active session) at /usr/share/perl5/EBox/GConfModule.pm line 50.

Matthew East (mdke) wrote :

The task on ubuntu-docs is invalid, this isn't a problem with the documentation as the package should be installable. When the package is fixed, the documentation will work as intended.

I've accidentally declined this bug for intrepid on ebox as I didn't realise that declining it on the ubuntu-docs task would decline it on all tasks... Launchpad's UI is rather misleading there.

Changed in ubuntu-docs:
assignee: milena-stamenova → nobody
status: Confirmed → Invalid
Arnaud Quette (aquette) wrote :

guys,

the point is maybe that the package has been removed from Debian Sid:
http://packages.qa.debian.org/liba/libapache-authcookie-perl/news/20080709T071623Z.html

this may be the base reason for its removal from universe too!

just my 2 cents to the discussion...

Neal McBurnett (nealmcb) wrote :

The server team discussed this at UDS and plans to do what is necessary to make eBox installable in Intrepid via an SRU (Stable Release Update: https://wiki.ubuntu.com/StableReleaseUpdates). Getting a minimal patch to fix it for Jaunty, based on the notes at https://bugs.edge.launchpad.net/ubuntu/+source/ebox/+bug/273486 would seem like the first step, so I'm nominating it for Jaunty.

Adam Sommer (asommer) wrote :

SRU Report

Bug Impact:
This bug causes the ebox package to be uninstallable due to unmet dependency.

Fix in the development branch:
Not yet fixed in Jaunty, but will be soon. The issue is fixed in the eBox PPA: https://launchpad.net/~ebox-unstable/+archive so the problem is fixed upstream.

Minimal Patch:
See dpatch attachment.

Test Case:
$ sudo apt-get install ebox
Package will fail to install with:
The following packages have unmet dependencies:
  ebox: Depends: libapache-authcookie-perl but it is not installable
E: Broken packages

Regression Potential:
I don't believe there will be any regression based on my testing. Also, the patch is intended to fix a regression that results in a non-working package.

If there is any additional information required please let me know.

Adam Sommer (asommer) wrote :

Also, here is a debdiff patch for the Apache Authentication issue.

Thanks,
Adam

For the most part, this looks good but I do have a few questions:

 1. Your changelog makes it seem like you've modified src/EBox/Apache.pm inline. However, if I've read your debdiff correctly it looks like the change is made by your 17_dbus_gconf.dpatch patch. If the former is the case, please do not make the change inline. If the later, please update your changelog entry. You can have your sponsor do this - no need to prepare another debdiff for this at this time.
 2. Can you confirm that the dbus changes are counterpart changes to the SRU in bug #314606? If so, please note this in your changelog. You can have your sponsor do this - no need to prepare another debdiff for this at this time.
 3. I assume that 16_add_apache_authcookie.dpatch is copying and pasting the file(s) you need from that package that got removed? Can you confirm or explain where they came from if my assumption is wrong?
 4. Also, I see that you note that this has not been fixed in Jaunty. Could you please explain why this is the case? Are you just getting a head start on the SRU or are you looking for this SRU to be accepted without the fix first being in Jaunty?

I also notice you don't close your SRU bugs in your changelog.

Nicolas Valcarcel (nvalcarcel) wrote :

ACK

Michael C (bigredpuppy) wrote :

This work around, workdsfor the normal desktop install of 8.10,
but does not work for ubuntu server 8.10
It fails with the following dependencies:

fyi: This was a new, vanilla install of Ubuntu Server 8.10, no updates or additions.

Rgds,
Mike

===============================================================

root@newyork:/etc/apt# apt-get install ebox
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ebox: Depends: libebox (>= 0.12) but it is not going to be installed
        Depends: libebox (<= 0.12.10) but it is not going to be installed
        Depends: libapache2-mod-perl2 but it is not installable
        Depends: libapache-singleton-perl but it is not installable
        Depends: gconf2 but it is not installable
        Depends: libgnome2-gconf-perl but it is not installable
        Depends: libsys-cpu-perl but it is not installable
        Depends: libsys-cpuload-perl but it is not installable
        Depends: libproc-process-perl but it is not installable
        Depends: postgresql but it is not installable
        Depends: libdbd-pg-perl but it is not installable
        Depends: libfile-tail-perl but it is not installable
        Depends: libclone-perl but it is not installable
        Depends: libnet-jabber-perl but it is not installable
        Depends: libfilesys-df-perl but it is not installable
        Depends: libchart-perl but it is not installable
        Depends: libfile-copy-recursive-perl but it is not installable
        Depends: libfile-mmagic-perl but it is not installable
        Depends: libxml-rss-perl but it is not installable
E: Broken packages

Javier Uruen Val (juruen) wrote :

Cody:

Regarding your question number 2: Yes, that's the dbus counterpart in libebox. Both eBox and libebox need to be patched to work with the new gconf using dbus.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebox - 0.12.4-0ubuntu1

---------------
ebox (0.12.4-0ubuntu1) jaunty; urgency=low

  * New upstream release. (LP: #318710, LP: #310045).
  * debian/control:
    - Bump standard version.
    - Depend on an apache2-mpm- rather then apache2 (LP: #225793).
    - Build depend on debconf-updatepo.
  * debian/rules:
    - Call debconf-updatepo from clean target.
  * debian/copyright:
    - Include section about apache-authcookie code.
  * debian/ebox.postrm:
    - Remove ebox log files (LP: #129738).
  * debian/ebox.prerm:
    - Stop ebox when the package is removed. (LP: #234912)
  * debian/watch:
    - add watch file.
  * debian/patches/01_add_apache_authcookie.dpatch
    - Patch to backport AuthCookie authentication for jaunty (LP: #255368).
  * debian/patches/02_dbus_gconf.dpatch
    - Patch to make gconf classes work with new gconf using dbus
      (LP: #314606).
  * debian/patches/03_js_libraries.dpatch
    - Patch to use javascript libraries that are already package for
      Jaunty

 -- Mathias Gug <email address hidden> Mon, 26 Jan 2009 18:21:18 -0500

Changed in ebox:
status: Confirmed → Fix Released
Adam Sommer (asommer) wrote :

Now that eBox is fixed in Jaunty here's an updated debdiff. Can someone sponsor the new package to proposed? Also, if there are other changes that need to be made please let me know.

Thanks,
Adam

Mathias Gug (mathiaz) wrote :

Sponsored.

I've updated the version number suitable for an SRU in intrepid as documented in https://wiki.ubuntu.com/SecurityUpdateProcedures. I've also modified the targeted distribution to be intrepid-proposed instead of intrepid.

Changed in ebox:
status: New → Fix Committed
Jonathan Riddell (jr) wrote :

Subscribed motu-sru who need to approve this before I can accept it.

Martin Pitt (pitti) wrote :

motu-sru ping?

motu-sru ACK.

Martin Pitt (pitti) wrote :

Accepted ebox into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted ebox-usersandgroups into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Any testers?

Thanks for the poke, I'll give it a crack, never tested anything before or
used proposed.
On Thu, Apr 16, 2009 at 7:31 PM, Martin Pitt <email address hidden> wrote:

> Any testers?
>

Arnaud Quette (aquette) wrote :

2009/4/16 Martin Pitt

> Any testers?
>

I've just given it a quick shot (intrepid using -proposed):
- installation is OK,
- running a few use case (web access, modules enabling, ...) seems OK

I've not done deeper testing but the above is sufficient to validate the
install-ability...

cheers,
-- Arnaud

Steve Beattie (sbeattie) wrote :

I have reproduced the dependency failure with ebox 0.11.99-0ubuntu11 in intrepid, and can confirm that the version in intrepid-proposed, 0.11.99-0ubuntu11.8.10.1, installs succesfully. Minimal testing through the web interface didn't show any obvious regressions; marking verification-done.

tags: added: verification-done
removed: verification-needed
Changed in ubuntu-docs (Ubuntu Intrepid):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ebox - 0.11.99-0ubuntu11.8.10.1

---------------
ebox (0.11.99-0ubuntu11.8.10.1) intrepid-proposed; urgency=low

  [ Adam Sommer ]
  * debian/patches/16_add_apache_authcookie.dpatch
    - Patch to backport AuthCookie authentication for intrepid.
    - Also changes src/EBox/Apache.pm to use dbus. (LP: #255368)
  * Removed libapache-authcookie-perl dependency.
  * debian/patches/17_dbus_gconf.dpatch
    - Patch to support the new gconf version using dbus.

 -- Mathias Gug <email address hidden> Mon, 09 Feb 2009 18:55:11 -0500

Changed in ebox (Ubuntu Intrepid):
status: Fix Committed → Fix Released
wesley (wesklingerfelt) on 2010-06-07
Changed in ebox (Ubuntu):
assignee: nobody → wesley (wesklingerfelt)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions