FFe: e2fsprogs 1.44, support for largedir and ea_inode

Bug #1756177 reported by Steve Langasek on 2018-03-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
e2fsprogs (Ubuntu)
Undecided
Unassigned

Bug Description

e2fsprogs 1.44 landed in Debian unstable on March 8, missing feature freeze / Debian import freeze by about a week. Per upstream (https://bugs.launchpad.net/ubuntu/+source/e2fsprogs/+bug/1365874/comments/17), 1.44 includes two new not-enabled-by-default features which would be good to have available in the 18.04 userspace: largedir, and ea_inode.

This is a rather stable and well-maintained codebase with stable interfaces, so I believe the risks are small to taking this post-FF. The one known change in behavior relative to Ubuntu 16.04 is the enablement of metadata checksums by default, which is a change we already have via the 1.43.9 package, so shouldn't count against an FFe.

The main (but still small) risk to the release from taking this change would be disruption to image builds / installation as a result of broken tools. This would be detected fairly quickly through our automated image testing, and if any regressions are introduced we should roll back the e2fsprogs update immediately.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in e2fsprogs (Ubuntu):
status: New → Confirmed
Łukasz Zemczak (sil2100) wrote :

Looks good to me. In this case it's better to sync it early than later. I approve of the FFe for e2fsprogs 1.44 in bionic.

Changed in e2fsprogs (Ubuntu):
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

This bug was fixed in the package e2fsprogs - 1.44.0-1

---------------
e2fsprogs (1.44.0-1) unstable; urgency=medium

  * New upstream release
  * Update Czech, Spanish, French, Malay, and Ukrainian translations.

 -- Theodore Y. Ts'o <email address hidden> Wed, 07 Mar 2018 14:39:52 -0500

e2fsprogs (1.44.0~rc2-1) experimental; urgency=medium

  * New upstream release
  * Fix FTBFS problem on Hurd
  * Improved e2fsck's consistency checking for symlink.

 -- Theodore Y. Ts'o <email address hidden> Sun, 04 Mar 2018 15:57:21 -0500

e2fsprogs (1.44.0~rc1-1) experimental; urgency=low

  * New upstream release
  * Add support for the large_dir feature
  * Add support for the ea_data feature
  * Resize2fs will not complain about online resizes of bigalloc file
    systems
  * Debugfs's ls command will now print the high bits of the mode bits
  * Fix some corner cases with tune2fs and journal replay
  * Add support for libreadline.so.7
  * E2freefrag will now use the GETFSMAP ioctl for mounted file systems
  * E2fsck is now much faster when scanning extents on bigalloc file systems
  * Fix various compiler and UBSAN warnings

 -- Theodore Y. Ts'o <email address hidden> Tue, 27 Feb 2018 16:56:32 -0500

Changed in e2fsprogs (Ubuntu):
status: Triaged → Fix Released

FWIW 'this seems to WORK in bionic, including "make fullcheck" on the source, system able to check itself on boot, resizing other system disks, no issues so far as I can. Thankyou for agreeing//doing this so quickly.

Backporting related matters to be discussed separately in:-
https://bugs.launchpad.net/ubuntu/+source/e2fsprogs/+bug/1365874

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers