ported from obsolete GTK1.2 to GTK2

Bug #197478 reported by Lars Friedrichs
4
Affects Status Importance Assigned to Milestone
e16menuedit (Debian)
Fix Released
Unknown
e16menuedit (Ubuntu)
Wishlist
Lars Friedrichs

Bug Description

debdiff attached - please drop me a line if you expect more info here...

Revision history for this message
Lars Friedrichs (l-friedrichs) wrote :
Changed in e16menuedit:
status: New → Confirmed
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Looks very good, just a couple of questions:

1. Why it is needed to port this to GTK2.0 (note that both GTK1.2 and 2.0 are in hardy)
2. Why is gdk-imlib dropped?
3. It seems that patch 03_port_to_gtk2.dpatch was not made with dpatch, even though its using the dpatch extension?

Finally, its not your fault but there is nothing in rules that actually applies the patches, so all the patches, yours included, are not applied and the build fails.
Note that before enabling dpatch I would like to understand if this was done on purpose by the Debian maintainer (there is no clue in the changelog).

PS. Next time please link the debian bug here too.

Changed in e16menuedit:
assignee: nobody → l-friedrichs
importance: Undecided → Low
status: Confirmed → In Progress
importance: Low → Wishlist
Revision history for this message
Lars Friedrichs (l-friedrichs) wrote :

Hi,

1. I was asked by persia to help with migration. I believe that GTK1.2 support is to be dropped soon (it will still be in hardy but not in intrepid)
2. I am not so sure about that one but I removed the build dependency because it's either GTK2 including it differently now or it's e16menuedit not even needing it as you can see I removed the linking against that lib and the build still worked. It seemed sane to me but to be honest I am not that much into GTK1.2/2 issues.
3. the patch was created with cdbs-edit-patch and I believe it was named .dpatch by it. It could also be that I renamed it (I am not quite used to proper packaging, so that could have been my fault)

I did not check whether the patches actually get used. But I wonder how my debuild worked if it would not patch... Strange...

Bye
Lars

debian bug is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=468866

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Do you have a buildlog?
Attached is my attempt at building. As you can see it fails because your patch is not applied, and therefore it won't find gdk_imlib.h
This is debian/rules:

#!/usr/bin/make -f

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/makefile.mk

# Add here any variable or target overrides you need.

Unless something is changed in latest cdbs, it used to be mandatory to include /usr/share/cdbs/1/rules/simple-patchsys.mk to be able to use the cdbs simple patch system (or dpatch.mk to use dpatch).

Changed in e16menuedit:
status: Unknown → New
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Please, resubscribe u-u-s when you will have a new debdiff ready for review. Thanks!

Changed in e16menuedit (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.