post-installation fails when already configured

Bug #106689 reported by Niklas Edmundsson on 2007-04-15
28
Affects Status Importance Assigned to Milestone
drupal (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: drupal

When installing drupal-5.1 on feisty I get this:
-----8<-----
dpkg: error processing drupal-5.1 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 drupal-5.1
-----8<-----

Poking a -x in drupal-5.1.postinst I see that it's the following that fails:
-----8<-----
curl http://localhost/drupal/install.php?profile=default 2> /dev/null | grep "Drupal installation complete" > /dev/null || exit 1
-----8<-----

This can fail because:
- That page says "Drupal already installed" when already configured and installed
- If you don't want help from the dbconfig-thingie, you won't have a complete install until you have configured the DB.
- There's no guarantee thats the location of the VHost using drupal.

I suggest that this test is refined, and that the only effect of failing it is popping up a warning saying that manual configuration is needed. Failing hard without an explanation like now is definately wrong in any case.

Another reason why this might fail (as just happened to me...) - the web server might not be on port 80.
For instance, we only listen on port 443. So yeah, I'd like to see this be a warning.

Chris Teachworth (cteachworth) wrote :

Just another "me too". When I tell dpkg I'll configure the db manually I hit the same error. I had to configure the db manually and then run apt-get install again to fix it.

I have a related problem, when installing on a system that has mysql and postgres, but not the php5-pgsql package, if you select Postgresql as your database, it fails to install. Drupal provides very detailed and helpful diagnostic error messages at the URL that curl is trying to get (if it's really installed on that vhost/port), however the curl output is sent to /dev/null. The test definitely needs to be refined, and/or the output of curl displayed on failure.

I managed to work around the problem by not letting the installation script generate its own random password. See my post titled "Found a solution" here for details:

Error message about one package after each install
http://ubuntuforums.org/showthread.php?t=545106

Ivo Mans (ivomans) wrote :

Another workaround that is a bit easier: Edit the file /var/lib/dpkg/info/drupal-5.1.postinst line 56. Edit the part 'grep "Drupal installation complete" ' into 'egrep "Drupal installation complete|Drupal already installed" '

Ivo Mans (ivomans) on 2007-10-28
Changed in drupal:
status: New → Confirmed
marcw (marcw) wrote :

Ivo Mans solution is perfect! That Drupal upgrade should never have gone out in the condition it did.

nicocesar (nicocesar) wrote :

Ivo Mans solution is perfect! I'm new to ubuntu (used GNU/Debian before) which is the correct way to inform this to package builder?

marcw (marcw) wrote :

A few moments ago I noticed yet another Drupal update was ready for download and install. That part went fine but I was left with the exact same post install error as before. And once again, Ivo Mans' workaround fixed the issue.

So why has this problem been repeated, especially when there is a known workaround/solution?

Daniel Hahler (blueyed) wrote :

The package "drupal" has moved to "drupal5" in Gutsy and later, which does not have this problem.

This bug should (only) get fixed in case there's another security or bugfix update required, so that the upgrade itself does not fail (again).

Changed in drupal:
importance: Undecided → High
status: Confirmed → Triaged

Thank you for reporting this bug to Ubuntu. Ubuntu 7.04 (Feisty Fawn) reached EOL on October 19, 2008.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

I've tried recreating this bug with Ubuntu 9.04 (Jaunty Jackalope) and was unable to, given the information you've provided. Please either a) upgrade and test or b) increase the verbosity of the steps to recreate it so we can try again.

Please feel free to report any other bugs you may find.

Changed in drupal (Ubuntu):
status: Triaged → Incomplete
Mackenzie Morgan (maco.m) wrote :

Since this bug seems not to be reproduceable on current versions of Ubuntu, I'm marking it as invalid.

Changed in drupal (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers