Drupal fails to install if PostgreSQL is chosen as DB backend

Bug #125625 reported by scw on 2007-07-12
2
Affects Status Importance Assigned to Milestone
drupal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: drupal

When installing drupal-5.1 on feisty I get this:
----------------------
Setting up drupal-5.1 (5.1-0ubuntu2) ...
dbconfig-common: writing config to /etc/dbconfig-common/drupal-5.1.conf
Replacing config file /etc/drupal/5.1/sites/default/dbconfig.php with new version
creating postgres user drupal51: already exists.
resetting password: success.
creating database drupal51: already exists.
dbconfig-common: flushing administrative password
dpkg: error processing drupal-5.1 (--configure):
 subprocess post-installation script returned error exit status 1
 Errors were encountered while processing:
  drupal-5.1
  E: Sub-process /usr/bin/dpkg returned an error code (1)
----------------------

Manually loading the Drupal page at http://localhost/drupal/ reveals that an unmet dependency of php5-pgsql is the culprit, but unfortunately this information is redirected to dev-null in the drupal-5.1.postinst script.

This bug is also reported in the comments of #106689:
  https://bugs.launchpad.net/ubuntu/+source/drupal/+bug/106689/comments/3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers