SRU: package drbd8-utils (not installed) failed to install/upgrade: trying to overwrite '/usr/share/cluster/drbd.sh', which is also in package rgmanager 0:3.0.2-2ubuntu3

Bug #627174 reported by kenchan on 2010-08-31
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
drbd8 (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned
redhat-cluster (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned

Bug Description

drbd8-utils fails to install when rgmanager is installed. rgmanager is shipping two shell scripts that are also shipped with drbd8.

The fix is to not install such scripts with rgmanager in redhat-cluster source package.

The error is detailed bellow:

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: drbd8-utils (not installed)
ProcVersionSignature: Ubuntu 2.6.32-24.42-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
Date: Tue Aug 31 10:14:06 2010
ErrorMessage: trying to overwrite '/usr/share/cluster/drbd.sh', which is also in package rgmanager 0:3.0.2-2ubuntu3
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: drbd8
Title: package drbd8-utils (not installed) failed to install/upgrade: trying to overwrite '/usr/share/cluster/drbd.sh', which is also in package rgmanager 0:3.0.2-2ubuntu3

TEST CASE:
 - Install rgmanager.
 - Install drbd8-utils.
 - You will see how drbd8-utils will fail to install as detailed above.

Once the proposed fix is applied, drbd8-utils will install correctly.

kenchan (kenchan-sun) wrote :
Mathias Gug (mathiaz) on 2010-08-31
Changed in drbd8 (Ubuntu):
importance: Undecided → Medium
Ante Karamatić (ivoks) wrote :

This is actually fixed in Maverick's source of redhat-cluster-suite, but there are still no fixed binaries.

Changed in drbd8 (Ubuntu):
status: New → Confirmed
Changed in drbd8 (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andres Rodriguez (andreserl)
Changed in redhat-cluster (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Andres Rodriguez (andreserl) wrote :

Attaching debdiff.

Changed in drbd8 (Ubuntu):
status: In Progress → Confirmed
assignee: Andres Rodriguez (andreserl) → nobody
Changed in redhat-cluster (Ubuntu):
status: In Progress → Confirmed
Andres Rodriguez (andreserl) wrote :

Attaching buildlog

description: updated
summary: - package drbd8-utils (not installed) failed to install/upgrade: trying to
- overwrite '/usr/share/cluster/drbd.sh', which is also in package
- rgmanager 0:3.0.2-2ubuntu3
+ SRU: package drbd8-utils (not installed) failed to install/upgrade:
+ trying to overwrite '/usr/share/cluster/drbd.sh', which is also in
+ package rgmanager 0:3.0.2-2ubuntu3
Changed in redhat-cluster (Ubuntu):
status: Confirmed → New
description: updated
Martin Pitt (pitti) wrote :

Lucid fix looks okay, I'm going to accept it into proposed. However, please also fix this for maverick and natty, otherwise this can't progress into -updates. Thanks!

Changed in drbd8 (Ubuntu):
status: Confirmed → Invalid
Changed in drbd8 (Ubuntu Lucid):
status: New → Invalid
Changed in redhat-cluster (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

Accepted redhat-cluster into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Andres Rodriguez (andreserl) wrote :

Hi,

I've just tested the proposed fix, and everything works as expected.

Thank you.

C de-Avillez (hggdh2) wrote :

Marked 'verification-done' per Andres' comment above.

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Please fix in maverick and natty, or if this isn't required, please explain why and close the main task as "invalid".

Andres Rodriguez (andreserl) wrote :

Martin,

This is already fixed in Maverick/Natty. The fix came from Debian itself. I just wanted to SRU the fix to Lucid.

Marking it as fix released for such purpose.

Regards

Changed in redhat-cluster (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package redhat-cluster - 3.0.2-2ubuntu3.1

---------------
redhat-cluster (3.0.2-2ubuntu3.1) lucid-proposed; urgency=low

  * SRUs:
    - debian/liblogthread-dev: Install missing pkg-config file (LP: #627291)
    - debian/rules: Remove drbd.sh and drbd.metadata because DRBD already
      ships them. (LP: #627174)
 -- Andres Rodriguez <email address hidden> Wed, 20 Oct 2010 12:44:43 -0400

Changed in redhat-cluster (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers