dolphin breaks when you try to open a directory with a # sign in it.

Bug #138374 reported by Chris on 2007-09-09
24
Affects Status Importance Assigned to Milestone
dolphin
Fix Released
Medium
dolphin (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: dolphin

when you try to open a directory with a "#" sign in its name dolphin says the directory doesn't exist and doesn't open it.

Hi!

Thanks for your bug report.
In order to help us process the problem, could you give us some additionnal information :
- The version of ubuntu you are using
- The version of dolphin you are using, as seen in the adept package manager

I've checked upstream, a similar bug report has already been filled and is marked resolved.[1] So unless you are using a very new version and the bug is back, this bug is already fixed :)

Thanks for the bug report and keep us informed!

[1] http://bugs.kde.org/show_bug.cgi?id=144807

Changed in dolphin:
assignee: nobody → ndeschildre
status: New → Incomplete

I'm running up to date tribe 5. It's probably that it's not fixed in this
version then, because this is in kde 3.5.7. Dolphin 0.9.2 in the package
manager it says:
0.9.2-0ubuntu1. Do I have to submit another bug report somewhere else to get
the kubuntu guys to fix this from your patch then, since it sounds like a
kubuntu issue?

Thanks,

Chris

_________________________________________________________________
Enter to win a night a VIP night out at TIFF
http://redcarpet.sympatico.msn.ca/

fogNL (fognl) wrote :

I was able to re-create this with Kubuntu Tribe 5 w/updates and Dolphin 0.9.2-0ubuntu1

Clicking on the directory with the "#" in its name does nothing, however, you can enter the directory by right-clicking and selecting Open With->Dolphin.

Changed in dolphin:
assignee: ndeschildre → nobody
status: Incomplete → Confirmed

Ok so it affect 3.5.7 but is fixed in KDE4.

As the backport policy indicates that only crash bugs fixes can be backported, i don't think the fix will be backported to 3.5.7. I might be wrong.

Anyway, thanks for your bugreports!

Changed in dolphin:
status: Unknown → Fix Released
Chris (billytwowilly) wrote :

It would be nice if the kubuntu guys backported it anyway. If they are going to have this as their default file browser, this is a fairly major bug...

Onlinelli (cornelius-maihoefer) wrote :

I reported the same bug somewhere else... turns out it was an duplicate.

I'd really appreciate this bug to be fixed. I also consider it as some quite major bug. I know quite some people trying to keep their folders organized by using signs like # or %.

Solo0815 (triple-x) wrote :

For the default Filemanager in Gutsy it´s a MAJOR Bug. Many ppl (like me) have "#"s in their (at least) directory-names.

PLS fix this bug. I don´t want to wait for KDE4

arloth (mnuahs) wrote :

It's nice that this is fixed in KDE 4, however, it's still present in 7.10, as of today (it's release date!), which uses KDE 3.5.8. Dolphin seems to have rather poor handling of characters. :-(

Dave Bekker (phyrexicaid-gmail) wrote :

Another character that Dolphin has a problem with is "/". I opened another bug report before I saw this one. I guess the two are related, perhaps they should be merged?

https://bugs.launchpad.net/ubuntu/+source/dolphin/+bug/160132

Solo0815 (triple-x) wrote :

Still no Fix for KDE 3.5.8 in Gutsy?
No Backport?
It´s a shame for the "new Filemanager" which can´t open ALL Folders. I have to use Konqueror instead.

Martin Böhm (martin.bohm) wrote :

This bug is a very troublesome one. I already have some parts of a fix and I will be releasing the patch shortly. I will do my best to convince the developers to offer it as an update for Gutsy.

Changed in dolphin:
assignee: nobody → martin.bohm
importance: Undecided → Medium
status: Confirmed → In Progress
Asraniel (asraniel) wrote :

The bug is still present in hardy. Please someone fix it.

Kaltsi (kaltsi) wrote :

I can confirm this bug on kubuntu hadry.
dolphin does cut the # and what fallows that.
example:
/home/user/1#this_is_hidden
in dolphin:
/home/user/1/

Martin Böhm (martin.bohm) wrote :

Unassigning myself as I'm not involved in Dolphin KDE3 improvements anymore. Feel free to checkout our branch and push the fix.

Changed in dolphin:
assignee: martin.bohm → nobody

this is confusing. if this bug has been fixed according to KDE Bug #144807 (linked to above), then why do I still have this problem with d3lphin 0.9.2-3?

Christian González (droetker) wrote :

In hardy (KDE3) the dolphin qt3 version is used.

$ ldd /usr/bin/dolphin |grep qt
        libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xb6c35000)

And it seems we have to wait till KDE 4.1 as KDE3 doesn't get very much love from Ubuntu, they have to few developers...

I'd help if I knew C++...

@ Christian A. Reiter
not quite, it is fixed in dolphin (1.0.2) in kde 4.0.3.

Jonathan Thomas (echidnaman) wrote :

KDE 4.1 is shipping with the next Kubuntu as the default/only KDE, so we can close this as fixed.

Changed in dolphin:
status: In Progress → Fix Released
Changed in dolphin:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.