error send_packet:message too long

Bug #274069 reported by Giovanni on 2008-09-24
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
dhcp3 (Ubuntu)
Low
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

My network working fine with ibex alfa 6 kernel 2.6.27-2 dhclient rel 3.1.1 and NetworkManager 0.7 MB asus p5k premium wifi Ap Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12).But after update kernel 2.6.27-3 my network don't work i have this error send_packet:message too long . Today(24/09) I have try daily release with kernel 2.6.27-4 live cd but my network not work error send_packet:message too long .

bug 61989 is back

:: WORKAROUND ::
1) remove the option interface-mtu in /etc/dhcp3/dhclient.conf
2) lower the mtu : sudo ifconfig eth0 mtu 1000

Related branches

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies Thanks in advance!

Changed in linux:
status: New → Incomplete
Giovanni (gfalivene) wrote :

Ready

Jean-Baptiste Lallement (jibel) wrote :

The message in "dhcp error" makes me think about a broken/misconfigured router.
Furthermore there is this line in dmesg.log:

[ 82.885456] sky2 eth0: Link is up at 10 Mbps, half duplex, flow control rx

Can you attach the output of "ifconfig eth0" and the file /etc/dhcp3/dhclient.conf

Can you try the following things and tell if it helps:
- set the router to full duplex
- lower the mtu "sudo ifconfig eth0 mtu 1436" or something lower
- remove the option interface-mtu in /etc/dhcp3/dhclient.conf

Thanks.

Giovanni (gfalivene) wrote :

work fine after :
1) remove the option interface-mtu in /etc/dhcp3/dhclient.conf
2) sudo ifconfig eth0 mtu 1000
My router work fine with gutsy hardy and ibex alfa 5. What is the problem with alfa 6 ?
Thank you very much.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up.

interface-mtu has been removed in edgy and reintroduced in intrepid. But I'd thought it was before alpha5. This is a revival of bug 61989. I'll ask about it.

confirming and affecting to dhcp3

Thanks for your help to make Ubuntu better.

Changed in linux:
status: Incomplete → Confirmed
description: updated
description: updated
Han Chung (han+c) wrote :

Just to inform, this bug still affects stable/final release Intrepid.

Giovanni (gfalivene) wrote :

confirm the problem in the final stable release Intrepid.
Thank you.

Baughn (sveina) wrote :

Please don't "fix" this "bug"

The interface-mtu option is a valid method for routers to tell computers what their MTU is, so as to avoid unnecessary fragmentation. For example, I have a router that reports an MTU of 1412; anything above this does indeed get fragmented.

While I would certainly be able to add the option myself, this is not true for everyone, and there is no reason to break perfectly functional software in order to support broken routers. Instead, I suggest filtering out obviously bogus MTUs such as anything below 200. (There are some very low-MTU links out there)

Jean-Baptiste Lallement (jibel) wrote :

This is not a bug in linux. Closing the task

Changed in dhcp3:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in linux:
status: New → Invalid

As people have said this bug seems to be similar to #61989, and it affects me and my belkin router. Note that this was not a problem in Hardy!

jmn42 (jmn-lpad) wrote :

Suggst this affect release notes for all releases with an upgrade path from Hardy.

This should probably be mentioned in the release notes since affected users (including myself) has no problem when running Hardy, but will lose the internet connection when using a release with this issue in.

The fault is not in Ubuntu, but Ubuntu is likely to get the blame unless the explanation and workaround in this issue is not very easy to find.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dhcp3 - 3.1.1-5ubuntu2

---------------
dhcp3 (3.1.1-5ubuntu2) jaunty; urgency=low

  * Raise minimum valid MTU to 577 to avoid broken devices that send 576,
    which is unlikely to be correct either (LP: #274069, debian bug #513616).

 -- Kees Cook <email address hidden> Fri, 30 Jan 2009 11:13:15 -0800

Changed in dhcp3:
status: Triaged → Fix Released
Mathias Gug (mathiaz) on 2009-10-28
Changed in ubuntu-release-notes:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments