dhcdbd: message_handler: message handler not found

Bug #228707 reported by AndreK on 2008-05-09
24
Affects Status Importance Assigned to Milestone
dhcdbd (Debian)
Fix Released
Unknown
dhcdbd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dhcdbd

please see attached log, contains lots of references to redhat ... that does not work.

dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.interface_mtu

please search attached log syslog-dump.txt file for "redhat"

ProblemType: Bug
Architecture: i386
Date: Fri May 9 16:57:10 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.24-17-generic i686

AndreK (andre-k) wrote :
description: updated
aldebx (aldebx) wrote :

I confirm this issue with Ubuntu Hardy 8.04 stable.

However it has nothing to do with yelp,
instead is related to dhcdbd (I'm with iwlwifi drivers).

This seems only an aesthetic bug since I can connect with wireless and get IP through dhcp.

Here is the relevant /var/log/messages output:

dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.host_name
dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.domain_name
dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.nis_domain
dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.nis_servers
dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.interface_mtu

AndreK (andre-k) wrote :

the reason I reported this , is connection problems, namely DHCP problems,
see attached log, search for IP 192.168.1.2 - it does not even exist on the "tkgjest" network I had trouble connecting to.
instead of geting an DHCP , it tries last IP from an completely another net.

flubio123 (clintkyksa) wrote :

I can confirm this as well on my Dell Inspiron 6000 with Ubuntu Hardy 8.04.

flubio123 (clintkyksa) wrote :

FYI: This has been logged as a bug in Debian. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464834

flubio123 (clintkyksa) wrote :

Wish I could just my comments. Did some more googling and it seems someone has already done some more investigation work @ http://ubuntuforums.org/showthread.php?t=714341

On Sun, Aug 10, 2008 at 9:49 AM, flubio123 <email address hidden> wrote:
> Wish I could just my comments. Did some more googling and it seems
> someone has already done some more investigation work @
> http://ubuntuforums.org/showthread.php?t=714341
>
Well, this one was me reporting it to ubuntu and some one else asking
about it. The Debian bug was moved from "Normal" to "Minor" so is not
too likely to be fixed though the fix should be trivial.
> --
> dhcdbd: message_handler: message handler not found
> https://bugs.launchpad.net/bugs/228707
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Man is the only animal that laughs and weeps, for he is the only
animal that is struck with the difference between what things are and
what they ought to be.
 - William Hazlitt

Brian Murray (brian-murray) wrote :

Reviewing this bug report and its comments it seems that multiple people are experiencing this problem. Subsequently, I am confirming this bug report. For future reference you can manage the status of bug reports by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status .

Changed in dhcdbd:
status: New → Confirmed
Changed in dhcdbd:
status: Unknown → New
KevinM (kevbert1) wrote :

I'm getting this on Hardy 64bit 2.6.24-19-generic kernel on an AMD64 PC. Every time I boot into Hardy this occurs.

Ketil Vestby (ketil-vestby) wrote :

The sad thing is that after doing a clean install of 8.04.1 it works fine - but "something" happend on the first upgrade making my wireless network connection b0rken. This Redhat - bug makes it really hard to pinpoint what's happening, since the data I'm looking for would have been written in these files..

Does anybody know where on the harddisk the files should be, and what permissions they should have? - I could use them to pinpoint why my wireless connection get bad.

:-)

Ketil Vestby (ketil-vestby) wrote :

For some strange reason, this worksforme - on Intepid. Have had a mutitude of bugs related to the ipw2200 driver, but none of these have shown any pointers to the redhat-directory.

aesis05401 (aesis05401) wrote :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=527849

The dhcdbd package is dead upstream and is no longer being distributed with network-manager .7 and greater. Ubuntu Karmic appears to be at n-m .8, and the package list does not include dhcdbd.

Changed in dhcdbd (Debian):
status: New → Fix Released

您发给我的邮件我已收到。
------------------------------------------------

                                                                               何帅昆

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.