debuild fails if GREP_OPTIONS are set in environment

Bug #581319 reported by Andreas Roth on 2010-05-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
devscripts (Debian)
Fix Released
Unknown
devscripts (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: devscripts

devscripts: version 2.10.61ubuntu5

On my PC i set the GREP_OPTIONS environment variable in .bashrc:
export GREP_OPTIONS='-Hn --color=auto'

When the GREP_OPTIONS are set, debuild will fails with the following line:
debuild: fatal error at line 643:
don't understand dpkg-parsechangelog output: (standard input):1:Source: pkgname

I recommend to reset all GREP environment variables to an emtpy string (default), to ensure that grep is working as expected within the devscripts.

Logan Rosen (logan) wrote :

This is probably the same bug as http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501055. Are you running debuild with --preserve-env?

Andreas Roth (aroth) wrote :

You're right it is the same issue.
I run the debuild from the package directory which any arguments and debuild immediately terminates with the error (on ubuntu precise):
debuild: fatal error at line 640:
don't understand dpkg-parsechangelog output: (standard input):1:Source: pkgname

I noticed that the options '-Hn' to grep are the cause of the problem. Only using the '--color=auto' option does not hurt at all.

Logan Rosen (logan) wrote :

Thanks for confirming that it is the same bug! I have added a bug watch for the bug in Debian.

Changed in devscripts (Debian):
status: Unknown → New
Benjamin Drung (bdrung) wrote :

I committed the fix in the Debian git repository [1]. It will be fixed in the next upload.

[1] http://anonscm.debian.org/gitweb/?p=devscripts/devscripts.git;a=commitdiff;h=a0bfdf4b

Changed in devscripts (Ubuntu):
status: New → Fix Committed
Benjamin Drung (bdrung) on 2012-10-20
Changed in devscripts (Ubuntu):
importance: Undecided → Low
Changed in devscripts (Debian):
status: New → Fix Committed
Changed in devscripts (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package devscripts - 2.12.5

---------------
devscripts (2.12.5) unstable; urgency=low

  [ James McCoy ]
  * bts:
    + Provide a clearer error message when Authen::SASL isn't installed.
      (Closes: #689816)
    + Don't require a usertag after 'bts usertag <bug> ='. (Closes: #689815)
    + Don't require a package after 'bts affects <bug> ='. (Closes: #690131)
  * Add German translation of man pages. Thanks to Chris Leick. (Closes:
    #687985)

  [ Benjamin Drung ]
  * Fix Subversion typo and write all instances of it with an capital initial
    letter. Thanks to Regid Ichira for the finding. (Closes: #689953)
  * debuild:
    - Fix failure if called with --preserve-env and GREP_OPTIONS is set.
      Thanks to Aaron Culich for the patch. (Closes: #501056, LP: #581319)
    - Add missing bits to support dpkg-genchanges hook.
      Thanks to Maciej Malycha for the patch. (LP: #1065201)
  * wrap-and-sort: Sort Pre-Depends list (LP: #1070599)

  [ David Prévot ]
  * French translation update.

 -- Benjamin Drung <email address hidden> Wed, 24 Oct 2012 22:15:34 +0200

Changed in devscripts (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.