USB flash drive does not mount automatically

Bug #452768 reported by LarryGrover on 2009-10-16
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
devicekit-disks (Ubuntu)
Undecided
Unassigned

Bug Description

System is a netbook (Acer Aspire One) with a fresh install of Karmic netbook-remix beta, and all updates installed.

When I plug a USB flash drive, it does not mount. The flash drive is fine, and automounts on other systems running Ubuntu 9.04 (also windows, mac osx).

Some additional information:

grover@stingray:~$ uname -a
Linux stingray 2.6.31-14-generic #47-Ubuntu SMP Thu Oct 15 02:08:08 UTC 2009 i686 GNU/Linux

grover@stingray:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

grover@stingray:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 0781:5406 SanDisk Corp. Cruzer Micro 1/2/4GB Flash Drive
Bus 001 Device 002: ID 064e:d101 Suyin Corp. Acer CrystalEye Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

grover@stingray:~$ devkit-disks --mount /dev/sdb1
Mounted /org/freedesktop/DeviceKit/Disks/devices/sdb1 at /media/0BC6-007E

I will attach dmesg output after inserting the flash drive.

ProblemType: Bug
Architecture: i386
Date: Thu Oct 15 23:47:47 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.28.0-0ubuntu6
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: nautilus
Tags: ubuntu-unr
Uname: Linux 2.6.31-14-generic i686

LarryGrover (lgrover) wrote :
LarryGrover (lgrover) wrote :

dmesg output immediately after USB flash drive is inserted. The system is recognizing the USB drive (sdb), but it is not mounting it.

Jackallen (jackallen) wrote :

Try this:

1.backup this file to somewhere else /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi

2.delete it in the terminal:
sudo rm /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi

3.restart HAL service:
sudo service hal restart

Then re-plug USB drive

LarryGrover (lgrover) wrote :

jackallen: I moved /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi to a different location and restarted hal. This had no effect. When I plug in my USB flash drive, it still fails to mount.

affects: ubuntu → devicekit-disks (Ubuntu)
Busby (mobusby) wrote :
Download full text (10.2 KiB)

This happens on stock Karmic Beta as well. Any USB drive plugged in after booting will not automount. Mounting manually works as usual.

as can be seen below, the devices are recognized, but automounting fails due to an I/O error.

before plugging in devices, after restarting:
$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 0bc2:3001 Seagate RSS LLC
Bus 001 Device 004: ID 0b38:0010
Bus 001 Device 003: ID 046d:c521 Logitech, Inc. MX620 Laser Cordless Mouse
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

after plugging in two devices:
$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 011: ID 0781:5530 SanDisk Corp.
Bus 001 Device 010: ID 0fca:8004 Research In Motion, Ltd.
Bus 001 Device 005: ID 0bc2:3001 Seagate RSS LLC
Bus 001 Device 004: ID 0b38:0010
Bus 001 Device 003: ID 046d:c521 Logitech, Inc. MX620 Laser Cordless Mouse
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ dmesg | tail -120
[ 3237.672088] usb 1-7: new high speed USB device using ehci_hcd and address 10
[ 3237.817510] usb 1-7: configuration #1 chosen from 1 choice
[ 3237.824268] scsi7 : SCSI emulation for USB Mass Storage devices
[ 3237.824505] usb-storage: device found at 10
[ 3237.824509] usb-storage: waiting for device to settle before scanning
[ 3238.368109] usb 1-8: new high speed USB device using ehci_hcd and address 11
[ 3238.505256] usb 1-8: configuration #1 chosen from 1 choice
[ 3238.505575] scsi8 : SCSI emulation for USB Mass Storage devices
[ 3238.505797] usb-storage: device found at 11
[ 3238.505801] usb-storage: waiting for device to settle before scanning
[ 3242.821017] usb-storage: device scan complete
[ 3242.822116] scsi 7:0:0:0: Direct-Access RIM BlackBerry SD 0003 PQ: 0 ANSI: 4 CCS
[ 3242.823146] sd 7:0:0:0: Attached scsi generic sg3 type 0
[ 3242.839590] sd 7:0:0:0: [sdc] Attached SCSI removable disk
[ 3243.504424] usb-storage: device scan complete
[ 3243.505006] scsi 8:0:0:0: Direct-Access SanDisk SanDisk Cruzer 8.02 PQ: 0 ANSI: 0 CCS
[ 3243.505845] scsi 8:0:0:1: CD-ROM SanDisk SanDisk Cruzer 8.02 PQ: 0 ANSI: 0
[ 3243.506857] sd 8:0:0:0: Attached scsi generic sg4 type 0
[ 3243.508047] sd 8:0:0:0: [sdd] 15695871 512-byte logical blocks: (8.03 GB/7.48 GiB)
[ 3243.509141] sd 8:0:0:0: [sdd] Write Protect is off
[ 3243.509147] sd 8:0:0:0: [sdd] Mode Sense: 45 00 00 08
[ 3243.509152] sd 8:0:0:0: [sdd] Assuming drive cache: write through
[ 3243.510520] sr1: scsi3-mmc drive: 48x/48x tray
[ 3243.510720] sr 8:0:0:1: Attached scsi CD-ROM sr1
[ 3243.510829] sr 8:0:0:1: Attached scsi generic sg5 type 5...

Changed in devicekit-disks (Ubuntu):
status: New → Confirmed
Busby (mobusby) wrote :

Changed status to confirmed.

LarryGrover (lgrover) wrote :

I am no longer experiencing this bug. I guess one of the updates I installed in the last couple of days must have fixed the problem.

oshunluvr (stuartksmith) wrote :

I am still experiencing this bug.

Requested files below

oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :
oshunluvr (stuartksmith) wrote :

I am now seeing an additional udev/hal problem when using VirtualBox. I believe this is related to the above issue.

VitrualBox Error Message:
Could not access USB on the host system, because neither the USB file system (usbfs) nor the DBus and hal services are currently available. If you wish to use host USB devices inside guest systems, you must correct this and restart VirtualBox.
The USB Proxy Service could not be started, because neither the USB file system (usbfs) nor the hardware information service (hal) is available.

Oleg Blednov (blake-r) wrote :

Jackallen, you method almost correct bug in my case. But need reboot, rather than just restart hal.

After that, I'm even reinstall hal and automount work correctly.

Martin Pitt (pitti) wrote :

First, please have a look at bug 463347. The udev update there fixes a lot of those cases.

In Ubuntu 9.10 (Karmic), hal has nothing to do with hanlding storage devices any more, so poking it won't help.

If it still happens with the new udev, please do "ubuntu-bug", select "storage problem", and file a new bug with this (this will collect the necessary debug information). Please let me know the number here, so that I can link them.

Thanks!

Changed in devicekit-disks (Ubuntu):
status: Confirmed → Incomplete

Did not work for me. Opened bug #479206 as requested.

There's no udev bug here that I can see, sdc1 is present in the udev db and populated with the correct info (including blkid detecting it as fat16)

Martin Pitt (pitti) wrote :

Giulio, you have a completely different problem. I followed up in bug 479206.

LarryGrower, as the original reporter you confirmed that it's working for you now, so I close this one.

Martin Pitt (pitti) wrote :

Everyone else who has storage problems, please report a new bug using "ubuntu-bug storage". Thanks!

Changed in devicekit-disks (Ubuntu):
status: Incomplete → Fix Released
brownknight (ramilclarin) wrote :

I am having the same issue as oshunluvr on VirtualBox:
VitrualBox Error Message:
Could not access USB on the host system, because neither the USB file system (usbfs) nor the DBus and hal services are currently available. If you wish to use host USB devices inside guest systems, you must correct this and restart VirtualBox.
The USB Proxy Service could not be started, because neither the USB file system (usbfs) nor the hardware information service (hal) is avaiable.

andromedar (andromedar) on 2010-03-30
Changed in devicekit-disks (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers