Ubuntu

desktopcouch-service crashed with RuntimeError in find_port__linux()

Reported by helopepe on 2009-10-30
632
This bug affects 123 people
Affects Status Importance Assigned to Milestone
desktopcouch
High
Chad Miller
Gentoo Linux
Invalid
Undecided
Unassigned
desktopcouch (Ubuntu)
High
Unassigned
Karmic
Undecided
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: desktopcouch

desktopcouch-service crashed with RuntimeError in find_port__linux()

ProblemType: Crash
Architecture: i386
Date: Fri Oct 30 18:38:42 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/desktopcouch/desktopcouch-service
InterpreterPath: /usr/bin/python2.6
Package: desktopcouch 0.5-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/desktopcouch/desktopcouch-service
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
PythonArgs: ['/usr/lib/desktopcouch/desktopcouch-service']
SourcePackage: desktopcouch
Title: desktopcouch-service crashed with RuntimeError in find_port__linux()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

lp:~cmiller/desktopcouch/find-port-runtimeerror2
Merged into lp:desktopcouch at revision 157
Eric Casteleijn (community): Approve on 2010-04-28
Tim Cole (community): Approve on 2010-04-27
helopepe (helopepe) wrote :

This crash has the same stack trace characteristics as bug #442120. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Chad Miller (cmiller) on 2009-12-18
Changed in desktopcouch (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) on 2009-12-18
Changed in desktopcouch (Ubuntu):
status: New → Fix Committed
Chad Miller (cmiller) on 2009-12-21
Changed in desktopcouch (Ubuntu):
status: Fix Committed → Confirmed
Changed in desktopcouch:
status: New → Fix Released
Changed in desktopcouch (Ubuntu):
assignee: Chad Miller (cmiller) → nobody
Changed in desktopcouch:
assignee: nobody → Chad Miller (cmiller)
tags: added: bugpattern-needed
visibility: private → public
tags: added: bugpattern-written
removed: bugpattern-needed
Chad Miller (cmiller) wrote :
Changed in desktopcouch (Ubuntu):
assignee: nobody → Ubuntu Stable Release Updates Team (ubuntu-sru)
miked (miked11) wrote :

root@LeftGuest:~# lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
root@LeftGuest:~#
Alpha 2 Lucid Lynx ix386.iso

Martin Pitt (pitti) wrote :

Patch looks fine, please get it uploaded to lucid and karmic-proposed.

Changed in desktopcouch (Ubuntu):
assignee: Ubuntu Stable Release Updates Team (ubuntu-sru) → Ken VanDine (ken-vandine)
Ken VanDine (ken-vandine) wrote :

Chad: There isn't a release tarball for 0.5.1, can you publish one?

Chad Miller (cmiller) wrote :

Ken, There's this:

https://edge.launchpad.net/desktopcouch/+milestone/0.5.1-stable

i don't know why that isn't visible on the desktopcouch project page.

Ken VanDine (ken-vandine) wrote :

This was fixed in 0.6.3

Changed in desktopcouch (Ubuntu):
status: Confirmed → Fix Released
Ryan Kitty (gothickitty93) wrote :

this bug still affects me on Lucid Daily Devel from April 16th, 2010

April 17th. Tried to open gwibber from me menu through (Set Up Broadcast Accounts). Failed to open gwibber and reported error, and then gwibber error in bug #539781

Changed in desktopcouch:
status: Fix Released → New
Changed in desktopcouch (Ubuntu):
status: Fix Released → New
Changed in desktopcouch:
status: New → Fix Released
Changed in desktopcouch (Ubuntu):
importance: Undecided → High

Made New and release blocking. Note that gwibber did open the settings window eventually. Account info was synced, so only passwords needed to be entered.

Qays Poonawala (qayshp) wrote :

on boot, 10.04 beta 2, latest updates

I'm also being affected in a Ubuntu 10.04 Beta 2 updated today, 19/04/2010.

SiscoGarcia (sisco) wrote :

I'm also being affected in an Ubuntu 10.04 Beta 2. The notice was shown to me just when I opened Gwibber.

Ken VanDine (ken-vandine) wrote :

Making this New again, it looks like people are still affected by this.

Changed in desktopcouch:
importance: Undecided → High
status: Fix Released → New
Chad Miller (cmiller) wrote :

If this is still happening, I want a new backtrace, please.

Changed in desktopcouch (Ubuntu Lucid):
status: New → Incomplete
tags: added: cmiller
tags: removed: cmiller
Chad Miller (cmiller) on 2010-06-21
Changed in desktopcouch:
status: New → Incomplete
Maciej Piechotka (uzytkownik2) wrote :

desktopcouch 0.6.4:

mpiechotka@localhost ~ % cat .cache/desktop-couch/desktop-couchdb.stdout

=CRASH REPORT==== 7-Jul-2010::18:20:46 ===
  crasher:
    initial call: couch_config:init/1
    pid: <0.76.0>
    registered_name: []
    exception exit: {{case_clause,{error,eacces}},
                     [{couch_config,parse_ini_file,1},
                      {couch_config,'-init/1-fun-0-',1},
                      {lists,map,2},
                      {couch_config,init,1},
                      {gen_server,init_it,6},
                      {proc_lib,init_p_do_apply,3}]}
      in function gen_server:init_it/6
    ancestors: [<0.32.0>]
    messages: []
    links: [<0.32.0>]
    dictionary: []
    trap_exit: false
    status: running
    heap_size: 610
    stack_size: 24
    reductions: 179
  neighbours:

=CRASH REPORT==== 7-Jul-2010::18:20:46 ===
  crasher:
    initial call: application_master:init/4
    pid: <0.31.0>
    registered_name: []
    exception exit: {bad_return,
                        {{couch_app,start,
                             [normal,
                              ["/etc/couchdb/default.ini",
                               "/etc/couchdb/local.ini"]]},
                         {'EXIT',
                             {{badmatch,
                                  {error,
                                      {{case_clause,{error,eacces}},
                                       [{couch_config,parse_ini_file,1},
                                        {couch_config,'-init/1-fun-0-',1},
                                        {lists,map,2},
                                        {couch_config,init,1},
                                        {gen_server,init_it,6},
                                        {proc_lib,init_p_do_apply,3}]}}},
                              [{couch_server_sup,start_server,1},
                               {application_master,start_it_old,4}]}}}}
      in function application_master:init/4
    ancestors: [<0.30.0>]
    messages: [{'EXIT',<0.32.0>,normal}]
    links: [<0.30.0>,<0.6.0>]
    dictionary: []
    trap_exit: true
    status: running
    heap_size: 987
    stack_size: 24
    reductions: 118
  neighbours:

desktopcouch stack:

  File "/usr/lib64/python2.6/site-packages/desktopcouch/__init__.py", line 51, in find_port
    return _direct_access_find_port(pid=pid, ctx=ctx)
  File "/usr/lib64/python2.6/site-packages/desktopcouch/__init__.py", line 132, in __find_port__linux
    raise RuntimeError("Unable to find listening port")
RuntimeError: Unable to find listening port

Notes:

/etc/couchdb/default.ini and /etc/couchdb/local.ini have 0660 permission.

Maciej Piechotka (uzytkownik2) wrote :

Crash seems to occure when /etc/couchdb/*.ini are not user readable. At least on Gentoo.

Chad Miller (cmiller) wrote :

Maciej, yes, that's exactly correct. "eacces". We must be able to read the system INI files. I suggest 0664 perms.

ok thanks

> Date: Wed, 7 Jul 2010 18:09:37 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 465216] Re: desktopcouch-service crashed with RuntimeError in find_port__linux()
>
> Maciej, yes, that's exactly correct. "eacces". We must be able to read
> the system INI files. I suggest 0664 perms.
>
> --
> desktopcouch-service crashed with RuntimeError in find_port__linux()
> https://bugs.launchpad.net/bugs/465216
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Desktop CouchDB: Incomplete
> Status in “desktopcouch” package in Ubuntu: New
> Status in “desktopcouch” source package in Lucid: Incomplete
> Status in “desktopcouch” source package in Karmic: New
> Status in Gentoo Linux: New
>
> Bug description:
> Binary package hint: desktopcouch
>
> desktopcouch-service crashed with RuntimeError in find_port__linux()
>
> ProblemType: Crash
> Architecture: i386
> Date: Fri Oct 30 18:38:42 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/lib/desktopcouch/desktopcouch-service
> InterpreterPath: /usr/bin/python2.6
> Package: desktopcouch 0.5-0ubuntu1
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/lib/desktopcouch/desktopcouch-service
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_US.UTF-8
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> PythonArgs: ['/usr/lib/desktopcouch/desktopcouch-service']
> SourcePackage: desktopcouch
> Title: desktopcouch-service crashed with RuntimeError in find_port__linux()
> Uname: Linux 2.6.31-14-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/desktopcouch/+bug/465216/+subscribe

_________________________________________________________________
Novità dai tuoi amici? Le trovi su Messenger
http://www.messenger.it/novita.aspx

Chris Plaza (cplaza) wrote :

Anytime I use Firefox.

Ronshua (ronshua) wrote :

Nuts .

Changed in desktopcouch (Ubuntu Lucid):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in desktopcouch (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Chad Miller (cmiller) wrote :

(Partial transcript from online chat)

D: I don't really think setting 0664 on /etc/couchdb/local.ini is a very good idea, since that may have the admin password in it.

Chad: desktopcouch is sending these parameters, for me: -a /etc/couchdb/default.ini -a /etc/xdg/desktop-couch/compulsory-auth.ini -a /home/cmiller/.config/desktop-couch/desktop-couchdb.ini

Chad: the couchdb bootstrap script in the PATH adds more. (namely /etc/couchdb/local.ini)

Chad: so, either 1) user must put auth in another file and load it with -a, and make others readable, or 2) we reimplement /usr/bin/couchdb and ship our own, or 3) we patch it and get upstream not to do that.

Chad Miller (cmiller) wrote :

I don't think this is valid any more. There are no recent complaints since the Gentoo packaging problem of unreadable couchdb config files. Please create discrete new bug reports for continuing problems.

Changed in desktopcouch:
status: Incomplete → Fix Released
Changed in desktopcouch (Ubuntu Lucid):
status: Incomplete → Fix Released
Changed in gentoo:
status: New → Invalid
Changed in desktopcouch (Ubuntu Karmic):
status: New → Incomplete
Changed in desktopcouch (Ubuntu):
status: New → Incomplete
miked (miked11) wrote :

I don't have access to this computer anymore, and it has been upgraded many times since this. can close this bug for me.

Changed in desktopcouch (Ubuntu):
status: Incomplete → Opinion
miked (miked11) on 2011-09-12
Changed in desktopcouch (Ubuntu Karmic):
status: Incomplete → Opinion
Chad Miller (cmiller) on 2011-09-12
Changed in desktopcouch (Ubuntu Karmic):
status: Opinion → Incomplete
Changed in desktopcouch (Ubuntu):
status: Opinion → Incomplete
To post a comment you must log in.