desktopcouch-service crashed with RuntimeError in find_port__linux()

Bug #442120 reported by Vorticerosso on 2009-10-04
834
This bug affects 170 people
Affects Status Importance Assigned to Milestone
desktopcouch
Critical
Chad Miller
desktopcouch (Ubuntu)
High
Chad Miller
Karmic
High
Chad Miller

Bug Description

Just started

ProblemType: Crash
Architecture: i386
Date: Sun Oct 4 13:00:03 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/desktopcouch/desktopcouch-service
InterpreterPath: /usr/bin/python2.6
Package: desktopcouch 0.4.2-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/desktopcouch/desktopcouch-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=it_IT.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
PythonArgs: ['/usr/lib/desktopcouch/desktopcouch-service']
SourcePackage: desktopcouch
Title: desktopcouch-service crashed with RuntimeError in find_port__linux()
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1682): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1682): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1725): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1778): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1724): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -2 and height 24

Related branches

Vorticerosso (vorticerosso) wrote :
tags: removed: need-duplicate-check
affects: ubuntu → desktopcouch (Ubuntu)
visibility: private → public
Andrey Zhekov (x3ro.daemon) wrote :

crash on Evolution's start
Ubuntu 9.10 beta 64bit (updated on 07.10.2009)

Changed in desktopcouch (Ubuntu):
status: New → Confirmed

Architecture: amd64
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: desktopcouch 0.4.2-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.39-generic
Uname: Linux 2.6.31-12-generic x86_64
UserGroups:

XsessionErrors:
 (gnome-settings-daemon:2083): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2083): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2189): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2166): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:2162): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.2/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

tags: added: apport-collected
PEIGNOT Kévin (kpeignot) wrote :

I have this bu too, but not on evolution's start, but every time I open the session. I reported my bug there, but it seems it's the seame bug, so I put the link: https://bugs.launchpad.net/ubuntu/+source/desktopcouch/+bug/447842

Chad Miller (cmiller) on 2009-10-16
Changed in desktopcouch (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) on 2009-10-16
Changed in desktopcouch:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Chad Miller (cmiller)
Changed in desktopcouch:
status: Fix Committed → Triaged
Changed in desktopcouch (Ubuntu):
importance: Undecided → High
Changed in desktopcouch:
importance: Critical → High
Joshua Hoover (joshuahoover) wrote :

I think I stomped on Chad's updates on this. I'm changing back to what he had originally. Sorry about that!

tags: added: ubuntuone-karmic
Changed in desktopcouch:
status: Triaged → Fix Committed
importance: High → Critical
Christian Berg (xeniac) wrote :

Seems that this Bug starts to affect me to, since the last update.

I should mention that the "real" couchdb daeomon can not start on both of my systems out of the box. /var/log/couchdb/0.10.0 and /var/lib/couchdb/0.10.0 dind'nt exists. I added them by hand and owned them as couchdb:couchdb 0775.

Since then i could start couchdb with /etc/init.d/couchdb start, but /usr/lib/deskopcouch/desktopcouch-service gives me:
Apache CouchDB has started, time to relax.
Desktop CouchDB is not running; starting it. ...waiting for couchdb to start...
...waiting for couchdb to start...
...waiting for couchdb to start...
.
.
.
Traceback (most recent call last):
  File "/usr/lib/desktopcouch/desktopcouch-service", line 99, in <module>
    replication_runtime = replication.set_up(desktopcouch.find_port)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/replication.py", line 214, in set_up
    port = port_getter()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/__init__.py", line 40, in find_port__linux
    pid = find_pid()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/__init__.py", line 29, in find_pid
    pid = start_local_couchdb.start_couchdb()
  File "/usr/lib/python2.6/dist-packages/desktopcouch/start_local_couchdb.py", line 303, in start_couchdb
    write_bookmark_file(username, password, pid)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/start_local_couchdb.py", line 276, in write_bookmark_file
    port = desktopcouch.find_port(pid=pid)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/__init__.py", line 50, in find_port__linux
    raise RuntimeError("Unable to find file descriptors in /proc")
RuntimeError: Unable to find file descriptors in /proc

Franck (alci) wrote :

Happened to me while Evolution was filtering mails. Each time I start evolution again, it will crash...

Christian Berg (xeniac) wrote :

I fixed it for me.
I deleted all of my desktop-couch folders, now couchdb does start and the desktopcouch-service does not crash:
rm -Rf ~/.config/desktop-couch, ~/.local/share/desktop-couch, and ~/.cache/deskop-couch

This are two Bugs for me:
1st: desktopcouch can not start couchdb under some conditions.
2nd: desktopcouch crashes if the couchdb can not start.

Chad Miller (cmiller) on 2009-10-19
Changed in desktopcouch:
status: Fix Committed → Fix Released
Changed in desktopcouch (Ubuntu):
milestone: none → ubuntu-9.10
Noel J. Bergman (noeljb) wrote :

Fix Released? In what version? See Bug 456787, where I just reported it.

Martin Pitt (pitti) on 2009-10-23
Changed in desktopcouch (Ubuntu Karmic):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

The package is in unapproved now, but it has tons of other changes; I reviewed them, but I can't judge correctness since I don't understand the surrounding code.

Ken said that he tested this a lot and it works well for him.

Hi Martin,

Thank you very much for a great distro,i must say i am very happy with
kubuntu, i have since ubuntu 7.1 been upgrading on this old computer HP
Pavilion PC w 1158 d,upgrade 8.04-8.1-9.04 all gnome,i changed to
kubuntu-desktop in jaunty and did a update-manager -d and got karmic,so
this info might give you some info of whay i get error.Hope it helps.I
am running LinuxMint 7.0 Gloria KDE on my laptop Samsung SensR510 but
when final release of Kubuntu comes out 29th.Keep up the good work and
keep the world free from MICROSOFT and their companions.

Cheers,

Arne Aukan

-----Original Message-----
From: Martin Pitt <email address hidden>
Reply-to: Bug 442120 <email address hidden>
To: <email address hidden>
Subject: [Bug 442120] Re: desktopcouch-service crashed with RuntimeError
in find_port__linux()
Date: Fri, 23 Oct 2009 09:51:22 -0000

The package is in unapproved now, but it has tons of other changes; I
reviewed them, but I can't judge correctness since I don't understand
the surrounding code.

Ken said that he tested this a lot and it works well for him.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktopcouch - 0.5-0ubuntu1

---------------
desktopcouch (0.5-0ubuntu1) karmic; urgency=low

  * New upstream release.
    + Fix remote-db-listing bug for SSL/HTTPS services. (LP: #458540)
    + Fix OAuth signatures for SSL urls.
    + Avoid couchdb bug where users' PID files are incorrectly interpreted as
      valid by couchdb, and so after slightly different boot, desktopcouch can
      never start couchdb, causing desktopcouch to quit. (LP: #442120)
    + For dbus, do not resolve data for events signaling a service disappears,
      and use explicit veriable-passing / references. (LP: #440072)
    + Flip push/pull logic in replication information.
    + When pulling from remote DB, do not try to access remote management DB.
    + Use meaningful names for keyring access. (LP: #451333)

 -- Chad MILLER <email address hidden> Thu, 22 Oct 2009 17:15:57 -0400

Changed in desktopcouch (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in desktopcouch:
status: Fix Released → New
Chad Miller (cmiller) on 2009-12-09
Changed in desktopcouch:
status: New → Fix Released
Dmitriy Larchenko (neokril) wrote :

I have this problem with desktopcouch version 0.6.4-0ubuntu1

My system: Ubuntu lucid, amd64

> I have this problem with desktopcouch version 0.6.4-0ubuntu1
>
> My system: Ubuntu lucid, amd64
>

Hi, in my case, after upgrade to kernel 2.6.32-21 that bug is an ex-bug.
After all, lucid is still in beta, so be cool. Take care.
Martin

Dmitriy Larchenko (neokril) wrote :

> Hi, in my case, after upgrade to kernel 2.6.32-21 that bug is an ex-bug.

Yes, update to the latest kernel helped me too :-)

Chris Plaza (cplaza) wrote :

Did all the updates but I still get this. Just opening a Firefox instance and a Terminal session. Rythmbox is playing in background.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers