Open packages (debs) in Ubuntu Software Center by default, not Archive Manager

Bug #629846 reported by Halvor Lyche Strandvoll on 2010-09-03
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Wishlist
Sebastien Bacher
Maverick
Wishlist
Sebastien Bacher
software-center (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: nautilus

Open packages (debs) in Ubuntu Software Center by default, not Archive Manager.

This would be better for new users.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.31.90-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Sep 3 23:02:55 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 LANG=nb_NO.utf8
 SHELL=/bin/bash
SourcePackage: nautilus

Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
affects: nautilus (Ubuntu) → desktop-file-utils (Ubuntu)
Changed in desktop-file-utils (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
Kiwinote (kiwinote) on 2010-09-06
Changed in software-center (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → Medium

Work great now :)

Changed in desktop-file-utils (Ubuntu Maverick):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.16-0ubuntu3

---------------
desktop-file-utils (0.16-0ubuntu3) maverick; urgency=low

  * debian/defaults.list: default to software-center for the deb (lp: #629846)

  [ Martin Pitt ]
  * Add bzr-builddeb configuration (merge mode).
 -- Sebastien Bacher <email address hidden> Mon, 06 Sep 2010 18:04:44 +0200

Changed in desktop-file-utils (Ubuntu Maverick):
status: Fix Committed → Fix Released

I does get it opened in Archive Manager on my laptop. Its not fixed yet...

Changed in software-center (Ubuntu Maverick):
status: Confirmed → Fix Released

I have downloaded the update (desktop-file-utils) but it does not open in Software Center. It open Archive Manager now too.

You guys might want to consider that since .deb packages are already set to open in Archive Manager, applying an update won't change that. You can make .deb packages open in Software Center by right clicking a .deb package in Nautilus, clicking properties, going to the "Open With" tab, and choosing Ubuntu Software Center.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers