Reproducible segfault with desktop-file-validate

Bug #188073 reported by Siegfried Gevatter on 2008-02-01
4
Affects Status Importance Assigned to Milestone
desktop-file-utils
Fix Released
Medium
desktop-file-utils (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: desktop-file-utils

Try to validate a file containing a line looking different than "a=b" or "[a]" makes desktop-file-validate segfault. For example:

""" file.desktop """
[Desktop Entry]
Version=1.0
a
"""

[rainct, debian]$ desktop-file-validate file.desktop
Segmentation fault (core dumped)

Changed in desktop-file-utils:
importance: Undecided → Low
status: New → Confirmed
Michael Bienia (geser) wrote :
Changed in desktop-file-utils:
assignee: nobody → desktop-bugs
status: Confirmed → Triaged

The bug has been opened on https://bugs.launchpad.net/ubuntu/+source/desktop-file-utils/+bug/188073

"Binary package hint: desktop-file-utils

Try to validate a file containing a line looking different than "a=b" or "[a]" makes desktop-file-validate segfault. For example:

""" file.desktop """
[Desktop Entry]
Version=1.0
a
"""

[rainct, debian]$ desktop-file-validate file.desktop
Segmentation fault (core dumped)

http://launchpadlibrarian.net/11704139/debdiff
Debdiff containing fix (915 bytes, text/plain)"

Sebastien Bacher (seb128) wrote :

Thank you for the work there, I've sent the bug and patch upstream and will likely wait for their comment before uploading a change since the bug is a minor one

Sebastien Bacher (seb128) wrote :

The bug has been fixed to cvs, http://webcvs.freedesktop.org/menus/desktop-file-utils/src/validate.c?r1=1.28&r2=1.29&view=patch, upstream used a different change though

Changed in desktop-file-utils:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

The issue doesn't seem something worth doing backporting, do you need the change?

Michael Bienia (geser) wrote :

From my point of view, this can wait for the next upstream version. Such broken desktop files are not common enough.

Changed in desktop-file-utils:
status: Unknown → Confirmed

Fixed in head.

Changed in desktop-file-utils:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.15-1ubuntu1

---------------
desktop-file-utils (0.15-1ubuntu1) hardy; urgency=low

  * Sync on debian:
    - don't crash on short key (lp: #188073)
  * debian/control:
    - maintained by the Ubuntu Desktop Team
  * debian/desktop-file-utils.install, debian/desktop-file-utils.links:
    - install the defaults.list.

 -- Sebastien Bacher <email address hidden> Tue, 04 Mar 2008 22:31:46 +0100

Changed in desktop-file-utils:
status: Fix Committed → Fix Released
Changed in desktop-file-utils:
importance: Unknown → Medium
Changed in desktop-file-utils:
importance: Medium → Unknown
Changed in desktop-file-utils:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.