Ubuntu

Alpha-5 alternate installer fails

Reported by Henk Koster on 2008-09-15
86
This bug affects 9 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

Tried installing from Alpha-5 intrepid-alternate-amd64.iso (checked quality of CD burn with MD5SUM). My hardware: Asus M3A32-MVP DeLuxe mobo, AMD Phenom 9850 Black Edition Quad processor, 4 GB RAM, IDE dvd/cd.
Installer needed additional boot option "acpi=off", otherwise USB keyboard wouldn't be responsive.

The problem occurred halfway through the installation of the base system, when the installer asked for insertion of the disc labelled 'Ubuntu 8.10 _Intrepid Ibex_-Alpha amd64 (20080903.2)' in the drive /cdrom/ and to press Enter. Mmm..., wasn't that disc already in that drive? What was the installer installing from? Anyway, neither hitting Enter nor hitting Back would budge the installer from this message, stopping the installation cold.

I've tried a number of combinations of other additional boot options (together with "acpi=off"), but all of them ended with the above message.

Now, I did manage to install Intrepid in the end: first install Hardy from the alternate-amd64.iso (no additional boot options required, whole installation went without a hitch); then using the "update-manager -d" command to upgrade to the latest Intrepid, which also went without a hitch.

Henk Koster (h-a-j-koster) wrote :

I replaced the IDE dvd/cd-drive with a new SATA drive, then tried to install again from the alpha-5 intrepid-alternate-amd64.iso. This time the installation went OK, so the conclusion is warranted that the problem was with recognizing my IDE dvd/cd-drive.

But note that there appears to be nothing wrong with this IDE drive: I managed to install Hardy with it using the hardy-alternate-amd64.iso, and a few weeks ago I installed Debian testing with it in another partition.

[On another note: the 2.6.27-amd64-2 kernel, once installed, also required the "acpi=off" boot option. After this kernel was upgraded to the -3 version, there appeared still a problem with vesafb (computer beeping a few times), then continuing to boot without any ill effects, it would seem. I'm not filing a bug on that.]

This happens/happened to me as well. Alternate CDROM stops ~40% into base system and wants another CDROM.

Alternate i386 Alpha-4 and Alpha-5.

Desktop Alpha-4/5 i386 is OK (I installed from that).
Never had problems with Gutsy, Hardy etc. Not seen anything like this before.

CDROM info (running Gutsy just now) :

NEC AD-7170A-0B
E-IDE/ATAPI

Not sure what the "jmicron" part is - PATA to SATA? Maybe part of the problem.

[ 29.648434] scsi0 : pata_jmicron
[ 29.648469] scsi1 : pata_jmicron
[ 29.648485] ata1: PATA max UDMA/100 cmd 0x0001df00 ctl 0x0001de02 bmdma 0x0001db00 irq 16
[ 29.648488] ata2: PATA max UDMA/100 cmd 0x0001dd00 ctl 0x0001dc02 bmdma 0x0001db08 irq 16
[ 29.842979] usb 3-1: device not accepting address 2, error -71
[ 29.961002] ata_piix 0000:00:1f.2: version 2.11
[ 29.961007] ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
[ 29.961050] PCI: Setting latency timer of device 0000:00:1f.2 to 64
[ 29.961184] scsi2 : ata_piix
[ 29.961311] scsi3 : ata_piix
[ 29.961328] ata3: SATA max UDMA/133 cmd 0x0001f800 ctl 0x0001f702 bmdma 0x0001f400 irq 19
[ 29.961330] ata4: SATA max UDMA/133 cmd 0x0001f600 ctl 0x0001f502 bmdma 0x0001f408 irq 19
[ 30.267929] usb 7-5: new high speed USB device using ehci_hcd and address 2
[ 30.289922] ata3.00: ATA-7: ST3250310AS, 3.AAC, max UDMA/133
[ 30.289926] ata3.00: 488397168 sectors, multi 1: LBA48 NCQ (depth 0/32)
[ 30.289931] ata3.01: ATAPI: Optiarc DVD RW AD-7170S, 1.00, max UDMA/66
[ 30.304359] ata3.00: configured for UDMA/133
[ 30.402893] usb 7-5: configuration #1 chosen from 1 choice
[ 30.478250] ata3.01: configured for UDMA/66
[ 30.640831] usb 8-1: new high speed USB device using ehci_hcd and address 2
[ 30.645172] scsi 2:0:0:0: Direct-Access ATA ST3250310AS 3.AA PQ: 0 ANSI: 5
[ 30.646123] scsi 2:0:1:0: CD-ROM Optiarc DVD RW AD-7170S 1.00 PQ: 0 ANSI: 5
[ 30.646185] ata_piix 0000:00:1f.5: MAP [ P0 P2 P1 P3 ]
[ 30.646236] PCI: Setting latency timer of device 0000:00:1f.5 to 64
[ 30.646273] scsi4 : ata_piix
[ 30.646323] scsi5 : ata_piix
[ 30.646347] ata5: SATA max UDMA/133 cmd 0x0001f100 ctl 0x0001f002 bmdma 0x0001ed00 irq 19
[ 30.646350] ata6: SATA max UDMA/133 cmd 0x0001ef00 ctl 0x0001ee02 bmdma 0x0001ed08 irq 19
....
[ 31.060345] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[ 31.060348] Uniform CD-ROM driver Revision: 3.20
[ 31.060462] sr 2:0:1:0: Attached scsi CD-ROM sr0

stormelf (elfwind) wrote :

I am having the same problem with both the alternate Intrepid "beta" and alternate Intrepid "daily 2008-10-15". Installing with full disk LUKS encryption. CD-rom install using a very common CD/DVD IDE player NEC ND-3550A. This was never a problem with Hardy or earlier.

"
[!!] Install the base system
Please insert the disc labeled: 'Ubuntu8.10 _Intrepid Ibex_ - Alpha i386 (20081015)' in the drive '/cdrom/' and press enter.
Media change
"

Neither <Go Back> not <Continue> works.

Alex Dancu (alex-dancu) wrote :

I'm having the same problem. I've tried both Intrepid Alternate Beta and the daily build(20081017). The funny thing is that I can reproduce this bug all the time in VMWare, using the cdrom device directly. If I use iso image instead in vmware, it works just fine. But I couldn't reproduce this in VirtualBox OSE.

I'm using an IDE DVDRW drive: NEC ND-3540A

I'm using the alternate way of installing debian/ubuntu for 3 years, every 6 months, but this is the first time it happens this. I didn't change my hardware since the last time I've installed Hardy. Actually I even reinstalled Hardy using alternate a few days ago and it works just fine.

Here are the last lines of dmesg after the error appears:

[ 209.841771] sr 1:0:0:0: [sr0] Device not ready: Sense Key : Not Ready [current]
[ 209.841972] sr 1:0:0:0: [sr0] Device not ready: Add Sense : No additional sense information
[ 209.842092] end_request: I/O error, dev sr0, sector 388
[ 209.859434] ISOFS: unable to read i-node block
[ 211.196259] sr 1:0:0:0: [sr0] Device not ready: Sense Key : Not Ready [current]
[ 211.196360] sr 1:0:0:0: [sr0] Device not ready: Add Sense : No additional sense information
[ 211.196430] end_request: I/O error, dev sr0, sector 352
[ 211.196655] ISOFS: unable to read i-node block

According to mount, the cdrom is mounted
/dev/scd0 on /target/media/cdrom0 type iso9660

I have checked both alternates (beta and daily) for defects.

Alex Dancu (alex-dancu) wrote :

I've just test it with an old IDE Asus Cdrom and it seems to work, at least on vmware. So the problem might be my NEC DVDRW drive.

Andrej Mernik (r33d3m33r) wrote :

I tried installing Kubuntu 8.10 final with the alternate CD. Checked CD for defects and no error. The installer stops with Media Change error as above. I tried to figure out what was wrong, and noticed the installed sources.list file, contains only the path to the installer, but no web mirrors. Because the installer stops almost right after updating the APT sources, this might be it.

Henrik Holmboe (holmboe) wrote :

Hello all,

bug #274396 is a duplicate of this one. In that bug it states that you should "Save debug logs", but that isn't possible since it doesn't matter if you flick on <Go Back> or <Continue>, the same dialog box pops up again prompting to change the media.

I'm testing this on the released version 8.10. So it asks for 'Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081028)' in my case.

Is there something I can do to help further?

In virtual console 4 it says (written in by hand, excuse any spelling errors):

[...]
[current date] in-target: The following NEW packages will be installed:
[current date] in-target: mdadm
[current date] in-target: Use of uninitialized value $x in scalar assignment at /usr/share/perl/5.10/utf8_heavy.pl line 242, <GEN0> line 1.
[current date] in-target: Use of uninitialized value $x in pattern match (m//) at /usr/share/perl/5.10/utf8_heavy.pl line 243, <GEN0> line 1.
[current date] in-target: Use of uninitialized value in split at /usr/share/perl5/Debconf/FrontEnd/Passthrough.pm line 68, <GEN0> line 1.
[current date] in-target: Use of uninitialized value in split at /usr/share/perl5/Debconf/FrontEnd/Passthrough.pm line 68, <GEN0> line 1.

erisa (unixchick) wrote :

There might be a commonality.. I ran into this bug 4 times in a row, but once I switched my CD-ROM drive for an old no-name spare I had lying around, the install went smoothly. The original drive when I ran into the bug was an NEC ND-3550A -- same as Stormelf's, similar to Keyser's, and the same brand as Alastair's. It's also worth noting that the CD-ROM is the only IDE device in my computer; the internal hard drives are both SATA. And I used the Alternate CD so that I could enable disk encryption.

Bobby D. Bryant (bdbryant) wrote :

I have the same problem with the AMD64 "alternate" disc.

I did *not* have the problem when I installed the AMD64 "alternate" for the beta.

Bobby D. Bryant (bdbryant) wrote :

A bit more about that previous post. I got the error with the release disc, but not with the beta disc. The beta installation ran to completion. However, it would not boot.

While troubleshooting I noticed that my CD-ROM was on the primary controller and the one IDE drive was on the secondary, and I had read somewhere that such configurations will not boot, so I swapped them. It still wouldn't boot, so I tried installing the beta again. This time I *did* get the "insert disc" message.

Somehow the difference between being on the primary and secondary IDE controller made a difference, at least for the beta installation.

Antal (spammijnu) wrote :

Same here! I am using the AMD64 alt CD. At the same point I get:

>>please insert the disc labeled 'Ubuntu 8.10 _Intrepid Ibex_ - Relese amd64 (20081028)' in the drive '/cdrom/' and press enter.
>>
>>Media change

I've tried it 4 times now with my IDE NEC 3520 DVDRW, and it keeps showing. After reading this bug report I tried using my other CDROM, and now it works great!

denicfr (denicfr) wrote :

I got the same problem with both beta and final Intrepid.

I had an IDE Nec ND-3500A. I tried several times master or slave => doesn't work. mdadm package doesn't want to be installed. I tried to make a cp /cdrom/pool/.../mdadm* /tmp => device error !
I tried CD check => works fine

Then I used a Pioneer device =>it works great!
My Nec is about to go to the dust bin ;)

Seems to be a bug, isn't it ?

Henrik Holmboe (holmboe) wrote :

I finally got Intrepid installed. The solution was to search the attic for an old CD-ROM drive from 1999 and use it during installation.

The failing drive is:

 - Sony NEC Optiarc Inc
   DVD/CD Rewritable Drive
   Model no. AD-7173A

The working solution:

 - Really old LG CD-ROM drive
 - Alternative install CD (to enable SW RAID1 and LVM)

Just for the record, I did not try any other working combinations of HW and install CDs.

Martijn Brinkers (m-brinkers) wrote :

Same problem here. The same system installed 7.10 and 8.04 without any problem.

dblade (listmail) wrote :

Sony Optiarc DVD RW AD-7170S (sata) drive, ASUS P5B-Deluxe WIFI/AP, ubuntu-8.10-server-amd64.iso burned three times of those 3 times, the image was downloaded twice.

Install the base system dialog eventually indicates "Updating available list of packages" (I believe) and I am presented wit the same media change dialog and the only option is to reset. I had no issues installing 8.10 desktop amd64 on this same setup and right now what i'm actually doing is trying to install to a thumb drive while all my local hard drives are unplugged (protection). I'm wondering now if having the raid rom on the controller enabled with no other drives is triggering it, but who knows if a perl script is dumping errors.

Adam Hill (sidepipeuk) wrote :

I've just come across this one myself... again an NEC CDROM though this time in a Laptop ( a Philips Freevents model. ) Since changing the CDROM is not an option for me, and I don't have a USB CDROM drive handy, I came up with this workaround:

When the message appears the first time:
Ctrl-Alt-F2 to get another console.
chroot /target
vi /etc/apt/sources.list
( comment out the CDROM line by inserting a # at the start, save and quit. )
apt-cdrom add
Ctrl-Alt-F1 to get back to the installed and press Enter.

( This is with the alternate install CDROM. )

The message appeared at least once more during the install, but repeating the above got past it. Also, at one point I got a message that selecting and installing failed - again I repeated the above, and selected to repeat the step from the menu.

After all of that, I had a working system! Although this seems to be related to NEC CDROM drives, it appears to be a bug since the drive itself works. Ideally someone needs to find out what the root cause is....

i have this problema with alternate cd of intrepid and jaunty alfa4 but not with hardy

http://img207.imageshack.us/img207/9402/alternateintrepidjk4.jpg
http://img24.imageshack.us/img24/7104/alternatepr0.jpg

hmc8 (hmc8) wrote :

The same problem for me (alternate/alpha6/Jaunty). I am using a NEC 3500AG DVD-RW.

Mitja (i-launchpad-mitja-cc) wrote :

I got the same problem. Hardy installed perfectly, I havn't tested Intrepid, but Jaunty Alpha 5 and Beta 1 fail with the same error as described in this thread. Will try my old CDROM drive now and if that fails, the solution of Adam Hill.

JimHigson (jim-wikizzle) wrote :

Same problem here with Jaunty. I tried installing from a USB stick but the alternate installer doesn't like not being on a CD. Apparently it can be done with cunning use of symlinks but I couldn't get it going.

dblade (listmail) wrote :

is this bug related or perhaps the core issue? https://bugs.launchpad.net/ubuntu/+source/apt-setup/+bug/316618

Mitja (i-launchpad-mitja-cc) wrote :

Tested it with Kubuntu Jaunty Final now.. same thing like before. Tried the workaround of Adam Hill now which didn't work for me. Using my old CD drive now which worked with alpha 5 and beta 1, too.

MountainX (dave-mountain) wrote :

Here's a work-around:
http://ubuntuforums.org/showpost.php?p=10420985&postcount=13

I also think this could be the basis for a real fix by the Ubuntu team.

MountainX (dave-mountain) wrote :

Here's another work-around:
http://ubuntuforums.org/showpost.php?p=10420985&postcount=13

I also think this could be the basis for a real fix by the Ubuntu team.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments