Installing Ubuntu Server fails in UEFI mode

Bug #1552365 reported by sudodus on 2016-03-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Unassigned

Bug Description

Two failures are reported in this bug report:

1. The text mode fails - the screen does not show the text dialogue in two laptop computers (my computers).

2. The installer fails to install files in a desktop computer (oldfred's computer).

Nota bene: The desktop iso files and their installers work well in these computers, but Lubuntu alternate with the debian installer fails too in UEFI mode.
-----
Has anyone installed Ubuntu Server in UEFI mode? Is it intended to work?

See this link to a thread in the Ubuntu Forums,

http://ubuntuforums.org/showthread.php?t=2315007

One of the computers is the Toshiba that I often use for testing, a Toshiba laptop with Intel i5 and Intel 3rd gen core proc graphics controller. It runs the kernel module i915 in Xenial desktop systems. The wifi is RTL8723AE using the kernel module rtl8723ae. (I'm writing this report from Lubuntu Xenial in this computer.)

The graphics and wifi work for me without tweaks with all current Ubuntu versions and flavours is UEFI as well as in BIOS mode.

The other one is a Lenovo X131e with Intel i3 and Intel 2nd gen core proc graphics controller. It runs the kernel module i915 in Xenial desktop systems. The wifi is Broadcom BCM43228 using the kernel module b43.

The graphics works for me without tweaks with all current Ubuntu desktop versions and flavours in UEFI as well as in BIOS mode. The wifi does not create any problems when connected via wired network.

Ubuntu Server amd64 (and its debian installer) works in BIOS mode. But there are problems in UEFI mode. I have tried several 14.04 point versions, 15.10 and Xenial (of course amd64 versions). The computer boots to grub, and the grub menu looks good, but after that the screen cannot display anything but some messy lines. It seems that the graphics driver does not get the correct information to work (which is different from BIOS mode in the same computers). So I cannot see the user dialogue, and cannot run the [debian] installer.

This is for testing purposes and for the future. I can boot these two computers in both BIOS and UEFI mode, but we can expect that computers in the future will not boot in BIOS mode, so we should be prepared not only with the desktop versions and flavours, but also the server and mini versions of Ubuntu.
---
Fred Palmer, 'oldfred' at the Ubuntu Forums, has tried Ubuntu Server too. He has working graphics in a new desktop computer in UEFI mode. But the debian installer failed to install any files:

'I just tried installing server version in UEFI mode, I had just set up 16.04 desktop on sda, and tried server install to sdb.

It booted and took me all the way to installing software and failed. I could see folders, but no files in folders in new install.'
---
I would say that the debian installer for Ubuntu Server is either buggy, or it has never been intended to use the Ubuntu Server in UEFI mode.

I think that nobody has really tested Ubuntu Server in UEFI mode, or at least it is not tested enough, and I think that it is time to make it work in UEFI mode now.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: debian-installer (not installed)
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic i686
ApportVersion: 2.20-0ubuntu3
Architecture: i386
CasperVersion: 1.367
CurrentDesktop: LXDE
Date: Wed Mar 2 17:48:35 2016
DeviceMapperTables: No devices found
DmraidDevices: no raid disks
DmraidSets: no raid disks
LiveMediaBuild: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha i386 (20160301)
MachineType: TOSHIBA SATELLITE PRO C850-19W
MemoryUsage:
 total used free shared buff/cache available
 Mem: 4014540 371672 2519080 96852 1123788 3503536
 Swap: 2007264 0 2007264
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=(loop)/casper/vmlinuz boot=casper iso-scan/filename=/cdimage.ubuntu.com/username/daily-live/current/xenial-desktop-i386.iso splash --
SourcePackage: debian-installer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/24/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 6.10
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: PLCSF8
dmi.board.vendor: Intel
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr6.10:bd09/24/2012:svnTOSHIBA:pnSATELLITEPROC850-19W:pvrPSCBXE-00C00VN5:rvnIntel:rnPLCSF8:rvrType2-BoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: SATELLITE PRO C850-19W
dmi.product.version: PSCBXE-00C00VN5
dmi.sys.vendor: TOSHIBA

sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) on 2016-03-02
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1552365

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Changed in debian-installer (Ubuntu):
importance: Undecided → High
sudodus (nio-wiklund) on 2016-03-05
description: updated
sudodus (nio-wiklund) wrote :

I have found no solution to this problem yet, but a *workaround*

A new computer, Intel NUC6i3SYH, manages to display the text of the installer in UEFI mode, so I could install Ubuntu Server 16.04 LTS in UEFI mode. In other words, the signed kernel was installed, and it works with secure boot. The installed system is portable and the text mode works in UEFI mode in my two computers, that do not like the text mode installer.

I used my method to create a portable system, that boots in both UEFI and BIOS mode. It is a minimal system with text mode menus to help creating an Ubuntu flavour including Ubuntu Server. There is also a menu entry to create an ultra-light system with the Fluxbox window manager.

It is convenient to set the font (size) of the text console, to make it fit the screen resolution. See the following link,

http://ubuntuforums.org/showthread.php?t=2213631&page=4&p=13481136#post13481136

"A new compressed image file is uploaded: 'dd_text_16.04-UEFI-n-BIOS-4-pendrive-7.8GB.img.xz'"

I think this system can be quite useful, when you want to make a portable installed system.

-o-

Oldfred taught me to use *tasksel* to make it convenient to install all the metapackages that are available from the Ubuntu Server iso file. So I made a new version of the compressed image files of an installed system that works in both UEFI and BIOS mode.

http://ubuntuforums.org/showthread.php?t=2213631&page=8&p=13495646#post13495646

"Two updated compressed image files are uploaded"

Alongside with improvements of https://help.ubuntu.com/community/mkusb (version 10.6.6) it is rather convenient to use this method to install Ubuntu Server into laptops or other computers, where the debian installer does not work in UEFI mode. See also the following link,

https://help.ubuntu.com/community/Installation/UEFI-and-BIOS]Installation/UEFI-and-BIOS

sudodus (nio-wiklund) wrote :

Lubuntu alternate amd64 16.04.1 LTS (release candidate) fails to boot in my laptops, but works in my NUC, so this bug is still alive.

sudodus (nio-wiklund) wrote :

I tested the Lubuntu alternate amd64 beta 2 (dated 20160927.5) in BIOS mode and UEFI mode:

-----
BIOS mode:

works, tested in
http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/)
-----
UEFI mode:

works in:
https://www-ssl.intel.com/content/www/us/en/nuc/nuc-kit-nuc6i3syh.html
---
grub menu ok, but debian installer's graphics fail:
http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/
bug report:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1552365)
---
nothing works, black screen with cursor in:
https://shop.lenovo.com/ISS_Static/ww/wci/products/us/laptop/thinkpad/x-series/x131e-intel/X131e-Datasheet-Intel.pdf
new bug?
-----

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers