installer ignores preseeding settings added after --

Bug #1427252 reported by Mathieu Trudel-Lapierre on 2015-03-02
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Mathieu Trudel-Lapierre
Trusty
High
Adam Conrad
Utopic
High
Adam Conrad
installation-guide (Ubuntu)
High
Mathieu Trudel-Lapierre
Trusty
High
Unassigned
Utopic
High
Unassigned

Bug Description

When installing from the server iso or mini.iso (any debian-installer, really), any preseeding parameters passed after the "--" (two dashes) separator on the command line are silently ignored. This slightly complicates matters for our users because they need to remember to add the settings before the separator, which also has a different behavior.

Parameters added after the separator are meant to be passed on to the installed system; so they are especially relevant to server installs where one might need to specify a console= to be used for the installation as well as on boot of the installed system.

The kernel now strips anything after "--"; which appears to be what causes the problem. Switching to using "---" (three dashes), as already done in Debian would fix the issue.

Related branches

I'll be applying the changes from http://anonscm.debian.org/cgit/d-i/debian-installer.git/commit/?id=10af2f56; but fixed to properly apply to our older version of debian-installer.

Changed in debian-installer (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
status: New → In Progress

This will also need an installation-guide update to note the changes, also cherry-picking a commit from upstream (svn revision 69498)

Changed in installation-guide (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package installation-guide - 20100518ubuntu12

---------------
installation-guide (20100518ubuntu12) vivid; urgency=medium

  * Cherry-picked changes:
    - Update documentation for changes to the multi partitioning scheme: /usr
      is no longer made onto its own separate partition, but rather included
      with /.
    - Replace -- with --- in details about how to pass parameters to the kernel
      that need to be passed on to the installed system. (LP: #1427252)
 -- Mathieu Trudel-Lapierre <email address hidden> Sat, 28 Feb 2015 10:27:06 -0500

Changed in installation-guide (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu367

---------------
debian-installer (20101020ubuntu367) vivid; urgency=medium

  * Cherry-pick from upstream 10af2f56; with fixup: (LP: #1427252)
    - Use --- as options separator for all Linux command lines.
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 02 Mar 2015 10:50:09 -0500

Changed in debian-installer (Ubuntu):
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1427252

tags: added: iso-testing

This bug would also affect utopic.

Changed in debian-installer (Ubuntu Utopic):
status: New → Triaged
Changed in installation-guide (Ubuntu Utopic):
status: New → Triaged
Changed in debian-installer (Ubuntu Utopic):
importance: Undecided → High
Changed in installation-guide (Ubuntu Utopic):
importance: Undecided → High

Also needs a change in debian-cd, so that it applies to the usual images, and not just mini.iso.

Adam Conrad (adconrad) wrote :

For trusty, it's incredibly invasive to switch from -- to --- for only some d-i variants, so this change will end up affecting all variants, from vanilla to lts-utopic to lts-vivid. This shouldn't cause any real issues, I'd guess, since people who pass custom args via automation already completely override the d-i command line to replace it with their own anyway.

Adam Conrad (adconrad) on 2015-06-02
Changed in debian-installer (Ubuntu Trusty):
assignee: nobody → Adam Conrad (adconrad)

Hello Mathieu, or anyone else affected,

Accepted debian-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu318.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Verified that the d-i portion of this works as advertised in trusty-proposed.

tags: added: verification-done-trusty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu318.18

---------------
debian-installer (20101020ubuntu318.18) trusty; urgency=medium

  * Switch to '---' as option separator for all kernels (LP: #1427252)
  * Add lts-vivid variants for all targets except for e500, for which
    support was dropped in the utopic/lts-utopic kernel (LP: #1459779)
  * Conditionally use apm-mustang.dtb from new location (LP: #1408004)

 -- Adam Conrad <email address hidden> Tue, 02 Jun 2015 11:07:49 -0600

Changed in debian-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for debian-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Mathieu, or anyone else affected,

Accepted debian-installer into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu352.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Utopic):
status: Triaged → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) on 2015-07-17
Changed in debian-installer (Ubuntu Utopic):
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu352.3

---------------
debian-installer (20101020ubuntu352.3) utopic; urgency=medium

  * Force rebuild to pick up new debian-installer-utils (LP: #1402042)
  * Switch to '---' as option separator for all kernels (LP: #1427252)

 -- Adam Conrad <email address hidden> Fri, 17 Jul 2015 09:10:34 -0600

Changed in debian-installer (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in debian-installer (Ubuntu Trusty):
importance: Undecided → High
Changed in installation-guide (Ubuntu Trusty):
importance: Undecided → High
Changed in installation-guide (Ubuntu Utopic):
status: Triaged → Won't Fix
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers