Enable HP ProLiant m800 server

Bug #1326437 reported by Manoj Iyer on 2014-06-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
flash-kernel (Ubuntu)
Undecided
Manoj Iyer
Trusty
Undecided
Unassigned

Bug Description

[Impact]
New hardware support
[Test Case]
Install/boot an HP Moonshot m800 Cartridge
[Regression Potential]
Minimal - doesn't modify code that runs on other platforms.

Related branches

Manoj Iyer (manjo) on 2014-06-04
Changed in flash-kernel (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
dann frazier (dannf) wrote :

@Manoj: Please let me know if the above MP fixes the issue for you.

dann frazier (dannf) on 2014-06-09
description: updated
dann frazier (dannf) on 2014-06-20
summary: - [Utopic] Enable HP ProLiant m800 server
+ Enable HP ProLiant m800 server

Hello Manoj, or anyone else affected,

Accepted flash-kernel into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/flash-kernel/3.0~rc.4ubuntu49.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in flash-kernel (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Manoj, or anyone else affected,

Accepted debian-installer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu318.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Trusty):
status: New → Fix Committed
Sean Feole (sfeole) wrote :

I successfully installed the following trusty-proposed kernel on the HP ProLiant m800 server today.

http://ports.ubuntu.com/ubuntu-ports/dists/trusty-proposed/main/installer-armhf/20101020ubuntu318.4/images/keystone/netboot/

The node is booted at the moment and does not appear to have any outstanding issues.

tags: added: verification-done
removed: verification-needed
Sean Feole (sfeole) wrote :

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 3.13.0-8-keystone #12-Ubuntu SMP Sat Jul 19 07:56:07 UTC 2014 armv7l armv7l armv7l GNU/Linux

Sean Feole (sfeole) wrote :

I also had some problems with flash-kernel, I don't believe it installed and was later confirmed by another fresh set of eyes. I had to issue bootz ${kernel_addr_r} ${ramdisk_addr_r}:${filesize} ${fdt_addr_r}

dann frazier (dannf) wrote :

I've determined that the problem was just that we didn't install with proposed enabled. I did a new install with proposed enabled and verified that both d-i and flash-kernel from proposed work as expected.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu318.4

---------------
debian-installer (20101020ubuntu318.4) trusty; urgency=medium

  [ Manoj Iyer ]
  * Build netboot image for armhf/TI keystone (LP: #1326437)

  [ Adam Conrad ]
  * Include sata-modules on ppc64el (LP: #1323980)
 -- Adam Conrad <email address hidden> Tue, 29 Jul 2014 00:14:10 -0600

Changed in debian-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for debian-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.0~rc.4ubuntu49.1

---------------
flash-kernel (3.0~rc.4ubuntu49.1) trusty; urgency=medium

  * Add U-Boot environment configuration support (LP: #1328597)
  * Explicitly lower the console speed for HP ProLiant m400 cartridges to 9600
    and enable hardware flow control as required by the HP moonshot chassis
    (LP: #1328280)
  * Enable U-Boot environment support for X-Gene platforms
  * Use filesystem agnostic "load" command instead of assuming ext4
  * Add support for HP ProLiant m800 cartridges (LP: #1326437)
 -- dann frazier <email address hidden> Fri, 20 Jun 2014 17:09:02 -0600

Changed in flash-kernel (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flash-kernel - 3.0~rc.4ubuntu53

---------------
flash-kernel (3.0~rc.4ubuntu53) utopic; urgency=medium

  * Merge in remaining trusty SRU changes:
    * Add U-Boot environment configuration support (LP: #1328597)
    * HP Moonshot Cartridges: Use $baudrate from u-boot environment as
      serial console speed (LP: #1373628)
    * HP Moonshot Cartridges: Enable hardware flow control as required by
      the HP moonshot chassis (LP: #1328280)
    * Enable U-Boot environment support for X-Gene platforms
    * Use filesystem agnostic "load" command instead of assuming ext4
    * Add support for HP ProLiant m800 cartridges (LP: #1326437)
    * Set required boot arguments for HP ProLiant m800 cartridges
      (LP: #1373659)
 -- dann frazier <email address hidden> Mon, 29 Sep 2014 16:20:15 -0600

Changed in flash-kernel (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers