omap netboot partition too small for flash-kernel backup procedure

Bug #1040393 reported by Adam Conrad on 2012-08-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Adam Conrad
Precise
Undecided
Adam Conrad

Bug Description

[ SRU Justification ]
omap netboot installs are broken, and it's only a matter of time and/or bad luck before a d-i spin on omap4 has a slightly larger kernel and, thus, the same problem

[ Test Case ]
Install using the d-i netboot image, watch it fail with the old images with the below errors, install with the new image, watch it succeed, an verify that the VFAT boot partition on the SD card is 72ish MB instead of 30ish.

[ Regression Potential ]
Very low, as I'm using the (exact) same partition size as the CD-ish media uses, which should satisfy boundary concerns, etc. If it boots and passes the test case, it's fine.

[ Original Descrpition ]
Undecided if this should be fixed in flash-kernel-installer to be less broken when failing to create backups, or debian-installer to make the SD partition a bit (or a lot) larger. Probably d-i's fault, as our CD/preinstall images use a 72MB SD boot partition, and d-i appears to use something closer to 32MB.

At any rate, current precise on omap3 fails like so, and it's only a matter of time before the omap4 initrd gets large enough to cause the same issue, I suspect:

Aug 23 03:00:05 in-target: Using u-boot partition: /dev/mmcblk0p1
Aug 23 03:00:05 in-target: /usr/lib/u-boot/omap3_beagle/MLO is already installed in the boot partiti
on.
Aug 23 03:00:05 in-target: /usr/lib/u-boot/omap3_beagle/u-boot.bin is already installed in the boot
partition.
Aug 23 03:00:05 in-target: Creating backups of boot files ...
Aug 23 03:00:06 in-target: cp:
Aug 23 03:00:06 in-target: writing `/tmp/tmp.gOpwSqxTIj/uInitrd.bak'
Aug 23 03:00:06 in-target: : No space left on device
Aug 23 03:00:06 in-target:
Aug 23 03:00:06 in-target: cp:
Aug 23 03:00:06 in-target: failed to extend `/tmp/tmp.gOpwSqxTIj/uInitrd.bak'
Aug 23 03:00:06 in-target: : No space left on device
Aug 23 03:00:06 in-target:
Aug 23 03:00:10 flash-kernel-installer: error: bootloader installation failure

-rwxr-xr-x 1 root root 43648 Aug 3 18:37 MLO
-rwxr-xr-x 1 root root 265 Aug 3 18:37 boot.scr
-rwxr-xr-x 1 root root 340628 Aug 3 18:37 u-boot.bin
-rwxr-xr-x 1 root root 3833296 Aug 3 18:37 uImage
-rwxr-xr-x 1 root root 3833296 Aug 23 03:00 uImage.bak
-rwxr-xr-x 1 root root 11746823 Aug 3 18:37 uInitrd
-rwxr-xr-x 1 root root 11571200 Aug 23 03:00 uInitrd.bak

/dev/mmcblk0p1 29.9M 29.9M 2.0K 100% /mnt

Adam Conrad (adconrad) on 2012-08-23
Changed in debian-installer (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Changed in debian-installer (Ubuntu Precise):
assignee: nobody → Adam Conrad (adconrad)
Changed in debian-installer (Ubuntu Precise):
milestone: none → ubuntu-12.04.2
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1040393

tags: added: iso-testing
Oliver Grawert (ogra) wrote :

hmm ... looks like bug 806751 ....

Adam Conrad (adconrad) on 2012-12-02
description: updated
Adam Conrad (adconrad) on 2012-12-02
Changed in debian-installer (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu195

---------------
debian-installer (20101020ubuntu195) raring; urgency=low

  * Make omap/omap4 netboot VFAT partitions the same size
    as the ones used for CD-like media (LP: #1040393)
  * Move powerpc kernels to 3.7.0-2.
  * Move armadaxp kernels to 3.5.0-1604.
  * Move omap4 kernels to 3.5.0-215.
 -- Adam Conrad <email address hidden> Sat, 01 Dec 2012 19:22:27 -0700

Changed in debian-installer (Ubuntu):
status: In Progress → Fix Released

Hello Adam, or anyone else affected,

Accepted debian-installer into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu136.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) on 2013-01-29
tags: added: verification-done
removed: verification-needed
Adam Conrad (adconrad) wrote :

Did a spin through on both Xiang and Snoopy, and the results looked sane.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu136.7

---------------
debian-installer (20101020ubuntu136.7) precise; urgency=low

  * Make omap/omap4 netboot VFAT partitions the same size
    as the ones used for CD-like media (LP: #1040393)
  * Move omap4 kernels to 3.2.0-1424.
  * Move armadaxp kernels to 3.2.0-1613.

debian-installer (20101020ubuntu136.6) precise; urgency=low

  * Move to 3.2.0-36 kernels.
  * Move armel/omap4 and armhf/omap4 to 3.2.0-1423 kernels.
  * Move armhf/armadaxp to 3.2.0-1612 kernels.
  * Move quantal-* images to 3.5.0-22 kernels.
 -- Adam Conrad <email address hidden> Sun, 13 Jan 2013 01:37:40 -0700

Changed in debian-installer (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers