After every single page on ipp: Unable to get print job status

Bug #877958 reported by HPO
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cups (Debian)
Fix Released
Unknown
cups (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Connected to Printers on IPP, after every single page the printer is disabled and status is:
Printer State: Stopped - Unable to get printer job status

Manually re-enabling the printer prints the following page - and stops again!

Verified on HP Laserjet P3005. I tried adding ipp parameters like version=1.0 to no avail.

Revision history for this message
HPO (hpo) wrote :

Just found a possible upstream link:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638521

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

First, as a workaround you can comnnect to a network printer also with alternative protocols. Instead of IPP you can use AppSocket/JetDirect or LPD. To change your print queue appropriately, open system-config-printer (System menu by clicking the gear in the upper right, then "Printers"), right-click your printer, choose "Properties" in the pop-up menu, then "Change" button at "Device URI". In the window openbing then, wait around 15 seconds until the spinning icon in the lower left disappears, open the "Network Printer" section, select your printer and at the lower right under "Connection" choose something which is not IPP.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Can everyone with this problem please run the following command in a terminal window:

lpstat -v

and also attach the PPD file of the print queue (/etc/cups/ppd/*.ppd)?

Can you also follow the instructions in the sections "CUPS error_log" and "Capturing print job data" of https://wiki.ubuntu.com/DebuggingPrintingProblems. Thanks.

Changed in cups (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
HPO (hpo) wrote :

Was the latest cups update not meant to address this issue (too)?

Since today's update, the issue is resolved for me.

Revision history for this message
David Charypar (charypar) wrote :

I have the same problem, confirmed both on my updated linux box running oneiric Kubuntu 11.10 and on the same computer booted from the Kubuntu oneiric Desktop CD, 64bit

Steps to reproduce the problem:
* Install a network printer over ipp (HP LaserJet 4350 Postscript (recommended) )
(by the way, in the list of drivers, the same driver "HP LaserJet 4350 Postscript (recommended)" appears 6 times. I selected the first in the list. I am not sure if it matters)
* Print a test document (a simple PDF) or the printer test page

Result:
The Document is printed, but afterward the printer status says 'Paused - "Unable to get print job status."'. Subsequent print attempts are queued but not printed.

By deleting the queued documents and resuming the printer, it is possible to print one next document, afterwards the status is again 'Paused - "Unable to get print job status."

Changed in cups (Debian):
status: Unknown → New
Revision history for this message
David Charypar (charypar) wrote :

I have to correct my post from yesterday evening. It is not possible to reset the printer by simply deleting print jobs and resuming. To print another document it is necessary to delete the printer and add it from scratch.

Till, please find the requested data below as well as in the attached files. (cups_error_log, printout-13, printout-14)
Please note, I printed two documents consecutively (twice the printer test page) to reproduce the error. (Not only one as requested in the "Capturing print job data". The print jobs had ID 13 and 14, respectively.

Result from "lpstat-v":
device for test1: ipp://druckerraum-laser1.ethz.ch/ipp/

Please let me know if you need additional information.

Revision history for this message
David Charypar (charypar) wrote :
Revision history for this message
David Charypar (charypar) wrote :
Revision history for this message
HPO (hpo) wrote :

Correction: The issue is not resolved with me... It does, however, not always happen (not anymore). I'm still trying to figure out what triggers it :(

Possible workaround w/o changing too much of the infrastructure seems to add 'waitjob=false' as IPP parameter.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Can you please report an upstream bug on CUPS here

http://www.cups.org/str.php

and post the link to it in this bug report? Thanks.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Bug reported upstream as

http://www.cups.org/str.php?L3966

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Robert, have you any idea how to fix this one?

Revision history for this message
Robert Bradley (robert-bradley1) wrote :

I have no good ideas off-hand, but I might be able to get some hints from tcpdump/Wireshark packet logs, as I did with bug 881843.

HPO/David: would either of you be willing/able to get packetlogs of the IPP session (using "sudo tcpdump -i eth0 -p -w packetlog port 631")? I would need one from the current CUPS version in Oneiric (which isn't working), and ideally, one from Ubuntu 11.04 or earlier.

I also have a patch for the Oneiric CUPS at https://bugs.launchpad.net/ubuntu/+source/cups/+bug/881843/comments/6 applied, which effectively downgrades the IPP backend to CUPS 1.4.6. However, it will be far easier to just take the measurements from a pre-Oneiric system, if you have a system still running the older version.

Revision history for this message
David Charypar (charypar) wrote :

Dear Robert, Till

I tried the cups server both on natty and on oneiric, respectively. I collected the packet logs from the two IPP sessions as requested using tcpdump. The tests were run on the same computer booted from the natty and the oneiric dektop CD (amd64), respectively. In both cases, I added the network printer via IPP (HP LJ 4350) and printed the printer test page twice. On natty everything worked as expected, on oneirc the first test page was printed but afterwards nothing could be printed anymore. (This is the described bug).

Please find attached the two tcp dumps.

Best regards
David

Revision history for this message
David Charypar (charypar) wrote :
Changed in cups (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Robert Bradley (robert-bradley1) wrote :

Dear David,

I did not see anything obviously different between the two TCP dumps, unfortunately. I can't see what could cause the printer to stop printing!

Regards,

Robert

Revision history for this message
David Charypar (charypar) wrote :

Dear Robert

That is weird. I would have expected at least some relevant differences between the two communication dumps. Could it be that the problem lies within the server? E.g. the communication is correct but the server reaches an invalid state producing the situation where it is "Unable to get print job status."

Btw: Are you able to reproduce the error, or do you have to guess from what we report?

Thank you for your efforts.

David

Revision history for this message
Paul Gittings (taffydownunder) wrote :
Revision history for this message
Robert Bradley (robert-bradley1) wrote :

Hi David,

Sorry about my recent silence. At the moment, I have not been able to reproduce the error here (fortunately for me, unfortunately for everyone else). There do seem to be a lot of similar sounding bugs around though (TaffyDownUnder's bug, and the latest bug over at #881843), all resulting in paused printouts of various kinds. One thing I am sure of is that CUPS 1.5 seems extremely buggy at the moment.

In the meantime, the only suggestion I have is to see if the latest svn builds upstream work:

svn co http://svn.easysw.com/public/cups/branches/branch-1.5/
(then build)

That is just speculation on my part, though.

Revision history for this message
Robert Bradley (robert-bradley1) wrote :

David,

Having checked those packet logs again, I did notice one difference. The requested URI for Oneiric appears to be "ipp://druckerraum-laser1.ethz.ch:631/" and not "ipp://druckerraum-laser1.ethz.ch:631/ipp/". Could you quickly check that it is set the same as in Natty please?

Thanks in advance,

Robert

Revision history for this message
Paul Gittings (taffydownunder) wrote :

Hi Robert,
I built cups from svn as you suggested, but when I do a print test page, I still got the "Unable to get printer status" message.

Here's what I did :
svn co http://svn.easysw.com/public/cups/branches/branch-1.5/
cd branch-1.5
autoconf
./configure
# at this point when I tried to compile I got errors - warning treated as error. So I removed the -Werror compiler flag
make
make check
# checked results of tests, all passed
sudo make install
# at this point I opened up the Printing from the System Settings app and selected my Epson printer and sent a test page.

Cheers,
Paul

Revision history for this message
Paul Gittings (taffydownunder) wrote :

Hi,
I've found a work around that so far seems to work for me. Rather than connect via ipp, I switched to smb . I can at least print a test page now. I found details here:
http://planetlotus.org/profiles/ben-poole_94582

Cheers,
Paul

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

IPP backend reverted to the version of CUPS 1.4.x to fix bug 881843, bug 877958, bug 879625, and bug 883585 for the time being until the backend gets fixed upstream. Applied this to the Debian BZR repository of CUPS so that the fix will appear in the next CUPS package for Precise and also applied to a Stable Release Update (SRU) CUPS package for Oneiric which I have uploaded to -proposed. As soon as this package gets approved and ready for testing on Oneiric, a separate comment with testing instructions will get posted here. Please test the package then and report back here, so that we can make it an official update.

A debdiff of the SRU for Oneiric is attached.

Robert Bradley, thank you for all the work on these bugs and the downgrade patch for the IPP backend.

Changed in cups (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
Changed in cups (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → High
milestone: none → oneiric-updates
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.0-13

---------------
cups (1.5.0-13) unstable; urgency=low

  [ Till Kamppeter ]
  * debian/patches/ipp-patch-r8950+.patch: Revert the IPP backend to the state
    of CUPS 1.4.x, as the 1.5.x versiuon has major regressions (LP: #877958,
    LP: #879625, LP: #881843, LP: #883585, Closes: #638521, CUPS STR #3966,
    CUPS STR #3967). This patch will get removed as soon as upstream has fixed
    all these regressions. As upstream did not announce any new features for
    the IPP backend in the release notes for 1.5.x, we assume that with this
    step no features will get lost.
  * debian/patches/dont-send-malformed-dbus-messages.patch: Do not send D-Bus
    notifications with too few parameters when there are parameters which
    cannot be added to the D-Bus request, especially invalid UTF-8 strings.
    This made gnome-session-daemon crash (LP: #893676, CUPS STR #3984).
  * debian/local/filters/cpdftocps: The cpdftocps filter (used for PostScript
    printers and for drivers with PPDs which are not PDF-aware) did not
    recognize the duplex setting correctly, making duplex not working on
    many common printers (LP: #897723).
  * debian/local/filters/cpdftocps: Cleaned up the header comments.

  [ Martin-Éric Racine ]
  * [cups.postrm]: purge /etc/cups/ssl/server.[crt|key] and /etc/cups/ssl.

  [ Martin Pitt ]
  * debian/compat: Bump from 5 to 9, this apparently was forgotten in the
    Multi-Arch transition.
 -- Martin Pitt <email address hidden> Fri, 02 Dec 2011 11:05:51 +0100

Changed in cups (Ubuntu):
status: Fix Committed → Fix Released
Changed in cups (Debian):
status: New → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello HPO, or anyone else affected,

Accepted cups into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
David Charypar (charypar) wrote :

I tested the new Ubuntu cups package 1.5.0-8ubuntu6. It works for me, the printer now operates as expected.

Thank you, Till, Robert, and anyone else involved for your help.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

David, thank you for testing. I will mark the bug as verified now.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Robert Bradley (robert-bradley1) wrote :

This has been filed upstream at http://www.cups.org/str.php?L3974, which covers both this bug and #883585. Unlike bug #883585, the bug here seems to be fixed by the IPP backend downgrade in 1.5.0-8ubuntu6.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups - 1.5.0-8ubuntu6

---------------
cups (1.5.0-8ubuntu6) oneiric-proposed; urgency=low

  * debian/patches/ipp-patch-r8950+.patch: Revert the IPP backend to the state
    of CUPS 1.4.x, as the 1.5.x versiuon has major regressions (LP: #877958,
    LP: #879625, LP: #881843, LP: #883585, Closes: #638521, CUPS STR #3966,
    CUPS STR #3967). This patch will get removed as soon as upstream has fixed
    all these regressions. As upstream did not announce any new features for
    the IPP backend in the release notes for 1.5.x, we assume that with this
    step no features will get lost.
  * debian/patches/dont-send-malformed-dbus-messages.patch: Do not send D-Bus
    notifications with too few parameters when there are parameters which
    cannot be added to the D-Bus request, especially invalid UTF-8 strings.
    This made gnome-session-daemon crash (LP: #893676, CUPS STR #3984).
  * debian/local/filters/cpdftocps: The cpdftocps filter (used for PostScript
    printers and for drivers with PPDs which are not PDF-aware) did not
    recognize the duplex setting correctly, making duplex not working on
    many common printers (LP: #897723).
  * debian/local/filters/cpdftocps: Cleaned up the header comments.
 -- Till Kamppeter <email address hidden> Tue, 29 Nov 2011 21:49:41 +0100

Changed in cups (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.