cups exits with "No valid Listen or Ports lines"

Bug #429138 reported by Jeffrey Baker on 2009-09-14
40
This bug affects 10 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cups

In cups 1.4.0-5 on Karmic x86-64, upgraded from Jaunty, I find that cups no longer starts. It exits with signal 15 after putting this in error_log:

X [13/Sep/2009:18:25:24 -0700] No valid Listen or Port lines were found in the configuration file!

After looking in /etc, I found that cupsd.conf is empty. I purged cups and reinstalled it, and now cupsd.conf has contents. I have never edited cupsd.conf. Therefore I think there's some kind of error in the upgrade procedure which leaves cupsd installed but not able to start.

Workaround is to purge and reinstall cups, or move cupsd.conf.default to cupsd.conf

Architecture: amd64
DistroRelease: Ubuntu 9.10
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: OEM OEM
Package: cups 1.4.0-5
PackageArchitecture: amd64
Papersize: letter
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: root=UUID=0beb92b5-5d52-4cb8-a5a5-f15e838fa0db ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/04/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: 132-BL-E758
dmi.board.vendor: EVGA
dmi.board.version: Tylersburg
dmi.chassis.type: 3
dmi.chassis.vendor: OEM
dmi.chassis.version: OEM
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd03/04/2009:svnOEM:pnOEM:pvrOEM:rvnEVGA:rn132-BL-E758:rvrTylersburg:cvnOEM:ct3:cvrOEM:
dmi.product.name: OEM
dmi.product.version: OEM
dmi.sys.vendor: OEM

tags: added: apport-collected

The same happened on my computer too. It was a clean installation of karmic alpha 5 and then a full update to the current packages. CUPS worked right after installation, but stopped to work after update. The config file was empty. I could solve it by purging cups and installing it again.

Changed in cups (Ubuntu):
status: New → Confirmed
VladNistor (vladnistor) wrote :

I copied a standard config file and it worked after that. It seems that particular update caused the conf file to become empty.

Dereck Wonnacott (dereck) wrote :

This worked for me:

dereck@yakisoba:~$ sudo cp /etc/cups/cupsd.conf.default /etc/cups/cupsd.conf
dereck@yakisoba:~$ sudo /etc/init.d/cups restart
 * Restarting Common Unix Printing System: cupsd [ OK ]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers