evince can't print an pdf I made with LATex.

Bug #373796 reported by deabreu.ronaldo on 2009-05-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: evince

Evince does not print a PDF document I created using LATex. Evince reports that "too many failed attempts to print". However, I was able to print it using Adobe Acrobat Reader. And printing test page is working well. My printer is a Lexmark E120 conected under a USB port. The problem occurred using the printer's driver and the Generic CUPS driver.

Thanks.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/evince
Package: evince 2.26.1-0ubuntu1
ProcEnviron:
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.28-11-generic i686

affects: evince (Ubuntu) → cups (Ubuntu)

Can you please attach the mentioned pdf document that fails.

Please also run the following command on a terminal for adding some useful printing related debugging info to this bug:
apport-collect -p cups 373796

Please provide your cups error_log after trying to print the mentioned pdf as described here: https://wiki.ubuntu.com/DebuggingPrintingProblems#cupserrorlog

Changed in cups (Ubuntu):
status: New → Incomplete
Nick Østergaard (nickoe) wrote :

I got the same problem in ubuntu 9.04, but now I can't recreate the problem. But am not on ubuntu anymore, on Archlinux with evince 2.26.2.

Dear Mr. De Vuyst,

I believe this error has ocurred with all other pdf document I have tried to
print. I had to sell my printer recently, so I am unable to test the
correction you suggested.

By the time I acquire a new printer, I shall try your suggestion. I
appreciate very much your concern and help.

Yours,

Ronaldo Alves de Abreu.

2009/7/28 Pascal De Vuyst <email address hidden>

> Can you please attach the mentioned pdf document that fails.
>
> Please also run the following command on a terminal for adding some useful
> printing related debugging info to this bug:
> apport-collect -p cups 373796
>
> Please provide your cups error_log after trying to print the mentioned
> pdf as described here:
> https://wiki.ubuntu.com/DebuggingPrintingProblems#cupserrorlog
>
> ** Changed in: cups (Ubuntu)
> Status: New => Incomplete
>
> --
> evince can't print an pdf I made with LATex.
> https://bugs.launchpad.net/bugs/373796
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “cups” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: evince
>
> Evince does not print a PDF document I created using LATex. Evince reports
> that "too many failed attempts to print". However, I was able to print it
> using Adobe Acrobat Reader. And printing test page is working well. My
> printer is a Lexmark E120 conected under a USB port. The problem occurred
> using the printer's driver and the Generic CUPS driver.
>
> Thanks.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> ExecutablePath: /usr/bin/evince
> Package: evince 2.26.1-0ubuntu1
> ProcEnviron:
> LANG=pt_BR.UTF-8
> SHELL=/bin/bash
> SourcePackage: evince
> Uname: Linux 2.6.28-11-generic i686
>

--
Ronaldo Alves de Abreu

Please check your /etc/cups/printers.conf file, does it have the following line in it?
AuthInfoRequired username,password
Try changing it to:
AuthInfoRequired none

Dear Mr. De Vuyst,

The refered lines do not exist on the printers.conf file on my computer.
Would it be the cause of this problem?

I am sending to you the result of a cat command applied on the file.
# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2009-07-14 04:16
<DefaultPrinter Lexmark-E120>
Info Lexmark E120
DeviceURI usb://Lexmark/E120
State Stopped
StateMessage Unplugged or turned off
StateTime 1247555795
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>
<Printer Stylus-CX4900>
Info EPSON Stylus CX4900
Location ronaldo-laptop
DeviceURI usb://EPSON/Stylus%20CX4900
State Stopped
StateMessage Unplugged or turned off
StateTime 1247481715
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

I hope it to be of some use to you.
Thank you, again, for the interest on the case.

Your,

Ronaldo Alves de Abreu.

Em Sex, 2009-08-07 às 09:23 +0000, Pascal De Vuyst escreveu:
> Please check your /etc/cups/printers.conf file, does it have the following line in it?
> AuthInfoRequired username,password
> Try changing it to:
> AuthInfoRequired none
>

Till Kamppeter (till-kamppeter) wrote :

deabreu.ronaldo, can you follow the instructions in the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Thanks.

pinzia, the issue described in bug 463059 is already fixed. If the problem is caused performance problems of Ghostscript, see bug 668800.

This problem is probably caused by both bug 680628 and bug 668800.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers